Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XBMC-9999 requiring FFmpeg-9
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 192

PostPosted: Tue May 14, 2013 7:02 pm    Post subject: XBMC-9999 requiring FFmpeg-9 Reply with quote

I have been waiting to see if this requirement goes away but it's been this way for a bit. (ignore the x-portage , thats me playing around with the ebuild, below is the unedited gentoo one)

Code:
Calculating dependencies... done!
[ebuild  N    *] media-video/libav-9999:0/9  USE="3dnow 3dnowext X aac alsa bzip2 encode gpl hardcoded-tables ieee1394 jpeg2k mmx mmxext mp3 sdl ssl theora threads truetype v4l vdpau vorbis x264 xvid zlib (-altivec) -amr -avx -bindist -cdio -cpudetection -custom-cflags -debug -doc -faac -fdk -frei0r -gsm -jack (-neon) -network -openssl -opus -oss -pic -pulseaudio -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -tools -vaapi (-vis) -vpx" 0 kB
[ebuild     U #] virtual/ffmpeg-9 [0.10.3] USE="X encode jpeg2k mp3 sdl theora threads truetype vdpau x264 -gsm -opus% -speex -vaapi" 0 kB
[ebuild   R   *] media-tv/xbmc-9999::x-portage  USE="X alsa css fishbmc java opengl rtmp samba sdl sse sse2 usb vdpau webserver xrandr -airplay (-altivec) -avahi -bluetooth -bluray -caps -cec -debug -gles -goom -joystick -midi -mysql (-neon) -nfs -profile -projectm -pulseaudio -pvr -rsxs -sftp -udev -upnp -vaapi" PYTHON_SINGLE_TARGET="python2_7%* -python2_6%" PYTHON_TARGETS="python2_7%* -python2_6%" 0 kB
[blocks B      ] media-video/ffmpeg ("media-video/ffmpeg" is blocking media-video/libav-9999)

Total: 3 packages (1 upgrade, 1 new, 1 reinstall), Size of downloads: 0 kB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

virtual/ffmpeg:0

  (virtual/ffmpeg-0.10.3::gentoo, installed) pulled in by
    =virtual/ffmpeg-0.10.3 required by (net-misc/minidlna-1.0.25-r1::gentoo, installed)
    (and 3 more with the same problem)

  (virtual/ffmpeg-9::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/ffmpeg-9[encode] required by (media-tv/xbmc-9999::x-portage, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by virtual/ffmpeg-9
# required by media-tv/xbmc-9999::x-portage[vdpau]
# required by xbmc (argument)
=media-video/libav-9999 **

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by media-tv/xbmc-9999::x-portage[vdpau]
# required by xbmc (argument)
# /usr/portage/profiles/package.mask:
# Diego Elio Pettenò <flameeyes@gentoo.org> (14 Nov 2012)
# Masked for testing as some packages fail.
# See bug #443230 for tracking the progress
=virtual/ffmpeg-9

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


Does XBMC-9999 really require ffmpeg-9? Looks like it masked as well as other stuff already requiring ffmpeg-10. Also adding the "=media-video/libav-9999 **" changes nothing.
Back to top
View user's profile Send private message
schorsch_76
Apprentice
Apprentice


Joined: 19 Jun 2012
Posts: 216

PostPosted: Wed May 15, 2013 6:58 am    Post subject: Reply with quote

I suggest, as it is a live ebuild, to put at /etc/portage/env/ a file called xbmc-9999.conf with the following content
Code:

EGIT_BRANCH="frodo"

See [2]

Add the file /etc/portage/package.env the following content
Code:

media-tv/xbmc-9999 xbmc-9999.conf


So you can select the branch or the tag in the live ebuild. Hope that helps.

schorsch
[1] http://wiki.gentoo.org/wiki//etc/portage/env
[2] http://devmanual.gentoo.org/eclass-reference/git-2.eclass/index.html

EDIT: eclass git-2 added
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 192

PostPosted: Thu May 16, 2013 6:23 am    Post subject: Reply with quote

Unfortunately no as it has nothing to do with the original problem of the ebuild requiring ffmpeg v9.
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2335

PostPosted: Thu May 16, 2013 11:24 am    Post subject: Re: XBMC-9999 requiring FFmpeg-9 Reply with quote

Saundersx wrote:
Does XBMC-9999 really require ffmpeg-9? Looks like it masked as well as other stuff already requiring ffmpeg-10. Also adding the "=media-video/libav-9999 **" changes nothing.

Saundersx ... it requires both virtual/ffmpeg-9 and media-video/ffmpeg-1.2.1 both of which are currently masked. I assume that this is a case in which libav isn't supported as an option as virtual/ffmpeg-9 could be provided by either >=media-video/libav-9 or >=media-video/ffmpeg-1.1. So it looks like your options are limited as the only way forward is to replace libav with ffmpeg (but you may have some issues with net-misc/minidlna) to do this you will need to unmask both the virtual and ffmpeg:

/etc/portage/package.unmask
Code:
=virtual/ffmpeg-9
media-video/ffmpeg

/etc/portage/package.accept_keywords
Code:
=media-video/ffmpeg-1.2.1
=virtual/ffmpeg-9

I'm currently using ffmpeg-1.2.1 without issues, the mask seems to be mostly in place as not all packages will build/work with it.

HTH & best ... khay
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 192

PostPosted: Fri May 17, 2013 2:34 am    Post subject: Reply with quote

I unmasked ffmpeg but it failed to compile until I added this to the ebuild

Code:
   
    sed -i \
        -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' \
        lib/libdvd/libdvdcss/configure.ac || die

    # some dirs ship generated autotools, some dont


Can't say whether all is ok yet, have to play with it a bit.
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2335

PostPosted: Fri May 17, 2013 1:26 pm    Post subject: Reply with quote

Saundersx wrote:
I unmasked ffmpeg but it failed to compile until I added this to the ebuild

Saundersx ... that may be as you have automake-1.13 installed (guess), it wasn't necessary here.

best ... khay
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 192

PostPosted: Fri May 17, 2013 4:09 pm    Post subject: Reply with quote

khayyam wrote:
Saundersx wrote:
I unmasked ffmpeg but it failed to compile until I added this to the ebuild

Saundersx ... that may be as you have automake-1.13 installed (guess), it wasn't necessary here.

best ... khay


That's more then likely the culprit. Hopefully this helps someone. Also xbmc appears to run work fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum