Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Need tarball overlay for kde-4.9.5 [NOT POSSIBLE]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 734
Location: US-FL-EST

PostPosted: Thu May 16, 2013 10:30 pm    Post subject: Need tarball overlay for kde-4.9.5 [NOT POSSIBLE] Reply with quote

I made the mistake of upgrading all my installations of KDE from 4.9.5 to 4.10.3 on all my systems at one shot.

KDE splash doesn't run.
Plasma crashes.
Konqueror crashes repeatedly.
System tray doesn't run.

Yada-yada-yada.

I've read several of the pertinent reported bugs at kde.org and I'd like very much to go back to kde-4.9.5. Really.

While I still have all of the kde-4.9.5 binary installation packages I've previously created, I don't have a valid overlay for kde-base and kde-misc for 4.9.5. I'm not real keen on manually looking for and downloading each 4.9.5 kde package overly and I'd be really interested in an existing set I can copy to /usr/local/portage/kde-base and /usr/local/portage/kde-misc.

Fortunately, I have several other WMs installed so I'm not completely dead. I'm using 'xfce' at the moment. ;)
_________________
People whom think M$ is mediocre, don't know the half of it.
Back to top
View user's profile Send private message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 734
Location: US-FL-EST

PostPosted: Sun May 26, 2013 2:25 am    Post subject: Reply with quote

I did have one PC at an external site which still had KDE-4.9.5 installed. I received the PC back today and was able to copy off the kde-base and kde-misc packages to my test system's /usr/local/portage overlay. I also copied down the stabilization list from bug# 462890.

I ran into several problems:
  • There were several kde-base/misc packages which I have installed which were not on the stabilization list. The related dependencies were also not in the stabilization list which meant I kept having to go back and forth researching which other earlier versions of non kde-base/misc dependencies I needed to put into my local overlay in order to match requirements for the kde-4.9.5 packages I wanted to regress to.

  • There has also been a transition where all the 'qt' packages have been moved from /x11-libs/qt-* to /dev-qt/. This wouldn't be so bad but apparently I performed the emerge --sync on the system with kde-4.9.5 still installed while this transition was taking place. The net result is that most of my packages with 'qt3support' as a dependency point at /x11-libs/qt-qt3support-4.8.4 while several packages, including kdelibs-4.9.5, point to /dev-qt/qt3support-4.8.4.

  • There were other 'qt' based packages which were also impacted by the 'qt' portage tree re-location including 'razorqt'.

These issues basically made it impossible for me to regress from kde-4.10.3 to kde-4.9.5.

For now, I'm using 'xfce' and 'razorqt' until the new version of kde is updated such that plasma stops crashing during my kde login.
_________________
People whom think M$ is mediocre, don't know the half of it.
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2379
Location: Hilbert space

PostPosted: Sun May 26, 2013 6:33 am    Post subject: Reply with quote

AFAIK, all the ebuilds I sent you by mail are ok with regards to the /x11-libs/qt-* -> /dev-qt/ references.
Please list the packages you are concerned with and which are not included in the tarball.
_________________
Back to top
View user's profile Send private message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 734
Location: US-FL-EST

PostPosted: Tue May 28, 2013 2:07 am    Post subject: Reply with quote

aCOSwt wrote:
AFAIK, all the ebuilds I sent you by mail are ok with regards to the /x11-libs/qt-* -> /dev-qt/ references.
Please list the packages you are concerned with and which are not included in the tarball.

First, I owe you an apology for not being responsive. For a variety of less than optimal reasons, I missed your email!

I have it now and loaded it into my /usr/local/portage overlay. I tried:
Code:
# emerge -puNDv @world
using the referenced 4.10.1 stabilization list {converted to mask list as instructed} in the [solved] How to stay with KDE-4.9.5? thread.

The proposed emerge list wanted to install kde-4.10.0. Here is a snippet of the results:
Code:
[ebuild     UD ] kde-base/kdeedu-meta-4.9.5:4::local [4.10.3:4::gentoo] USE="(-aqua)" 0 kB
[ebuild     UD ] kde-base/korganizer-4.10.0:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/knode-4.10.0:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/knotes-4.10.0:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/akregator-4.10.0:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/kaddressbook-4.10.0:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/kjots-4.10.0:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/ktimetracker-4.10.0:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/kdebase-meta-4.9.5:4::local [4.10.3:4::gentoo] USE="wallpapers (-aqua)" 0 kB
[ebuild     UD ] kde-base/kmail-4.10.0:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug {-test}" 0 kB
[ebuild     UD ] kde-base/kdepim-meta-4.10.0:4::local [4.10.3:4::gentoo] USE="nls (-aqua)" 0 kB
[ebuild     UD ] kde-base/kdeartwork-kscreensaver-4.10.0:4::local [4.10.3:4::gentoo] USE="eigen kexiv2 opengl xscreensaver (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/kdeartwork-meta-4.10.0:4::local [4.10.3:4::gentoo] USE="(-aqua)" 0 kB
[ebuild     UD ] kde-base/kde-meta-4.10.0:4::local [4.10.3:4::gentoo] USE="accessibility nls sdk semantic-desktop (-aqua)" 0 kB
[blocks B      ] kde-base/libkleo:4 ("kde-base/libkleo:4" is blocking kde-base/kdepim-common-libs-4.10.3)
[blocks B      ] kde-base/libkdepim:4 ("kde-base/libkdepim:4" is blocking kde-base/kdepim-common-libs-4.10.3)

Total: 179 packages (177 downgrades, 2 new), Size of downloads: 628,504 kB
Conflict: 2 blocks (2 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

kde-base/oxygen-icons:4

  (kde-base/oxygen-icons-4.10.0::local, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (kde-base/oxygen-icons-4.10.3::gentoo, installed) pulled in by
    >=kde-base/oxygen-icons-4.10.3:4[aqua=] required by (kde-base/pykde4-4.10.3::gentoo, installed)
    (and 155 more with the same problem)

I left the stabilization list mask in place and added a second mask list as instructed by ppurka in the same thread:
Code:
eix -ICc kde- --only-names | sed -e 's/^/>=/' -e 's/$/-4.10/' > /etc/portage/package.mask/kde.mask

I've posted the proposed results at pastebin. The pastebin post was done as guest and has a lifespan of 1 month. I'm including an equal snippet similar to the above snippet for when the pastebin post goes away:
Code:
[ebuild     UD ] kde-base/kdebase-meta-4.9.5:4::local [4.10.3:4::gentoo] USE="wallpapers (-aqua)" 0 kB
[ebuild     UD ] kde-base/knode-4.9.5:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/knotes-4.9.5:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/kaddressbook-4.9.5:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/akregator-4.9.5:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/kjots-4.9.5:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/ktimetracker-4.9.5:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/kmail-4.9.5:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug {-test}" 0 kB
[ebuild     UD ] kde-base/kdepim-meta-4.9.5:4::local [4.10.3:4::gentoo] USE="nls (-aqua)" 0 kB
[ebuild     UD ] kde-base/kdeartwork-kscreensaver-4.9.5:4::local [4.10.3:4::gentoo] USE="eigen kexiv2 opengl xscreensaver (-aqua) -debug" 0 kB
[ebuild     UD ] kde-base/kdeartwork-meta-4.9.5:4::local [4.10.3:4::gentoo] USE="(-aqua)" 0 kB
[ebuild  N     ] kde-base/printer-applet-4.9.5:4::local  USE="handbook (-aqua)" 0 kB
[ebuild  N     ] kde-base/system-config-printer-kde-4.9.5:4::local  USE="(-aqua)" 0 kB
[uninstall     ] kde-base/print-manager-4.10.3:4  USE="(-aqua) -debug"
[blocks b      ] kde-base/printer-applet:4 ("kde-base/printer-applet:4" is blocking kde-base/print-manager-4.10.3)
[blocks b      ] kde-base/system-config-printer-kde:4 ("kde-base/system-config-printer-kde:4" is blocking kde-base/print-manager-4.10.3)
[ebuild     UD ] kde-base/kdeadmin-meta-4.9.5:4::local [4.10.3:4::gentoo] USE="cups%* (-aqua)" 0 kB
[ebuild     UD ] kde-base/kdeutils-meta-4.9.5:4::local [4.10.3:4::gentoo] USE="cups (-aqua) -floppy -lirc" 0 kB
[ebuild     UD ] kde-base/kde-meta-4.9.5:4::local [4.10.3:4::gentoo] USE="accessibility nls sdk semantic-desktop (-aqua)" 0 kB
[blocks B      ] kde-base/libkleo:4 ("kde-base/libkleo:4" is blocking kde-base/kdepim-common-libs-4.10.3)
[blocks B      ] kde-base/libkdepim:4 ("kde-base/libkdepim:4" is blocking kde-base/kdepim-common-libs-4.10.3)

Total: 242 packages (238 downgrades, 4 new, 1 uninstall), Size of downloads: 272,862 kB
Conflict: 4 blocks (2 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

kde-base/oxygen-icons:4

  (kde-base/oxygen-icons-4.10.3::gentoo, installed) pulled in by
    >=kde-base/oxygen-icons-4.10.3:4[aqua=] required by (kde-base/kdesdk-misc-4.10.3::gentoo, installed)
    (and 59 more with the same problem)

  (kde-base/oxygen-icons-4.9.5::local, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

kde-base/kdelibs:4

  (kde-base/kdelibs-4.10.3-r2::gentoo, installed) pulled in by
    >=kde-base/kdelibs-4.10.3:4[aqua=,handbook] required by (kde-base/kompare-4.10.3::gentoo, installed)
    (and 90 more with the same problem)

  (kde-base/kdelibs-4.9.5::local, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

I haven't yet tried this without the --pretend option.

I do have prebuilt 4.9.5 binary packages. When I try:
Code:
emerge -gpvuND @world
I get:
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The following binary packages have been ignored due to non matching USE:

    =kde-base/plasma-workspace-4.9.5 -google-gadgets
    =kde-base/oxygen-icons-4.9.5 -bindist

NOTE: The --binpkg-respect-use=n option will prevent emerge
      from ignoring these binary packages if possible.
      Using --binpkg-respect-use=y will silence this warning.

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-qt/qt3support-4.7.0:4[accessibility,kde]".
!!! One of the following packages is required to complete your request:
- dev-qt/qt3support-4.8.4::gentoo (Missing IUSE: kde)
- dev-qt/qt3support-4.8.4::gentoo (Missing IUSE: kde)
(dependency required by "sys-auth/polkit-kde-agent-0.99.0" [binary])
(dependency required by "kde-base/kdelibs-4.9.5" [binary])
(dependency required by "kde-base/klinkstatus-4.9.5" [binary])
(dependency required by "kde-base/kdewebdev-meta-4.9.5" [binary])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Apparently it's some of my pre-built binary packages which are a bit confused as to which version of qt3support they want to use. I can probably remove the confused binaries from /usr/local/portage/packages/ and let those packages be rebuilt from scratch. The list of packages it would install doesn't appear because of the ".. no ebuilds built with USE flags .." message.

I'm open to advice and suggestions.

As an aside, one of the things that disturbs me about the 'stabilization list' and the process of marking 4.10.1 stable is the incompleteness of the list. The stabilization list only had 179 of my kde 4.9.5 --> 4.10.1 related upgrade packages listed. Yet I had 242 packages installed which were subject to the upgrade and I know that list is not complete both as I don't have all kde packages installed and there are kde related packages which don't fall under kde-base/misc.
_________________
People whom think M$ is mediocre, don't know the half of it.
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2379
Location: Hilbert space

PostPosted: Tue May 28, 2013 5:40 am    Post subject: Reply with quote

dufeu wrote:
The proposed emerge list wanted to install kde-4.10.0. Here is a snippet of the results:[code][ebuild UD ]...
[ebuild UD ] kde-base/korganizer-4.10.0:4::local [4.10.3:4::gentoo] USE="handbook kontact (-aqua) -debug" 0 kB...

You are correct. The mask is OK but portage prefers downgrading to 4.10.0
dufeu wrote:
I left the stabilization list mask in place and added a second mask list as instructed by ppurka in the same thread:[code]eix -ICc kde- --only-names | sed -e 's/^/>=/' -e 's/$/-4.10/' > /etc/portage/package.mask/kde.mask[/code]

Keep the stabilization list mask in place but remove /etc/portage/package.mask/kde.mask

- Portage prefers downgrading some of the packages to 4.10.0 because they are > 4.9.5 and apparently made available for use.
- Because 4.10.0 packages are *not* stable, this must be because you explicitely accepted tildarch in your /etc/portage/package.keywords
- Because 4.9.5 packages are stable, remove from your system what you did in order to instruct it to accept tildarch for kde* packages, that should gracefully force portage to ignore 4.10.0
- retry your emerge and post the remaining problems.
_________________
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum