Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Trouble on First gentoo install. X-org server deps
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
SquidGuy
n00b
n00b


Joined: 16 May 2013
Posts: 2
Location: the Bleeding Edge

PostPosted: Thu May 16, 2013 5:10 pm    Post subject: [Solved] Trouble on First gentoo install. X-org server deps Reply with quote

This is very possibly because I'm totally new to the world of Gentoo, but I managed to trudge my way through a basic install and set up users. Now, I'm having difficulty setting up X-org. I have tried:

emerge -pv xorg-drivers

and afterward, I'm informed that "the following USE changes are necessary to proceed:
#required by media-libs/mesa-9.0.1
#required by x11-base/xorg-server-1.13.4[-minimal]
#required by x11-drivers/xf86-input-synaptics-1.6.2-r1
#required by xorg-drivers (argument)
>=dev-libs/libxm12-2.9.0-r2 python

I'm under the assumption that I've failed to provide the correct USE flags, but I'm obviously missing something in the process. Walk me through this one guys, and I'll hopefully gather what part of the process I'm not getting.


Last edited by SquidGuy on Thu May 16, 2013 7:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31909
Location: 56N 3W

PostPosted: Thu May 16, 2013 5:46 pm    Post subject: Reply with quote

SquidGuy,

Welcome to Gentoo.

You get a good default set of USE flags bu setting the right profile. Play with
Code:
eselect profile

You should choose a profile ending in /dektop, or desktop/kde or /desktop/gnome if you want to use KDE or Gnome.

This may not solve all of your issues.

The message means that to build the packages
Code:
#required by media-libs/mesa-9.0.1
#required by x11-base/xorg-server-1.13.4[-minimal]
#required by x11-drivers/xf86-input-synaptics-1.6.2-r1
#required by xorg-drivers (argument)

>=dev-libs/libxm12-2.9.0-r2 python
Using dev-libs/libxm12-2.9.0-r2 or later, that package must be built with python support and its not at the moment.

After you have checked your profile, if this problem persists, than add
Code:
>=dev-libs/libxm12-2.9.0-r2 python
to etc/portage/package.use, so that the python USE flag applies to this specific package only.
Code:
man portage
will tell you all about the files in /etc/portage
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
SquidGuy
n00b
n00b


Joined: 16 May 2013
Posts: 2
Location: the Bleeding Edge

PostPosted: Thu May 16, 2013 7:09 pm    Post subject: Reply with quote

Thanks so much, the eselect did make a huge difference in the USE flags, setting me up to run into my next set of issues. This has been my first non-plug n' play Linux, though, so I'm going to walk myself back through the steps in the handbook before I actually have questions that just RTFM won't fix.

Regards,
SG
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31909
Location: 56N 3W

PostPosted: Thu May 16, 2013 8:19 pm    Post subject: Reply with quote

SquidGuy,

Changing your profile has changed the USE flags you have selected.
To make them take effect, you need to rebuild the affected packages.

Code:
emerge --sync
emerge -uDNav world
is a good start.

Read the emerge man page to see what those options do.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Deathwing00
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4078
Location: Barcelona, Spain

PostPosted: Thu May 16, 2013 8:26 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Desktop Environments.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum