Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
audiocd:/ bringt den KDE Desktop zum laggen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1710
Location: Heidelberg - Germany

PostPosted: Mon May 13, 2013 11:52 am    Post subject: audiocd:/ bringt den KDE Desktop zum laggen Reply with quote

Mir ist aufgefallen, dass beim Rippen von AudioCDs den K - Desktop zum Ruckeln bringt. Das Arbeiten damit wird sehr unkonfortabel. Ein Blick auf die Prozessliste zeigt, dass der X - Server Prozess bis an den Anschlag CPU Leistung verbraucht. Mir ist schleierhaft, wie sich das ausgerechnet auf den xorg-server auswirkt.
Mein LG Laufwerk ist eh gähnend langsam und ich sehne mich nach meinem alten Ultraplex SCSI Laufwerk zurück.

Hat jemand etwas ähnliches beobachtet? Eine workaround, der das Rippen (noch-) langsamer macht, aber dafür die Bedienbarkeit des Desktops aufrechterhält, wäre nicht schlecht ;)
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4116

PostPosted: Mon May 13, 2013 3:13 pm    Post subject: Reply with quote

ich verwende soundKonverter zum rippen von Audio cds.
eventuell wäre das ein ersatzt statt dem audiocd:/ kio-slave.
Zumindestens könntes du damit testen ob es am kio-slave liegt oder ein eher generelles problem ist.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2289
Location: Germany

PostPosted: Mon May 13, 2013 4:38 pm    Post subject: Reply with quote

Hm, audiocd:/ kio-slave sollte normal einwandfrei funktionieren, hier tut es das (getestet unter kde-4.10.3 audiocd --> .flac mit nahezu null CPU-Auslastung).

Ein blinder Schuss ins Blaue: Wenn X dabei die CPU so hoch auslastet wie beschrieben, dann könnte es eventuell an dem kreiselnden Benachrichtigungs-Symbol im Systemtray liegen. Falls dem so ist, dann ist der Fehler vermutlich eher in einen inkompatiblen Theme, und oder beim Grafiktreiber, oder deren Konfiguration zu suchen.
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 566

PostPosted: Tue May 14, 2013 4:22 pm    Post subject: Re: audiocd:/ bringt den KDE Desktop zum laggen Reply with quote

Hi
Erdie wrote:
Mir ist aufgefallen, dass beim Rippen von AudioCDs den K - Desktop zum Ruckeln bringt. Das Arbeiten damit wird sehr unkonfortabel. Ein Blick auf die Prozessliste zeigt, dass der X - Server Prozess bis an den Anschlag CPU Leistung verbraucht. Mir ist schleierhaft, wie sich das ausgerechnet auf den xorg-server auswirkt.
Mein LG Laufwerk ist eh gähnend langsam und ich sehne mich nach meinem alten Ultraplex SCSI Laufwerk zurück.

Hat jemand etwas ähnliches beobachtet? Eine workaround, der das Rippen (noch-) langsamer macht, aber dafür die Bedienbarkeit des Desktops aufrechterhält, wäre nicht schlecht ;)

Ich kenne so etwas ähnliches seit vielen Jahren mit Audiocds unter KDE. Ich habe bei mir SCSI Cdrom/Brenner Laufwerken. Es wird
beim mir in einer endlos Schleife der SCIS Bus resettet bei Audiocds und es reagiert kaum noch etwas. Mit dmesg konnte ich das feststellen. Workaround
habe ich nie gefunden das ich KDE und Programme nie oder nur sehr selten nutze und habe auch nicht weiter gesucht. Es hat aber auch bei der eine oder
anderen KDE version mal funktioniert was aber eine sehr seltene Ausnahme war.

MfG
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1710
Location: Heidelberg - Germany

PostPosted: Wed May 15, 2013 2:20 pm    Post subject: Reply with quote

Ich habe mal testweise in der Konsole mit cdparanoia gerippt. Da war es ähnlich, aber nicht ganz so extrem. Allerdings muß ich das nochmal testen weil ich zu dem Zeitpunkt vorher eine Kdelibs - Update gemacht hatte ohne neu zu starten. Das ist mir erst später in den Sinn gekommen. Vielleicht ist da ein Konflikt aufgetreten.

Warum mein LG Laufwerk CDs nur mit 1-facher Geschwindigkeit rippt, verstehe ich nicht. Ich hatte vorher ein anderes, das war genauso langsam und mir dann das LG gekauft weil mit dem anderen cdrdao nicht zuverlässig lief. Sind die "modernen" DVD Brenner alle so langsam beim Rippen? Hätte ich bloß meine Plextors nicht mit dem alten Rechner weggeschmissen. Das ging das Rippen mit 32-fachem Tempo - und das fehlerfrei!
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1710
Location: Heidelberg - Germany

PostPosted: Thu May 16, 2013 11:44 am    Post subject: Reply with quote

Das Problem scheint sich jetzt in Luft aufgelöst zu haben, jetzt scheint es zu gehen .. hmm .. Vielleicht lag es an den KDElibs.
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum