Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Help installing HD3850 AGP with fglrx
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Tue May 14, 2013 6:09 pm    Post subject: Help installing HD3850 AGP with fglrx Reply with quote

Hi folks,

I have some difficulties to run a config with a HD3850 AGP and fglrx drivers. When i start X, it stays at blank screen and i have to do a hard reset (cannot switch terminal).

I know this card is quite exotic. I've installated ati legacy driver and right xorg server version as said here. Previously, i had a nVidia card, but i carefully deleted use flag, packages and nvidia.ko. Xorg.0.log doesn't contain any "fatal" error, card seems to be well detected by the driver as i'm going to show you. I do what it needs with eselect (opengl and xvmc).

Here my Xorg.0.log :
http://pastebin.com/XcggDdDX

my make.conf :
http://pastebin.com/Cwyzc9ai

My kernel log :
http://pastebin.com/8AkRtHmF

And my .config kernel :
http://pastebin.com/iU293WsJ

And here my xorg.conf :
Code:

Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier  "aticonfig-Monitor[0]-0"
   Option       "VendorName"         "Asus"
   Option       "ModelName"          "VS228H"
   Option       "DPMS"               "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
   #Option      "MaxGARTSize"        "512"
   Option      "UseFastTLS"         "0"
   Option      "UseInternalAGPGART" "no"
   Option      "BusType"            "AGP"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


Thanks for any help.
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Wed May 15, 2013 6:02 pm    Post subject: Reply with quote

Updating some infos.
Back to top
View user's profile Send private message
xming
Guru
Guru


Joined: 02 Jul 2002
Posts: 434

PostPosted: Wed May 15, 2013 7:08 pm    Post subject: Reply with quote

Same card here, ditched catalyst years ago, using r600g makes the life a lot easier, you can use up to date kernel and xorg, have you tried to switch to OSS radeon driver?
_________________
http://wojia.be
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Wed May 15, 2013 7:26 pm    Post subject: Reply with quote

I haven't try with radeon on gentoo, but i suppose it will run because i have tested with a live CD (Linux Mint). I'm not going to troll but i'd like to use with fglrx, probably with radeon driver in parallel. Anyone success to use fglrx legacy with this card ?
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Mon May 20, 2013 11:11 pm    Post subject: Reply with quote

OK, some news. I disabled all IOMMU options as i read here, because i have an nForce3 chipset. I have disabled agpgart too, and after try to boot up my Gentoo. X starts with showing my desktop (Xfce) before it hangs up. Consulting Xorg.0.log, it says it can neither initialize AGP port nor DRI, so no 2D/3D acceleration. Activating once again agpgart in kernel, i again have blank screen. It seems to have conflict on AGP. Changing the option "UseInternalAGPGART" in xorg.conf doesn't help anything. I keep my way.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum