Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solve]startx problem!nvidia doesn't support server version?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
haleh
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 127

PostPosted: Sat May 11, 2013 8:39 pm    Post subject: [solve]startx problem!nvidia doesn't support server version? Reply with quote

today I was updating my system with emerge -autvND world that this updates x11-base/xorg-server to 1.14.1 and couldn't update nvidia driver because of some restriction of nvidia website !I should manually update this !any way it broke my x server and now I don't have access to my desktop and when I run $startx the error will be reported !

$startx
http://www.bpaste.net/show/98165/

#lspci
http://www.bpaste.net/show/98168/

#emerge --info
http://www.bpaste.net/show/98207/

/etc/X11/xorg.conf
http://www.bpaste.net/show/98207/

equery which x11-base/xorg-server
/usr/portage/x11-base/xorg-server/xorg-server-1.14.1.ebuild

how can I downgrade xorg-server ??any idea ?how can I get rid of this problem?


Last edited by haleh on Tue May 14, 2013 10:32 am; edited 1 time in total
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1376

PostPosted: Sat May 11, 2013 8:48 pm    Post subject: Reply with quote

You can try masking the current version to force a downgrade:

use nano -w /etc/portage/package.mask and add =x11-base/xorg-server-1.14.1 then run emerge -auv xorg-server That should take care of downgrading. You might want to add a greater than conditional to block all updates to xorg.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2214
Location: Netherlands

PostPosted: Sat May 11, 2013 9:10 pm    Post subject: Reply with quote

No need to downgrade.
Did you re-emerge nvidia-drivers after xorg-server was upgraded?
Read the contents of xorg-server ebuild (at the end).
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
haleh
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 127

PostPosted: Sun May 12, 2013 5:39 am    Post subject: Reply with quote

gerard82 wrote:
No need to downgrade.
Did you re-emerge nvidia-drivers after xorg-server was upgraded?
Read the contents of xorg-server ebuild (at the end).
Gerard.

I know that I can upgrade nvidia then everything will be fine but my problem is that I can't emerge nvidia-drivers when it want to download it will be failed and this is because of the restriction of nvidia website !I can't even see nvidia website without vpn !I had this issue and I should manually install this or use vpn for gentoo which I don't have yet !

I fixed this! gnome won't start itself and when I run startx will show my nvidia logo but gnome says "Oh no something has gone wrong"
I guess it is because of dependencies which are not updated all of them together !when I emerge -autvND world it will reach nvidia and it will be failed I don't have any idea how mask this because I did and I get error !

Code:
$startx
"Oh no something has gone wrong !A problem has occurred and the system can't recover.All extension have been disabled as precaution"

/var/log/gdm/:0-greeter.log
www.bpaste.net/show/98275
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1376

PostPosted: Sun May 12, 2013 6:36 am    Post subject: Reply with quote

Quote:
libgnutls.so.26: cannot open shared object file: No such file or directory
Failed to load module: /usr/lib/gio/modules/libgiognutls.so


Try revdep-rebuild.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
haleh
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 127

PostPosted: Sun May 12, 2013 7:49 am    Post subject: Reply with quote

Code:
revdep-rebuild

emerge : there are no ebuilds to satisfy ">=kde-base/oxygen-icons-4.10.3"[equa=]
(dependencies required by "kde-base/ksysguard-4.10.3")[ebuild]
(dependencies required by "kde-base/ksysguard:4")[argument]

*revdep-rebuild failed to emerge all packages.


:cry: 8O any idea ?

some how updating crash my system !I don't know what happened but even emerge --sync will be failed !I lost my gnome but I rebuild it with gnome-3.6 and then suddenly nvidia and X crashed and now I fix them and now gnome crashed !
Back to top
View user's profile Send private message
haleh
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 127

PostPosted: Tue May 14, 2013 4:38 am    Post subject: Reply with quote

I unmerge nvidia and run it manually and upgrade to newer version !it fixed !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum