Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia-drivers and segfaults
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
kettuz
n00b
n00b


Joined: 25 Dec 2004
Posts: 26

PostPosted: Fri Apr 19, 2013 8:39 am    Post subject: Nvidia-drivers and segfaults Reply with quote

At some point last Autumn a very curious problem emerged. Segfaults. At first I thought it was only connected to Opera, because it's nothing new for the operapluginwrapper to crash. However, quite soon it became evident that this is something different. I knew it when my firefox segfaulted as well. Add to this the crashing of xorg, strange occasions of screen going on and off and even emerge failing due to segfault.

Now, the curious thing. This doesn't happen if I don't start xorg. If I do, closing it doesn't help, the problem persist. Now, after some research I have come to believe nvidia-drivers is to be blamed for this problem. Some others have mentioned on these forums about the new drivers having made their computer unstable.

Now, why haven't I just downgraded? The reason: older versions of the driver were removed from Portage last Autumn. I believe it was at that time these problems began, because I had set to my package.keywords restrictions on which nvidia-drivers to install, but when the old drivers went away, emerge didn't respect the restriction anymore and installed the new version.

I was able to find the earlier version of the driver (older 304 series) from layouts, but the driver doesn't compile with the newer kernel sources it seems.

So, what should I do? Go back to earlier kernel and udev? Complain on the Nvidia developer forums? Any suggestions?
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Fri Apr 19, 2013 2:12 pm    Post subject: Reply with quote

Take a look at Nvidia's README, where it has advice such as trying:
Code:
pci=nommconf
Back to top
View user's profile Send private message
kettuz
n00b
n00b


Joined: 25 Dec 2004
Posts: 26

PostPosted: Mon May 13, 2013 9:56 pm    Post subject: Reply with quote

Tried it. Also upgraded to the latest nvidia-drivers version. For a while I thought the problem was solved, unfortunately just today operapluginwrapper has been segfaulting all day long and only a few minutes ago even Sylpheed (!) segfaulted. This is really weird.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32439
Location: 56N 3W

PostPosted: Mon May 13, 2013 10:11 pm    Post subject: Reply with quote

kettuz,

All the ebuilds that were ever in the portage tree are stored in the attic. Fetch the ebuild of your choice, put it in your local overlay, (see the handbook) and emerge in the normal way.

You may have problems finding the old drivers to download.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum