Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Strange clicking sounds after installing ALSA
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
pvh1987
n00b
n00b


Joined: 06 Jun 2012
Posts: 34

PostPosted: Wed Jun 06, 2012 12:32 pm    Post subject: [SOLVED] Strange clicking sounds after installing ALSA Reply with quote

I have installed ALSA and sounds comes out of my speakers just fine, like it should. However, I am having this very annoying issue: My speakers "click" once in a while, especially when surfing the web in Chrome. Then I tried going into the alsamixer and turn things up or down, and it clicks even more, almost everytime I change something in the mixer. I have tried to stop the alsa deamon using "/etc/init.d/alsasound stop" to see if my computer will stop making those irritating clicks. I did not stop. So is this really ALSA related?

I can inform you that I have tried to play a video on youtube and while it plays, audio is fine and no clicking sounds are made whatsoever. When the video finished, the clicking sounds came back on.

The clicking sounds are not constant and only appears when I do something on my computer, like going into a website in Google Chrome or going into the alsamixer. One of these actions usually produces a click or two. The clicking is independent of volume setting or channel muting.

My idea is that different programs (including Google Chrome and Alsamixer) will try to enable/disable the sound card now and then, and everytime they do that, a small click is made. I am not totally sure on this, but it is an idea.

Any ideas how I can get rid of these annoying cliks?

I am using Gentoo Linux (kernel 3.2.12) on my first generation (2006) Intel MacBook 13" and lspci tells this about my sound card:
Code:
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
   Subsystem: SigmaTel STAC9221 HD Audio Codec
   Flags: bus master, fast devsel, latency 0, IRQ 43
   Memory at 90440000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [50] Power Management version 2
   Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
   Capabilities: [100] Virtual Channel
   Capabilities: [130] Root Complex Link
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd-hda-intel


Last edited by pvh1987 on Wed Jun 06, 2012 2:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2314
Location: UK

PostPosted: Wed Jun 06, 2012 12:55 pm    Post subject: Reply with quote

Your guess sounds right. Try with hda powersaving mode disabled in the kernel, it's probably clicking when the card turns on/off.
Back to top
View user's profile Send private message
DanneStrat
n00b
n00b


Joined: 05 Jan 2012
Posts: 70

PostPosted: Wed Jun 06, 2012 1:17 pm    Post subject: Reply with quote

pvh1987,

Quote:
My idea is that different programs (including Google Chrome and Alsamixer) will try to enable/disable the sound card now and then, and everytime they do that, a small click is made.


"snd-hda-intel" has an option called "aggressive power save" in the kernel configuration that turns off the card when it's not in use and this procedure often causes a pop.

Since you've built alsa as modules, try the following as root:

Code:
modprobe -r snd-hda-intel && modprobe snd-hda-intel power_save=0


If this gets rid of the crackling, you can make it permanent either with:

Code:
nano -w /etc/modprobe.d/local.conf


and put the following line in the file:

options snd-hda-intel power_save=0

or if you build your own kernel, you can go directly into menuconfig and turn off "aggressive power save" under "hda intel".

Cheers.


Last edited by DanneStrat on Wed Jun 06, 2012 1:22 pm; edited 2 times in total
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Wed Jun 06, 2012 1:19 pm    Post subject: Re: Strange clicking sounds after installing ALSA Reply with quote

pvh1987 wrote:
The clicking is independent of volume setting or channel muting.

Which volume are you writing about ?
The one commanded by the amplifier's knob or the applications / alsa-or-other-mixer slider ?
If it is the one commanded by the amplifier's knob then if it is an electromagnetic field generated on-board by some power-off/on then the clicking should definitely depends on the volume setting.
_________________
Back to top
View user's profile Send private message
pvh1987
n00b
n00b


Joined: 06 Jun 2012
Posts: 34

PostPosted: Wed Jun 06, 2012 2:45 pm    Post subject: Reply with quote

Thanks. I rebuilded the kernel with no HDA Power Saving. It is possible that I only needed to rebuild the modules, but I wanted to be sure. That seemed to solve the problem. :-)

For other users having the same problem, I include my kernel settings (Gentoo 3.2.12) here:

Code:
Device Drivers -->
    <*> Sound card support -->
        <M> Advanced Linux Sound Architecture -->
            [*] PCI sound devices -->
                <M> Intel HD Audio
                    [ ] Aggressive power-saving on HD-audio    <-- Turned OFF
Back to top
View user's profile Send private message
DanneStrat
n00b
n00b


Joined: 05 Jan 2012
Posts: 70

PostPosted: Wed Jun 06, 2012 3:38 pm    Post subject: Reply with quote

Glad it worked.

Cheers.
Back to top
View user's profile Send private message
freifunk_connewitz
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2006
Posts: 114

PostPosted: Fri May 10, 2013 10:48 pm    Post subject: Reply with quote

for all of you that have the correct kernel config but still had that nasty problem (like me):
the advice found here: http://www.foxswap.com/computers-and-technology/ubuntu-12-04-clicking-sound-from-speakers/
helped to solve the problem in my case. (since the culprit was not the kernel config but pm-utils which switched on that stupid audio powersave mode that drives you crazy)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum