Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Tiefschlaf sperrt nur noch (KDE)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Changer90
n00b
n00b


Joined: 16 Apr 2013
Posts: 6

PostPosted: Wed May 08, 2013 3:25 pm    Post subject: [solved] Tiefschlaf sperrt nur noch (KDE) Reply with quote

Hallo zusammen,
ich bin ein Gentoo Neuling und habe vor kurzem das Update auf die aktuellste Version von KDE gemacht. (emerge -avuDN world). Wenn ich den Laptop zuklappe oder aus dem Startmenü Tiefschlaf oder Ruhezustand auswähle, wird die Session nur gesperrt allerdings wird der Rechner nicht ausgeschaltet. Wenn ich in der Konsole sudo pm-suspend-hybrid ausführe wird der Laptop wie gewünscht in den Ruhezustand versetzt. Da ich bei Google keine passende Hilfe gefunden habe wende ich mich hierher.

Kernel Version 3.9.0

Vielen Dank für eure Hilfe
Changer90


Last edited by Changer90 on Fri May 10, 2013 9:07 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3949
Location: Irgendwo im Nirgendwo

PostPosted: Thu May 09, 2013 6:22 am    Post subject: Reply with quote

Kannst du ein wenig mehr über dein system erzählen? Verwendest du Openrc oder systemd zum booten? Mit welchen USE-Flags hast du polkit gebaut? Wie startest du dein KDE (direkt über startx oder per login in kdm/gdm/...)?
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Changer90
n00b
n00b


Joined: 16 Apr 2013
Posts: 6

PostPosted: Thu May 09, 2013 9:31 am    Post subject: Reply with quote

Ich verwende systemd zum booten. polkit wurde mit gtk introspection kde nls pam systemd gebaut. Und mein KDE starte ich über login. Der Tiefschlaf hat vorher funktioniert.
Mein System ist ein Sony VAIO SVS15112C5E mit einem i7 und intel HD4000 Grafikkarte. Ich hoffe ich konnte all deine Fragen beantworten
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3949
Location: Irgendwo im Nirgendwo

PostPosted: Thu May 09, 2013 10:07 am    Post subject: Reply with quote

Was war "vorher"? kde-4.9.5 oder 4.10.1? (ich geh davon aus dass du gerade auf 4.10.2 aktualisiert hast)
MMn. ist es irgendwo in polkit/pam anzusiedeln.
Welche kdebase-pam-Version ist installiert? etc-update gemacht?
Mit pam kenn ich mich leider nicht so wirklich aus, für die die es tun wäre aber sicher der Inhalt von system-auth und system-login (beides in /etc/pam.d) interessant.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Changer90
n00b
n00b


Joined: 16 Apr 2013
Posts: 6

PostPosted: Thu May 09, 2013 10:23 am    Post subject: Reply with quote

Ich bin mir nicht ganz sicher aber ich denke dass kde-4.9.5 installiert war. kdebase-pam-9 ist momentan installiert und etc-update habe ich gemacht.

system-auth
Code:
 
auth            required        pam_env.so
auth            required        pam_unix.so try_first_pass likeauth nullok
auth            optional        pam_permit.so
 
account         required        pam_unix.so
account         optional        pam_permit.so
 
password        required        pam_cracklib.so difok=2 minlen=8 dcredit=2 ocredit=2 retry=3
password        required        pam_unix.so try_first_pass use_authtok nullok sha512 shadow
password        optional        pam_permit.so
 
session         required        pam_limits.so
session         required        pam_env.so
session         required        pam_unix.so
session         optional        pam_permit.so


system-login
Code:

auth            required        pam_tally2.so onerr=succeed
auth            required        pam_shells.so
auth            required        pam_nologin.so
auth            include         system-auth
 
account         required        pam_access.so
account         required        pam_nologin.so
account         include         system-auth
account         required        pam_tally2.so onerr=succeed
 
password        include         system-auth
 
session         optional        pam_loginuid.so
session         required        pam_env.so
session         optional        pam_lastlog.so silent
session         include         system-auth
-session        optional        pam_ck_connector.so nox11
-session        optional        pam_systemd.so
session         optional        pam_motd.so motd=/etc/motd
session         optional        pam_mail.so
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3949
Location: Irgendwo im Nirgendwo

PostPosted: Thu May 09, 2013 10:50 am    Post subject: Reply with quote

Füg mal
Code:
session         optional        pam_systemd.so

in der system-auth ein. Logout+Login wird notwendig sein.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Changer90
n00b
n00b


Joined: 16 Apr 2013
Posts: 6

PostPosted: Thu May 09, 2013 11:02 am    Post subject: Reply with quote

Habs eben probiert leider ohne Erfolg. Bildschirm wird kurz schwarz ähnlich wie beim herunterfahren anschließend geht er wieder an und KDE ist gesperrt.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3949
Location: Irgendwo im Nirgendwo

PostPosted: Thu May 09, 2013 11:54 am    Post subject: Reply with quote

Ah, setz noch ein
Code:
session         optional        pam_loginuid.so

davor.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Changer90
n00b
n00b


Joined: 16 Apr 2013
Posts: 6

PostPosted: Thu May 09, 2013 2:43 pm    Post subject: Reply with quote

Auch diese Änderung bleibt leider ohne Erfolg. Ich kann keine sichtbare Veränderung durch das hinzufügen feststellen.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3949
Location: Irgendwo im Nirgendwo

PostPosted: Thu May 09, 2013 7:12 pm    Post subject: Reply with quote

Tjo - wenn du systemd-203 verwendest, wäre das hier eine Erklärung:
https://bugs.gentoo.org/show_bug.cgi?id=468998
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Changer90
n00b
n00b


Joined: 16 Apr 2013
Posts: 6

PostPosted: Thu May 09, 2013 9:52 pm    Post subject: Reply with quote

Ich hab jetzt nochmal ein update world gemacht und neugestartet und jetzt läuft auf einmal wieder alles wie es soll. Vielen Dank für deine Hilfe.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3949
Location: Irgendwo im Nirgendwo

PostPosted: Fri May 10, 2013 6:50 am    Post subject: Reply with quote

Super! Ich gehe davon aus dass der Fehler in systemd-203 für dein Problem verantwortlich war.
Kannst du noch den Thread noch als gelöst markieren? (Deinen ersten Beitrag in diesem Thread bearbeiten und den Titel ändern)
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum