Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[portage]Actualizacion
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
upszot
Guru
Guru


Joined: 29 Apr 2009
Posts: 303
Location: Argentina

PostPosted: Tue May 07, 2013 11:34 pm    Post subject: [portage]Actualizacion Reply with quote

hola gente, aca vuelvo después de un tiempo ausente...

hace rato que no actualizo mi sistema, y hoy al querer actualizarlo me tope con varios problemitas..
-perfiles deprecados (ya actualice a make.profile -> ../usr/portage/profiles/default/linux/x86/13.0/desktop )
-paquetes maskeados
-overlay que no se si siguen existiendo..

en fin.. les muestro una salida asi me tiran un cable..

Code:
M1530 upszot # emerge -uDvNa world
/usr/lib/portage/pym/portage/dbapi/porttree.py:225: DeprecationWarning: Repository 'zugaina' used deprecated 'pms' cache format. Please migrate to 'md5-dict' format.
  DeprecationWarning)

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies |

!!! Problem resolving dependencies for net-misc/networkmanager from @selected
... done!

!!! The ebuild selected to satisfy "net-misc/networkmanager" has unmet requirements.
- net-misc/networkmanager-0.9.6.4::gentoo USE="bluetooth consolekit dhcpcd gnutls introspection nss ppp resolvconf wext -avahi -connection-sharing -dhclient -doc -modemmanager -vala -wimax"                                                                                                                               

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( nss gnutls )

  The above constraints are a subset of the following complete expression:
    modemmanager? ( ppp ) exactly-one-of ( nss gnutls ) exactly-one-of ( dhclient dhcpcd )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
M1530 upszot #


* lo de zugaina entiendo que tengo que migrar 'pms' a 'md5-dict' , pero no se quien?.. ocea.. quien esta usando pms, busque "migrar pms to md5" pero no encontre nada... no entiendo bien a que se refiere con esa migracion... es algo de layman o de portage?.

y aparentemente afecto a todo el sistema pq nisiquiera puedo hacer esto...
Code:
M1530 upszot # equery list '*' |egrep net-misc/networkmanager
/usr/lib/portage/pym/portage/dbapi/porttree.py:225: DeprecationWarning: Repository 'zugaina' used deprecated 'pms' cache format. Please migrate to 'md5-dict' format.
  DeprecationWarning)
net-misc/networkmanager-0.8.4.0-r2

_________________
---------------------------------------
Gentoo >> Dell XPS M1530 - T8300 - 4gb - 8600gt 256
ubuntu + xp >> Athon 2000+xp - 1gb - 6600gt 128bt
dd-wrt v24 >> linksys wrt54gl v1.1
android 2.3 (Miui) >> Motorola Defy
Back to top
View user's profile Send private message
upszot
Guru
Guru


Joined: 29 Apr 2009
Posts: 303
Location: Argentina

PostPosted: Tue May 07, 2013 11:37 pm    Post subject: Re: [portage]Actualizacion Reply with quote

Bueno lo de..
upszot wrote:
Code:
M1530 upszot # equery list '*' |egrep net-misc/networkmanager
/usr/lib/portage/pym/portage/dbapi/porttree.py:225: DeprecationWarning: Repository 'zugaina' used deprecated 'pms' cache format. Please migrate to 'md5-dict' format.
  DeprecationWarning)
net-misc/networkmanager-0.8.4.0-r2


aparentemente lo acabo de solucionar ejecutando
Code:
layman -S

al menos con eso ahora ya no aparece mas... (raro pq antes habia ejecutado un "eix-sync" asique se supone que estaba actualizado... pero bueno)

ahora solo me queda lo del emerge del world
_________________
---------------------------------------
Gentoo >> Dell XPS M1530 - T8300 - 4gb - 8600gt 256
ubuntu + xp >> Athon 2000+xp - 1gb - 6600gt 128bt
dd-wrt v24 >> linksys wrt54gl v1.1
android 2.3 (Miui) >> Motorola Defy
Back to top
View user's profile Send private message
upszot
Guru
Guru


Joined: 29 Apr 2009
Posts: 303
Location: Argentina

PostPosted: Tue May 07, 2013 11:57 pm    Post subject: Reply with quote

bueno..investigando un poco...
Code:
M1530 upszot # equery list '*' |egrep net-misc/networkmanager
net-misc/networkmanager-0.8.4.0-r2

M1530 upszot # equery uses net-misc/networkmanager
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for net-misc/networkmanager-0.9.6.4:
 U I
 - - avahi              : Add avahi/Zeroconf support
 + + bluetooth          : Enables Bluetooth Support
 - - connection-sharing : Use net-dns/dnsmasq and net-firewall/iptables for connection sharing
 + + consolekit         : Use sys-auth/consolekit for session tracking
 - - dhclient           : Use dhclient from net-misc/dhcp for getting ip
 + - dhcpcd             : Use net-misc/dhcpcd for getting ip
 - - doc                : Adds extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
 + - gnutls             : Adds support for net-libs/gnutls (TLS 1.0 and SSL 3.0 support)
 + - introspection      : Adds support for GObject based introspection
 - - modemmanager       : Enable support for mobile broadband devices using net-misc/modemmanager
 + - nss                : Use dev-libs/nss for cryptography
 + - ppp                : Enable support for mobile broadband and PPPoE connections using net-dialup/ppp
 + - resolvconf         : Use net-dns/openresolv for managing DNS information
 - - vala               : Enable bindings for dev-lang/vala
 + - wext               : Enable support for the deprecated Wext (Wireless Extensions) API; needed for some older drivers (e.g. ipw2200, ndiswrapper)
 - - wimax              : Enable support for WiMAX connections using net-wireless/wimax
M1530 upszot # spackage net-misc/networkmanager
================ package.keywords =========================
=net-misc/networkmanager-0.7.1-r3
================ package.mask =============================
================ package.unmask ==========================
================ package.use =============================
net-misc/networkmanager  dhcpcd gnutls resolvconf
por lo que le agrege la USE nss pero me sigue diciendo lo mismo...
Code:
M1530 upszot # emerge -uDvNa world

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies -

!!! Problem resolving dependencies for net-misc/networkmanager from @selected
... done!

!!! The ebuild selected to satisfy "net-misc/networkmanager" has unmet requirements.
- net-misc/networkmanager-0.9.6.4::gentoo USE="bluetooth consolekit dhcpcd gnutls introspection nss ppp resolvconf wext -avahi -connection-sharing -dhclient -doc -modemmanager -vala -wimax"                                                                                                                               

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( nss gnutls )

  The above constraints are a subset of the following complete expression:
    modemmanager? ( ppp ) exactly-one-of ( nss gnutls ) exactly-one-of ( dhclient dhcpcd )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

_________________
---------------------------------------
Gentoo >> Dell XPS M1530 - T8300 - 4gb - 8600gt 256
ubuntu + xp >> Athon 2000+xp - 1gb - 6600gt 128bt
dd-wrt v24 >> linksys wrt54gl v1.1
android 2.3 (Miui) >> Motorola Defy
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1532

PostPosted: Wed May 08, 2013 3:28 pm    Post subject: Reply with quote

Posiblemente tengas que volver al profile 10.0 y emerger portage despues ya podrás volver al profile 13.0 y ejecutar emerge --sync, no olvides que empiezo diciendo "Posiblemente" y con esto quiero decir que a mi me ocurrió lo que te comento pero puede que no sea tu caso.
Comprueba que tienes el último portage, a mi me sale algo así:
Quote:
sys-apps/portage
Latest version available: 2.1.11.62
Latest version installed: 2.1.11.55
Size of files: 894 kB
Homepage: http://www.gentoo.org/proj/en/portage/index.xml
Description: Portage is the package management and distribution system for Gentoo

Estoy en la rama estable de amd64 y aunque ya no es el portage más actual en su momento y no hace mucho lo era.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1532

PostPosted: Wed May 08, 2013 4:15 pm    Post subject: Reply with quote

He empezado a recordar, lee esto:
Quote:
mimaquina esteban # eselect news read 28
2013-02-10-new-13-profiles
Title New 13.0 profiles and deprecation of 10.0 profiles
Author Andreas K. Huettel <dilfridge@gentoo.org>
Posted 2013-02-10
Revision 1

We have generated a new set of profiles for Gentoo installation. These are now
called 13.0 instead of 10.0. Everyone should upgrade as soon as possible (but
please make sure sys-apps/portage is updated to current stable *before* you
switch profile).
This brings (nearly) no user-visible changes. Some new files have been added
to the profile directories that make it possible for the developers to do more
fine-grained use flag masking (see PMS-5 for the details), and this formally
requires a new profile tree with EAPI=5.

Y claro para pasar a EAPI=5 creo que es necesario actualizar portage.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Wed May 08, 2013 8:53 pm    Post subject: Reply with quote

Quote:
!!! The ebuild selected to satisfy "net-misc/networkmanager" has unmet requirements.
- net-misc/networkmanager-0.9.6.4::gentoo USE="bluetooth consolekit dhcpcd gnutls introspection nss ppp resolvconf wext -avahi -connection-sharing -dhclient -doc -modemmanager -vala -wimax"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( nss gnutls )

Solo puedes tener activa una de las dos uses que te dicen (nss y gnutls) y tienes puestas las dos. Tienes que eliminar una. Por ejemplo poniendo en package.use:
Code:
net-misc/networkmanager -gnutls
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum