Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Instalar blender (Solucionado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
fellsword
n00b
n00b


Joined: 23 Jul 2012
Posts: 64

PostPosted: Tue Apr 30, 2013 2:14 am    Post subject: Instalar blender (Solucionado) Reply with quote

Saludos :D
Pues reinstale el sistema gentoo :D Bueno, pues quiero instalar blender, pero no me deja. requiere python 3.3.0 cual no se puede instalar.

¿Como lo instalo?

Perdón por no editar el post.
Pero el comentario de @esteban_conde funciono al 100 :D


Last edited by fellsword on Wed May 22, 2013 5:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 2953
Location: Valencia, Spain

PostPosted: Tue Apr 30, 2013 10:41 am    Post subject: Reply with quote

Estoy seguro de que existe una buena razón para enmascarar Python 3.3 pero si estás seguro de que quieres arriesgarte a instalarlo aquí tienes una guía:

http://forums.gentoo.org/viewtopic-t-953748-start-25.html

No se te ocurra usar Python 3.3 como intérprete por defecto o se te romperán muchas cosas!
Back to top
View user's profile Send private message
fellsword
n00b
n00b


Joined: 23 Jul 2012
Posts: 64

PostPosted: Tue Apr 30, 2013 11:17 am    Post subject: Reply with quote

Bueno, como se puede instalar blender sin usar python 3.3.0?
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1494

PostPosted: Tue Apr 30, 2013 11:48 am    Post subject: Reply with quote

Para hacer esto:
Quote:
Bueno, como se puede instalar blender sin usar python 3.3.0?

Tendras conseguir de un ordenador parecido al tuyo y que tenga blender instalado (se da por entendido que usando una version de blender anterior a python-3.3) construyendo el paquete binario con "quickpkg --include-config=y blender" sin comillas, luego importas el paquete creado a tu ordenador y lo instalas con emerge -G blender.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
fellsword
n00b
n00b


Joined: 23 Jul 2012
Posts: 64

PostPosted: Tue Apr 30, 2013 9:16 pm    Post subject: Reply with quote

Uhhh gracias :D
Back to top
View user's profile Send private message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 788
Location: 127.0.0.1

PostPosted: Thu May 02, 2013 7:55 am    Post subject: Reply with quote

Por lo que veo en: http://gpo.zugaina.org/media-gfx/blender

Tienes en portage disponible, pero también masked, la versión blender-2.64a que por lo que entiendo depende de Python 3.2:
Code:

EAPI=4
PYTHON_DEPEND="3:3.2"


Salu2.
_________________
Localnet
Films Localnet
Back to top
View user's profile Send private message
fellsword
n00b
n00b


Joined: 23 Jul 2012
Posts: 64

PostPosted: Thu May 02, 2013 11:14 am    Post subject: Reply with quote

opotonil wrote:
Por lo que veo en: http://gpo.zugaina.org/media-gfx/blender

Tienes en portage disponible, pero también masked, la versión blender-2.64a que por lo que entiendo depende de Python 3.2:
Code:

EAPI=4
PYTHON_DEPEND="3:3.2"


Salu2.


Gracias, pero ya intentado los overlays. Intentare otravez con este :D
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1494

PostPosted: Thu May 02, 2013 12:29 pm    Post subject: Reply with quote

Creo entender en lo siguiente que hay un paquete en portage que todavia no exige python-3.3.x:
Quote:
mimaquina esteban # emerge -pv blender

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "blender" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-gfx/blender-2.66::gentoo (masked by: package.mask, ~amd64 keyword)
/usr/portage/profiles/package.mask:
# Julian Ospald <hasufell@gentoo.org> (10 Mar 2013)
# Depends on maked dev-lang/python:3.3

- media-gfx/blender-2.64a::gentoo (masked by: package.mask, ~amd64 keyword)
/usr/portage/profiles/package.mask:
# Julian Ospald <hasufell@gentoo.org> (10 Mar 2013)
# Unsupported and full of bundled libs. Only left
# for people who don't have python-3.3 yet.
# Will be removed once python-3.3 and >=blender-2.66 enter ~arch.


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



segun eso con: echo "=media-gfx/blender-2.64a" >/etc/portage/package.unmask/blender
y: echo "=media-gfx/blender-2.64a ~amd64" >/etc/portage/package.keywords/blender
seria posible instalar blender-2.64a y creeme que he instalado paquetes con avisos más severos que el que da.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
fellsword
n00b
n00b


Joined: 23 Jul 2012
Posts: 64

PostPosted: Thu May 02, 2013 10:18 pm    Post subject: Reply with quote

esteban_conde wrote:
Creo entender en lo siguiente que hay un paquete en portage que todavia no exige python-3.3.x:
Quote:
mimaquina esteban # emerge -pv blender

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "blender" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-gfx/blender-2.66::gentoo (masked by: package.mask, ~amd64 keyword)
/usr/portage/profiles/package.mask:
# Julian Ospald <hasufell@gentoo.org> (10 Mar 2013)
# Depends on maked dev-lang/python:3.3

- media-gfx/blender-2.64a::gentoo (masked by: package.mask, ~amd64 keyword)
/usr/portage/profiles/package.mask:
# Julian Ospald <hasufell@gentoo.org> (10 Mar 2013)
# Unsupported and full of bundled libs. Only left
# for people who don't have python-3.3 yet.
# Will be removed once python-3.3 and >=blender-2.66 enter ~arch.


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



segun eso con: echo "=media-gfx/blender-2.64a" >/etc/portage/package.unmask/blender
y: echo "=media-gfx/blender-2.64a ~amd64" >/etc/portage/package.keywords/blender
seria posible instalar blender-2.64a y creeme que he instalado paquetes con avisos más severos que el que da.


Muchas gracias, llegando a la casa lo probare :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum