Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Grub is installed but doesn't start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
leonixyz
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2012
Posts: 76
Location: Italy

PostPosted: Sat Apr 27, 2013 11:07 pm    Post subject: [SOLVED] Grub is installed but doesn't start Reply with quote

I'm trying to end my installation with grub and a reboot, but I get unexpected issues.

this is my partition table (I also have other hard drives but they have no bootable partitions)
Code:

Disk /dev/sda: 20.5 GB, 20547841536 bytes, 40132503 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xe01ae01a

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048       67583       32768   83  Linux
/dev/sda2           67584     4261887     2097152   82  Linux swap / Solaris
/dev/sda3         4261888    40132502    17935307+  83  Linux


I emerged and installed grub (grub-install --no-floppy /dev/sda) and it seems to be installed in /dev/sda1 (/boot)
Code:

drwxr-xr-x 2 root root   1024 Apr 28 01:25 .
drwxr-xr-x 4 root root   1024 Apr 27 23:32 ..
-rw-r--r-- 1 root root    197 Apr 28 01:25 default
-rw-r--r-- 1 root root     60 Apr 27 20:19 device.map
-rw-r--r-- 1 root root  10944 Apr 28 01:25 e2fs_stage1_5
-rw-r--r-- 1 root root  10160 Apr 28 01:25 fat_stage1_5
-rw-r--r-- 1 root root   9392 Apr 28 01:25 ffs_stage1_5
-rw-r--r-- 1 root root    613 Apr 28 01:25 grub.conf
-rw-r--r-- 1 root root   9448 Apr 28 01:25 iso9660_stage1_5
-rw-r--r-- 1 root root  11028 Apr 28 01:25 jfs_stage1_5
lrwxrwxrwx 1 root root      9 Apr 27 20:19 menu.lst -> grub.conf
-rw-r--r-- 1 root root   9580 Apr 28 01:25 minix_stage1_5
-rw-r--r-- 1 root root  12360 Apr 28 01:25 reiserfs_stage1_5
-rw-r--r-- 1 root root  33856 Apr 27 20:18 splash.xpm.gz
-rw-r--r-- 1 root root    512 Apr 28 01:25 stage1
-rw-r--r-- 1 root root 130416 Apr 28 01:25 stage2
-rw-r--r-- 1 root root 130416 Apr 27 20:18 stage2_eltorito
-rw-r--r-- 1 root root   9688 Apr 28 01:25 ufs2_stage1_5
-rw-r--r-- 1 root root   9028 Apr 28 01:25 vstafs_stage1_5
-rw-r--r-- 1 root root  11808 Apr 28 01:25 xfs_stage1_5


I wrote grub.conf as follows (and also tried with only "root=/dev/sda3", with only "real_root=/dev/sda3" and with both "real_root=/dev/sda3" and "root=/dev/ram0" as the default config file was written)
Code:

default 0
timeout 10
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo Linux 3.7.10
root (hd0,0)
kernel /boot/kernel-genkernel-x86-3.7.10-gentoo root=/dev/sda3 real_root=/dev/sda3
initrd /boot/initramfs-genkernel-x86-3.7.10-gentoo


No way... I tried to install it manually in /dev/sda like in the x86 handbook (I tried also /dev/sda1 "setup (hd0,0)"):
Code:

# grub --no-floppy
grub > root (hd0,0)
grub > setup (hd0)
grub > quit


But every time I reboot nothing happens... Grub doesn't start and I have to reboot into the installation cd and chroot again again and again...
I think now it could be harmful that Grub could be installed twice, into MBR and into /dev/sda1,... how do I uninstall it if I like to try lilo i.e.?
What am I missing?

-----------------------------------------------

Solved:
The wrong boot sequence was NET --> CD --> IDE1
Now is NET --> CD --> IDE0


Last edited by leonixyz on Sun Apr 28, 2013 5:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31716
Location: 56N 3W

PostPosted: Sun Apr 28, 2013 11:05 am    Post subject: Reply with quote

leonixyz,

Grub is in several parts, some of it will be in your /dev/sda1 (/boot) some in /dev/sda MBR. You need all the parts.

As grub does not start, either your hard drives have changed BIOS names between the install and normal boot. (Some BIOSes do that), or your BIOS is not booting from your Gentoo install.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
leonixyz
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2012
Posts: 76
Location: Italy

PostPosted: Sun Apr 28, 2013 5:48 pm    Post subject: Reply with quote

Thanks, solved
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum