Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iptables-1.4.12.1 + imq does not work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
nicraM
n00b
n00b


Joined: 23 Apr 2012
Posts: 6

PostPosted: Mon Apr 23, 2012 3:36 pm    Post subject: iptables-1.4.12.1 + imq does not work Reply with quote

Hi all
I'm new in gentoo, so please bear with us.

I'm trying install iptables with imq support by emerge, but this does not work.
I dowlnoaded imq patch from http://www.linuximq.net/patches/iptables-1.4.12-IMQ-test4.diff and saved it to /etc/portage/patches/net-firewall/iptables.
then i've tryed install iptables which is patching properly with imq patch.
Code:
#v+
john ~ # USE="extensions" emerge -av iptables

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] net-firewall/iptables-1.4.12.1  USE="ipv6 -netlink" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) net-firewall/iptables-1.4.12.1
 * iptables-1.4.12.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                       [ ok ]
>>> Unpacking source...
>>> Unpacking iptables-1.4.12.1.tar.bz2 to /var/tmp/portage/net-firewall/iptables-1.4.12.1/work
>>> Source unpacked in /var/tmp/portage/net-firewall/iptables-1.4.12.1/work
>>> Preparing source in /var/tmp/portage/net-firewall/iptables-1.4.12.1/work/iptables-1.4.12.1 ...
 * Applying iptables-1.4.12.1-lm.patch ...                                                                                    [ ok ]
 * Running automake --add-missing --copy --foreign ...                                                           [ ok ]
 * Applying user patches from /etc/portage/patches//net-firewall/iptables ...
 *   iptables-1.4.12-IMQ-test4.patch ...                                                             [ ok ]
 * Done with patching
#v- 

but iptables with --todev gives error.
Code:
iptables -j IMQ --help | grep -iA2 IMQ
prints nothing and imq doesn't work.

but when i'm do it manually it works.
Quote:
emerge -avf iptables
tar xjf /usr/portage/distfiesl/iptables-1.4.12.1.tar.bz2 -C /usr/src
cd /usr/src
ln -s iptables-1.4.12.1 iptables
cd iptables
patch -p1 < /etc/portage/patches/net-firewall/iptables/iptables-1.4.12.1.tar.bz2
./configure
make && make install

when i'm doing manually it works.

can anybody tell me, why emerge method doesn't install imq properly? or what am I doing wrong?
Code:
john / # uname -a
Linux john 3.2.12-gentoo #3 SMP Mon Apr 23 17:08:30 CEST 2012 x86_64 Intel(R) Xeon(R) CPU E5345 @ 2.33GHz GenuineIntel GNU/Linux

ps. sorry for my english.
Back to top
View user's profile Send private message
Odysseus
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 248
Location: Miami, FL. I miss San Francisco!!!

PostPosted: Wed Apr 25, 2012 5:18 pm    Post subject: Reply with quote

If I'm not mistaken, besides patching iptables you also need patched kernel sources and selecting the proper modules in said sources to get it to work.

I don't use IMQ, however, I do use the pf-sources for my kernel and IMQ patchset (as well as the BFS scheduler) are included.
Configure and install your kernel with the correct modules for iptables and IMQ, then try emerging your patched iptables. Give it a try and see if it works for you.

Ciao
Back to top
View user's profile Send private message
nicraM
n00b
n00b


Joined: 23 Apr 2012
Posts: 6

PostPosted: Wed Apr 25, 2012 5:48 pm    Post subject: Reply with quote

Odysseus wrote:
If I'm not mistaken, besides patching iptables you also need patched kernel sources and selecting the proper modules in said sources to get it to work.

I don't use IMQ, however, I do use the pf-sources for my kernel and IMQ patchset (as well as the BFS scheduler) are included.
Configure and install your kernel with the correct modules for iptables and IMQ, then try emerging your patched iptables. Give it a try and see if it works for you.

Ciao

The kernel was patched witch IMQ-patch before install iptables by emerge method.
however, when i install it manually it works but doesnt work by "emerge -av iptables". it seems like gentoo/emerge bug
Back to top
View user's profile Send private message
dafqq
n00b
n00b


Joined: 17 Apr 2013
Posts: 25

PostPosted: Fri Apr 26, 2013 8:16 pm    Post subject: Reply with quote

Hi,

Did you find solution of this ? i have the same problem

Regards


Last edited by dafqq on Sun Apr 28, 2013 10:05 am; edited 1 time in total
Back to top
View user's profile Send private message
nicraM
n00b
n00b


Joined: 23 Apr 2012
Posts: 6

PostPosted: Sat Apr 27, 2013 8:28 am    Post subject: Reply with quote

dafqq wrote:
Hi,

Did you find solution of this problem? i have the same problem.....

Regards
no i didn't. i've installed it manually and it works till today.
Back to top
View user's profile Send private message
dafqq
n00b
n00b


Joined: 17 Apr 2013
Posts: 25

PostPosted: Tue Apr 30, 2013 1:43 pm    Post subject: Reply with quote

anyone have some idea how to patch iptables with gentoo?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum