Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]kernel 3.7.10 - Error: circular dependencies:
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
dafqq
n00b
n00b


Joined: 17 Apr 2013
Posts: 25

PostPosted: Tue Apr 23, 2013 5:44 pm    Post subject: [SOLVED]kernel 3.7.10 - Error: circular dependencies: Reply with quote

Hello,

I install a fresh copy of the system, and rly i dont get it why i have that problem, it is normal? i try to disable flags but it not help. I even install gentoo 3.4.34 and is the same problem....

Every single time if i want to emerge something i get this:

Code:
emerge net-misc/dhcpcd

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!


[nomerge       ] dev-libs/elfutils-0.149  USE="bzip2 nls zlib -lzma"
[nomerge       ]  sys-devel/flex-2.5.37  USE="nls -static {-test}"
[nomerge       ]   sys-devel/gettext-0.18.2  USE="acl cxx nls openmp -cvs -doc -emacs -git -java -static-libs"
[nomerge       ]    dev-libs/libxml2-2.9.0-r2:2  USE="ipv6 readline -debug -examples -icu -lzma -python -static-libs {-test}" PYTHON_TARGETS="python2_7 -python2_5 -python2_6"
[nomerge       ]     dev-util/gtk-doc-am-1.18
[nomerge       ]      virtual/pkgconfig-0
[nomerge       ]       dev-util/pkgconfig-0.28  USE="-hardened -internal-glib"
[nomerge       ]        dev-libs/glib-2.32.4-r1:2  USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr"
[ebuild  N     ]         x11-misc/shared-mime-info-1.0  0 kB
[ebuild  N     ]       dev-util/pkgconfig-0.28  USE="-hardened -internal-glib" 0 kB
[ebuild  N     ]        dev-libs/glib-2.32.4-r1:2  USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" 0 kB
[ebuild  N     ] net-misc/dhcpcd-5.6.4  USE="zeroconf" 84 kB
[nomerge       ] x11-misc/shared-mime-info-1.0
[ebuild  N     ]  dev-libs/libxml2-2.9.0-r2:2  USE="ipv6 readline -debug -examples -icu -lzma -python -static-libs {-test}" PYTHON_TARGETS="python2_7 -python2_5 -python2_6" 0 kB
[ebuild  N     ]   dev-util/gtk-doc-am-1.18  0 kB
[ebuild  N     ]    virtual/pkgconfig-0  0 kB
[nomerge       ] x11-misc/shared-mime-info-1.0
[nomerge       ]  dev-libs/glib-2.32.4-r1:2  USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr"
[nomerge       ]   sys-devel/gettext-0.18.2  USE="acl cxx nls openmp -cvs -doc -emacs -git -java -static-libs"
[ebuild  N     ]    virtual/acl-0-r1  USE="-static-libs" 0 kB
[ebuild  N     ]     sys-apps/acl-2.2.51  USE="nls (-nfs) -static-libs" 0 kB
[ebuild  N     ]      sys-apps/attr-2.4.46-r1  USE="nls -static-libs" 0 kB
[nomerge       ] dev-libs/libxml2-2.9.0-r2:2  USE="ipv6 readline -debug -examples -icu -lzma -python -static-libs {-test}" PYTHON_TARGETS="python2_7 -python2_5 -python2_6"
[nomerge       ]  sys-devel/automake-1.12.6:1.12
[nomerge       ]   sys-apps/help2man-1.40.11  USE="nls"
[nomerge       ]    dev-perl/Locale-gettext-1.50.0
[nomerge       ]     dev-lang/perl-5.12.4-r1  USE="berkdb gdbm -build -debug -doc -ithreads"
[ebuild  N     ]      sys-libs/db-4.8.30:4.8  USE="cxx -doc -examples -java -tcl {-test}" 22,351 kB
[ebuild  N     ]       sys-devel/libtool-2.4-r1:2  USE="{-test} -vanilla" 0 kB
[ebuild  N     ]        sys-devel/automake-1.12.6:1.12  0 kB
[ebuild  N     ]         sys-apps/help2man-1.40.11  USE="nls" 0 kB
[ebuild  N     ]          dev-perl/Locale-gettext-1.50.0  8 kB
[ebuild  N     ]      app-admin/perl-cleaner-2.7  0 kB
[nomerge       ] x11-misc/shared-mime-info-1.0
[ebuild  N     ]  dev-util/intltool-0.50.2  0 kB
[ebuild  N     ]   dev-perl/XML-Parser-2.410.0  0 kB
[nomerge       ] dev-libs/libxml2-2.9.0-r2:2  USE="ipv6 readline -debug -examples -icu -lzma -python -static-libs {-test}" PYTHON_TARGETS="python2_7 -python2_5 -python2_6"
[nomerge       ]  sys-devel/libtool-2.4-r1:2  USE="{-test} -vanilla"
[ebuild  N     ]   sys-devel/autoconf-2.69:2.5  USE="-emacs -multislot" 0 kB
[ebuild  N     ]    dev-lang/perl-5.12.4-r1  USE="berkdb gdbm -build -debug -doc -ithreads" 0 kB
[nomerge       ] dev-libs/glib-2.32.4-r1:2  USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr"
[ebuild  N     ]  dev-libs/elfutils-0.149  USE="bzip2 nls zlib -lzma" 0 kB
[nomerge       ] app-admin/perl-cleaner-2.7
[nomerge       ]  app-shells/bash-4.2_p37  USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins -vanilla"
[ebuild  N     ]   virtual/yacc-0  0 kB
[ebuild  N     ]    sys-devel/bison-2.4.3  USE="nls -static" 0 kB
[nomerge       ] sys-libs/db-4.8.30:4.8  USE="cxx -doc -examples -java -tcl {-test}"
[nomerge       ]  sys-devel/binutils-2.22-r1  USE="cxx nls zlib -multislot -multitarget -static-libs {-test} -vanilla"
[ebuild  N     ]   sys-devel/flex-2.5.37  USE="nls -static {-test}" 0 kB
[ebuild  N     ]    sys-devel/gettext-0.18.2  USE="acl cxx nls openmp -cvs -doc -emacs -git -java -static-libs" 0 kB
[ebuild  N     ]  sys-devel/binutils-2.22-r1  USE="cxx nls zlib -multislot -multitarget -static-libs {-test} -vanilla" 19,542 kB
[ebuild  N     ] app-shells/bash-4.2_p37  USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins -vanilla" 0 kB

Total: 27 packages (27 new), Size of downloads: 41,984 kB

 * Error: circular dependencies:

(sys-libs/db-4.8.30::gentoo, ebuild scheduled for merge) depends on
 (sys-devel/automake-1.12.6::gentoo, ebuild scheduled for merge) (buildtime)
  (dev-lang/perl-5.12.4-r1::gentoo, ebuild scheduled for merge) (buildtime)
   (sys-libs/db-4.8.30::gentoo, ebuild scheduled for merge) (buildtime)

Note that the dependency graph contains a lot of cycles.
Several changes might be required to resolve all cycles.
Temporarily changing some use flag for all packages might be the better option.



Code:
emerge --info
System uname: Linux-3.7.10-gentoo-i686-Intel-R-_Xeon-R-_
KiB Mem:     3365444 total,   3238584 free
KiB Swap:    2000088 total,   2000088 free
Timestamp of tree: Tue, 16 Apr 2013 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm gpm iconv ipv6 modules mudflap ncurses nls nptl openmp pam pcre readline session ssl tcpd unicode x86 zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Code:
/etc/portage/make.conf


Code:
 These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="i686-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE=""


I use this manual to install : http://www.gentoo.org/doc/en/gentoo-x86-quickinstall.xml after reboot i cant emerge anything any clues?

Regards


Last edited by dafqq on Thu Apr 25, 2013 9:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6250
Location: Goose Creek SC

PostPosted: Tue Apr 23, 2013 6:04 pm    Post subject: Reply with quote

try
Code:
emerge -1av --nodeps db automake perl perl-updater
perl-updater
emerge -uND world

_________________
Defund the FCC.
Back to top
View user's profile Send private message
dafqq
n00b
n00b


Joined: 17 Apr 2013
Posts: 25

PostPosted: Tue Apr 23, 2013 6:31 pm    Post subject: Reply with quote

hi, thx for respond.. still i have problem

Code:
 emerge -1av --nodeps db automake perl

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

[ebuild  N     ] sys-libs/db-4.8.30:4.8  USE="-cxx -doc -examples -java -tcl {-test}" 0 kB
[ebuild  N     ] sys-devel/automake-1.12.6:1.12  0 kB
[ebuild  N     ] dev-lang/perl-5.12.4-r1  USE="-berkdb -build -debug -doc -gdbm -ithreads" 0 kB

Total: 3 packages (3 new), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 3) sys-libs/db-4.8.30
 * db-4.8.30.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                              [ ok ]
>>> Unpacking source...
>>> Unpacking db-4.8.30.tar.gz to /var/tmp/portage/sys-libs/db-4.8.30/work
 * Applying db-4.8-libtool.patch ...                                                                                                                  [ ok ]
 * Applying db-4.8.24-java-manifest-location.patch ...                                                                                                [ ok ]
 * Applying db-4.8.30-rename-atomic-compare-exchange.patch ...                                                                                        [ ok ]
 * Applying db-4.6-jni-check-prefix-first.patch ...                                                                                                   [ ok ]
 * Applying db-4.3-listen-to-java-options.patch ...                                                                                                   [ ok ]
 * Running eautoreconf in '/var/tmp/portage/sys-libs/db-4.8.30/work/db-4.8.30/dist' ...
 * ERROR: sys-libs/db-4.8.30 failed (unpack phase):
 *   Cannot find the latest automake! Tried 1.12:1.12
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_unpack
 *   environment, line 4992:  Called eautoreconf
 *   environment, line 1131:  Called _elibtoolize '--install' '--copy' '--force'
 *   environment, line  318:  Called autotools_run_tool 'libtoolize' '--install' '--copy' '--force'
 *   environment, line  642:  Called autotools_env_setup
 *   environment, line  603:  Called die
 * The specific snippet of code:
 *           [[ ${WANT_AUTOMAKE} == "latest" ]] && die "Cannot find the latest automake! Tried ${_LATEST_AUTOMAKE}";
 *
 * If you need support, post the output of `emerge --info '=sys-libs/db-4.8.30'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/db-4.8.30'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info =db-4.8.30
/usr/lib/portage/bin/isolated-functions.sh: line 215: wait: `Cannot find the latest automake! Tried 1.12:1.12': not a pid or valid job spec
 * The complete build log is located at '/var/tmp/portage/sys-libs/db-4.8.30/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/db-4.8.30/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-libs/db-4.8.30/work/db-4.8.30/dist'
 * S: '/var/tmp/portage/sys-libs/db-4.8.30/work/db-4.8.30/build_unix'

>>> Failed to emerge sys-libs/db-4.8.30, Log file:

>>>  '/var/tmp/portage/sys-libs/db-4.8.30/temp/build.log'

 * Messages for package sys-libs/db-4.8.30:

 * ERROR: sys-libs/db-4.8.30 failed (unpack phase):
 *   Cannot find the latest automake! Tried 1.12:1.12
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_unpack
 *   environment, line 4992:  Called eautoreconf
 *   environment, line 1131:  Called _elibtoolize '--install' '--copy' '--force'
 *   environment, line  318:  Called autotools_run_tool 'libtoolize' '--install' '--copy' '--force'
 *   environment, line  642:  Called autotools_env_setup
 *   environment, line  603:  Called die
 * The specific snippet of code:
 *           [[ ${WANT_AUTOMAKE} == "latest" ]] && die "Cannot find the latest automake! Tried ${_LATEST_AUTOMAKE}";
 *
 * If you need support, post the output of `emerge --info '=sys-libs/db-4.8.30'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/db-4.8.30'`.
 * The complete build log is located at '/var/tmp/portage/sys-libs/db-4.8.30/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/db-4.8.30/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-libs/db-4.8.30/work/db-4.8.30/dist'
 * S: '/var/tmp/portage/sys-libs/db-4.8.30/work/db-4.8.30/build_unix
Back to top
View user's profile Send private message
Maitreya
Apprentice
Apprentice


Joined: 11 Jan 2006
Posts: 190

PostPosted: Tue Apr 23, 2013 6:41 pm    Post subject: Reply with quote

Try emerging automake first as it cannot find it
Back to top
View user's profile Send private message
dafqq
n00b
n00b


Joined: 17 Apr 2013
Posts: 25

PostPosted: Tue Apr 23, 2013 6:46 pm    Post subject: Reply with quote

I really wanna merge something but:

Code:
emerge automake

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!


[nomerge       ] sys-apps/sed-4.2.1-r1  USE="acl nls (-selinux) -static"
[nomerge       ]  sys-devel/gettext-0.18.2  USE="acl cxx nls openmp -cvs -doc -emacs -git -java -static-libs"
[nomerge       ]   dev-libs/libxml2-2.9.0-r2:2  USE="ipv6 readline -debug -examples -icu -lzma -python -static-libs {-test}" PYTHON_TARGETS="python2_7 -python2_5 -python2_6"
[nomerge       ]    dev-util/gtk-doc-am-1.18
[nomerge       ]     virtual/pkgconfig-0
[nomerge       ]      dev-util/pkgconfig-0.28  USE="-hardened -internal-glib"
[nomerge       ]       dev-libs/glib-2.32.4-r1:2  USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr"
[ebuild  N     ]        x11-misc/shared-mime-info-1.0  0 kB
[ebuild  N     ]      dev-util/pkgconfig-0.28  USE="-hardened -internal-glib" 0 kB
[ebuild  N     ]       dev-libs/glib-2.32.4-r1:2  USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" 0 kB
[ebuild  N     ]     virtual/pkgconfig-0  0 kB
[ebuild  N     ]    dev-util/gtk-doc-am-1.18  0 kB
[ebuild  N     ]   dev-libs/libxml2-2.9.0-r2:2  USE="ipv6 readline -debug -examples -icu -lzma -python -static-libs {-test}" PYTHON_TARGETS="python2_7 -python2_5 -python2_6" 0 kB
[nomerge       ] x11-misc/shared-mime-info-1.0
[ebuild  N     ]  dev-util/intltool-0.50.2  0 kB
[ebuild  N     ]   dev-perl/XML-Parser-2.410.0  0 kB
[nomerge       ] sys-devel/automake-1.12.6:1.12
[nomerge       ]  sys-apps/help2man-1.40.11  USE="nls"
[nomerge       ]   dev-perl/Locale-gettext-1.50.0
[nomerge       ]    dev-lang/perl-5.12.4-r1  USE="berkdb gdbm -build -debug -doc -ithreads"
[ebuild  N     ]     sys-libs/gdbm-1.8.3-r4  USE="berkdb" 224 kB
[ebuild  N     ]      sys-libs/db-4.8.30:4.8  USE="cxx -doc -examples -java -tcl {-test}" 0 kB
[ebuild  N     ]       sys-devel/libtool-2.4-r1:2  USE="{-test} -vanilla" 0 kB
[ebuild  N     ]        sys-devel/automake-1.12.6:1.12  0 kB
[ebuild  N     ]         sys-apps/help2man-1.40.11  USE="nls" 0 kB
[ebuild  N     ]          dev-perl/Locale-gettext-1.50.0  8 kB
[ebuild  N     ]     app-admin/perl-cleaner-2.7  0 kB
[ebuild  N     ]  sys-devel/autoconf-2.69:2.5  USE="-emacs -multislot" 0 kB
[ebuild  N     ]   dev-lang/perl-5.12.4-r1  USE="berkdb gdbm -build -debug -doc -ithreads" 0 kB
[nomerge       ] app-admin/perl-cleaner-2.7
[nomerge       ]  app-shells/bash-4.2_p37  USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins -vanilla"
[ebuild  N     ]   virtual/yacc-0  0 kB
[ebuild  N     ]    sys-devel/bison-2.4.3  USE="nls -static" 0 kB
[nomerge       ] x11-misc/shared-mime-info-1.0
[nomerge       ]  dev-libs/glib-2.32.4-r1:2  USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr"
[ebuild  N     ]   dev-libs/elfutils-0.149  USE="bzip2 nls zlib -lzma" 0 kB
[ebuild  N     ]    sys-devel/flex-2.5.37  USE="nls -static {-test}" 0 kB
[ebuild  N     ]     sys-devel/gettext-0.18.2  USE="acl cxx nls openmp -cvs -doc -emacs -git -java -static-libs" 0 kB
[nomerge       ] dev-libs/glib-2.32.4-r1:2  USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr"
[nomerge       ]  sys-devel/gettext-0.18.2  USE="acl cxx nls openmp -cvs -doc -emacs -git -java -static-libs"
[nomerge       ]   virtual/acl-0-r1  USE="-static-libs"
[nomerge       ]    sys-apps/acl-2.2.51  USE="nls (-nfs) -static-libs"
[ebuild  N     ]     sys-apps/attr-2.4.46-r1  USE="nls -static-libs" 0 kB
[ebuild  N     ]    sys-apps/acl-2.2.51  USE="nls (-nfs) -static-libs" 0 kB
[ebuild  N     ]  sys-apps/sed-4.2.1-r1  USE="acl nls (-selinux) -static" 0 kB
[nomerge       ] sys-devel/automake-1.12.6:1.12
[nomerge       ]  dev-lang/perl-5.12.4-r1  USE="berkdb gdbm -build -debug -doc -ithreads"
[nomerge       ]   sys-libs/db-4.8.30:4.8  USE="cxx -doc -examples -java -tcl {-test}"
[ebuild  N     ]    sys-devel/binutils-2.22-r1  USE="cxx nls zlib -multislot -multitarget -static-libs {-test} -vanilla" 19,542 kB
[ebuild  N     ] app-shells/bash-4.2_p37  USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins -vanilla" 0 kB
[nomerge       ] sys-apps/sed-4.2.1-r1  USE="acl nls (-selinux) -static"
[ebuild  N     ]  virtual/acl-0-r1  USE="-static-libs" 0 kB

Total: 28 packages (28 new), Size of downloads: 19,773 kB

 * Error: circular dependencies:

(sys-libs/db-4.8.30::gentoo, ebuild scheduled for merge) depends on
 (sys-devel/automake-1.12.6::gentoo, ebuild scheduled for merge) (buildtime)
  (dev-lang/perl-5.12.4-r1::gentoo, ebuild scheduled for merge) (buildtime)
   (sys-libs/db-4.8.30::gentoo, ebuild scheduled for merge) (buildtime)

It might be possible to break this cycle
by applying the following change:
- dev-lang/perl-5.12.4-r1 (Change USE: -berkdb)

Note that this change can be reverted, once the package has been installed.

Note that the dependency graph contains a lot of cycles.
Several changes might be required to resolve all cycles.
Temporarily changing some use flag for all packages might be the better option



And when i try emerge this packet "dev-lang/perl-5.12.4-r1" i must emerge first this sys-apps/acl-2.2.51 (Change USE: -nls) and still one or another make cycle
Back to top
View user's profile Send private message
Maitreya
Apprentice
Apprentice


Joined: 11 Jan 2006
Posts: 190

PostPosted: Tue Apr 23, 2013 6:55 pm    Post subject: Reply with quote

Try it with

Quote:

emerge -1av --nodeps automake


Like how DONAHUE showed. It will not go trough the deps.
Back to top
View user's profile Send private message
dafqq
n00b
n00b


Joined: 17 Apr 2013
Posts: 25

PostPosted: Tue Apr 23, 2013 7:20 pm    Post subject: Reply with quote

ok its emerge now, but this is strange behaviour, any idea why so many problems in fresh system?
Back to top
View user's profile Send private message
Maitreya
Apprentice
Apprentice


Joined: 11 Jan 2006
Posts: 190

PostPosted: Tue Apr 23, 2013 8:15 pm    Post subject: Reply with quote

This is the first occurrence I have heard about.
What iso did you use? I'll try to replicate it in a VM
Back to top
View user's profile Send private message
dafqq
n00b
n00b


Joined: 17 Apr 2013
Posts: 25

PostPosted: Wed Apr 24, 2013 9:45 am    Post subject: Reply with quote

Hi, ofc i have this iso on my cd install-x86-minimal-20121213.iso now i download latest version, maybe this solve some of my problems....

Regards & thx for help:)
Back to top
View user's profile Send private message
dafqq
n00b
n00b


Joined: 17 Apr 2013
Posts: 25

PostPosted: Thu Apr 25, 2013 9:55 pm    Post subject: Reply with quote

Solved, its neccessary to mount all partition before u download stage3 not only root swap and boot ^^
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum