Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
disabling screensaver/screen timeout on gnome 2.32
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
blakdeath
Guru
Guru


Joined: 21 Sep 2012
Posts: 599

PostPosted: Fri Apr 19, 2013 2:59 pm    Post subject: disabling screensaver/screen timeout on gnome 2.32 Reply with quote

I have gnome 2.32.1 and I was wondering how I can persistently disable screen timeout and screensavers
I used the dconf editor to disable 'idle-activation-enabled'
under org --> gnome --> desktop --> screensaver
but the screen times out after around 10 minutes or so


thanks
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 4104
Location: USA

PostPosted: Tue Apr 23, 2013 2:48 pm    Post subject: Reply with quote

There's another option in the power management window "On AC Power" "Put display to sleep when inactive for:"

and mine is set for 10 minutes...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
blakdeath
Guru
Guru


Joined: 21 Sep 2012
Posts: 599

PostPosted: Tue Apr 23, 2013 3:28 pm    Post subject: Reply with quote

where can i get this power management window?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6719
Location: Goose Creek SC

PostPosted: Tue Apr 23, 2013 4:21 pm    Post subject: Reply with quote

System->Preferences->Power Management
_________________
Defund the FCC.
Back to top
View user's profile Send private message
blakdeath
Guru
Guru


Joined: 21 Sep 2012
Posts: 599

PostPosted: Tue Apr 23, 2013 6:49 pm    Post subject: Reply with quote

nope not there
is there a package I need to merge/
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 4104
Location: USA

PostPosted: Tue Apr 23, 2013 8:02 pm    Post subject: Reply with quote

This path is from the main Gnome window, not from dconf-editor... It should be installed with the default Gnome install.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
blakdeath
Guru
Guru


Joined: 21 Sep 2012
Posts: 599

PostPosted: Wed Apr 24, 2013 6:34 am    Post subject: Reply with quote

well I emerged the gnome-light package not the regular one, maybe that is why I do not have that icon?
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 382
Location: Svedala

PostPosted: Wed Apr 24, 2013 9:51 am    Post subject: Reply with quote

I had the same problem, there is a command I have put in session-start. I think it is an xset command...

LinuxQuestion.org wrote:

xset s off
xset s noblank


Try in a terminal: xset q afterwards to see if your dpms realy is off.
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 4104
Location: USA

PostPosted: Wed Apr 24, 2013 2:52 pm    Post subject: Reply with quote

I've never installed gnome-light, but this control was in gnome-power-manager.

In the full install of Gnome, simply using X11 native xset command doesn't work, or at least it didn't for me with gnome-power-manager running. They conflict with each other...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
blakdeath
Guru
Guru


Joined: 21 Sep 2012
Posts: 599

PostPosted: Wed Apr 24, 2013 7:25 pm    Post subject: Reply with quote

xset has no effect, the dpms is still enabled
Back to top
View user's profile Send private message
Woofie
Tux's lil' helper
Tux's lil' helper


Joined: 11 Sep 2010
Posts: 83
Location: Czech Rep.

PostPosted: Wed Apr 24, 2013 7:45 pm    Post subject: Reply with quote

What about

Code:

xset -dpms s off
xset +dpms s on

_________________
Sorry for my English. It's not my native language and I'm still learning it.
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 382
Location: Svedala

PostPosted: Thu Apr 25, 2013 4:45 am    Post subject: Reply with quote

blakdeath wrote:
xset has no effect, the dpms is still enabled


Here you have my .xinitrc command:
Quote:

exec startxfce4 xset -display :0 -dpms && xset -display :0 s off
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum