Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] EFI stub regression at linux-3.9-rc8
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1122

PostPosted: Tue Apr 23, 2013 12:27 pm    Post subject: [solved] EFI stub regression at linux-3.9-rc8 Reply with quote

Is someone able to run the new Linux-3.9 with EFI-stub directly?
I am only able to boot Linux-3.9 in compatibility mode :(
_________________
fun2gen2


Last edited by ulenrich on Sun Apr 28, 2013 11:22 pm; edited 2 times in total
Back to top
View user's profile Send private message
khayyam
Veteran
Veteran


Joined: 07 Jun 2012
Posts: 1533

PostPosted: Tue Apr 23, 2013 1:33 pm    Post subject: Re: Linux-3.8 runs as EFI stub but not linux-3.9-rc8 on Mac- Reply with quote

ulenrich wrote:
Is someone able to run the new Linux-3.9 with EFI-stub directly? I am only able to boot Linux-3.9 in compatibility mode

ulenrich ... I imagine this the same issue I had with eboot.c and 3.8.x ... try copying arch/x86/boot/compressed/eboot.c from 3.7 to the same location in 3.9 (probably a good idea to make a backup of eboot.c before hand).

best ... khay
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1122

PostPosted: Tue Apr 23, 2013 3:41 pm    Post subject: Reply with quote

diff linux-3.8/.../eboot.c linux-3.9/.../eboot.c
reveals a brand new function:

setup_efi_vars(boot_params);
... and one call of it, should I just comment out this one call?

But diffs on other files reveal a lot more changed regarding efi in Linux-3.9 ...
_________________
fun2gen2
Back to top
View user's profile Send private message
khayyam
Veteran
Veteran


Joined: 07 Jun 2012
Posts: 1533

PostPosted: Tue Apr 23, 2013 4:19 pm    Post subject: Reply with quote

ulenrich wrote:
diff linux-3.8/.../eboot.c linux-3.9/.../eboot.c
reveals a brand new function: setup_efi_vars(boot_params); ... and one call of it, should I just comment out this one call?

ulenrich ... as I said, I don't know if your issue is the same, different kernel, different issues ... perhaps. I simply suggested you try the solution that worked for 3.8.8.

ulenrich wrote:
But diffs on other files reveal a lot more changed regarding efi in Linux-3.9 ...

Thats quite possible, but it may function all the same with the eboot.c from 3.7 as this is used for memory addressing on boot and so not actually efi itself. Anyhow, I'd try and see, it takes only a minute to replace the file, recompile bzImage, and boot.

best ... khay
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1559
Location: Berlin, Germany

PostPosted: Tue Apr 23, 2013 10:33 pm    Post subject: Reply with quote

I am booting 3.9_rc7 EFI stub kernel on ASUS M5A97 R2.0 fine. Sometimes I noticed that kernels would fail to boot after upgrade, but it worked after powering off the computer.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1122

PostPosted: Wed Apr 24, 2013 8:46 am    Post subject: simply a regression Reply with quote

chithanh wrote:
I am booting 3.9_rc7 EFI stub kernel on ASUS M5A97 R2.0 fine. Sometimes I noticed that kernels would fail to boot after upgrade, but it worked after powering off the computer.
@chithanh,
very thanks for your info. This motivated me to retry with older Linux- 3.9_rc7
I can confirm a regression for working with EFI with a 3 years old Mac-Mini:
Linux- 3.9_rc7 efi works
Linux- 3.9_rc8 efi does NOT work
Code:
 boot # diff config-3.9.0-9997 config-3.9.0-9998
53c53
< CONFIG_LOCALVERSION="-9997"
---
> CONFIG_LOCALVERSION="-9998"
3653a3654
> CONFIG_UCS2_STRING=y

9998 == rc8 I do patch away Makefile EXTRAVERSION - I don't like.
I didn't manually enable UCS2_STRING for Linux- 3.9_rc8!
_________________
fun2gen2
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1559
Location: Berlin, Germany

PostPosted: Sun Apr 28, 2013 1:58 pm    Post subject: Reply with quote

There was one EFI boot fix after 3.9_rc8 which might apply to your situation.
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f697036b93aa7345d4cbb3c854a76456c0ddac45
Back to top
View user's profile Send private message
khayyam
Veteran
Veteran


Joined: 07 Jun 2012
Posts: 1533

PostPosted: Sun Apr 28, 2013 6:11 pm    Post subject: Reply with quote

chithanh wrote:
There was one EFI boot fix after 3.9_rc8 which might apply to your situation.

chithanh ... that seems to be the fix for the eboot.c issue I mention above.

best ... khay
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1122

PostPosted: Sun Apr 28, 2013 10:38 pm    Post subject: Reply with quote

@chithanh, thanks!
Yes, this seems to be the bug with my older MacMini:
J.Boyer wrote:
Older implementations of EFI don't have QueryVariableInfo but the runtime is a smaller structure, so the pointer to it may be pointing off into garbage. This is apparently the case with several Apple firmwares that support EFI 1.10, and the current check causes them to no longer boot.


[edit]Yes, boots again!
This will be no issue anymore with coming release (tomorrow?).
_________________
fun2gen2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum