Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
New ABI Confusion
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
chaseguard
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2004
Posts: 135

PostPosted: Sat Apr 20, 2013 6:04 am    Post subject: New ABI Confusion Reply with quote

Th new ABI (x86_32) continues to confuse me. A while ago I unmasked and installed emul-linux-x86-xlibs-20130224-r1 as a meta package because the same libraries were in x11-libs/***. After that, things were normal with portage. Now, some packages pop up (fontconfig for example) wanting a downgrade. But the packages want rid of emul-linux-x86-xlibs-20130224-r1 as a dependency. If I comment the unmasking of emul-linux-x86-xlibs-20130224-r1 I get what is shown below. Should I just mask <=media-libs/fontconfig-2.10.2 and similar packages that pop up? Is there some future where the emul-linux packages disappear replaced by the abi_x86_32? (AMD_64~ multilib.)





These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild UD ] media-libs/fontconfig-2.10.2:1.0 [2.10.2-r1:1.0] USE="-doc -static-libs" ABI_X86="(-32%*) (-64%*) (-x32%)" 0 kB
[ebuild UD ] app-emulation/emul-linux-x86-xlibs-20130224 [20130224-r1] USE="development opengl" 0 kB
[uninstall ] x11-libs/libXScrnSaver-1.2.2-r1 USE="-static-libs" ABI_X86="32 (64) (-x32)"
[blocks b ] x11-libs/libXScrnSaver[abi_x86_32] ("x11-libs/libXScrnSaver[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[uninstall ] x11-libs/libXxf86dga-1.1.3-r1 USE="-static-libs" ABI_X86="32 (64) (-x32)"
[blocks b ] x11-libs/libXxf86dga[abi_x86_32] ("x11-libs/libXxf86dga[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[uninstall ] x11-libs/libvdpau-0.5-r1 USE="dri -doc" ABI_X86="32 (64) (-x32)"
[blocks b ] x11-libs/libvdpau[abi_x86_32] ("x11-libs/libvdpau[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[uninstall ] x11-proto/scrnsaverproto-1.2.2-r1 USE="-doc" ABI_X86="32 (64) (-x32)"
[uninstall ] x11-proto/xf86dgaproto-2.1-r2 ABI_X86="32 (64) (-x32)"
[blocks B ] x11-libs/libXrandr[abi_x86_32] ("x11-libs/libXrandr[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXinerama[abi_x86_32] ("x11-libs/libXinerama[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXp[abi_x86_32] ("x11-libs/libXp[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXcursor[abi_x86_32] ("x11-libs/libXcursor[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXvMC[abi_x86_32] ("x11-libs/libXvMC[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libpciaccess[abi_x86_32] ("x11-libs/libpciaccess[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXi[abi_x86_32] ("x11-libs/libXi[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXft[abi_x86_32] ("x11-libs/libXft[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXxf86vm[abi_x86_32] ("x11-libs/libXxf86vm[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] media-libs/freetype[abi_x86_32] ("media-libs/freetype[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] <=app-emulation/emul-linux-x86-xlibs-20130224 ("<=app-emulation/emul-linux-x86-xlibs-20130224" is blocking x11-libs/libXdmcp-1.1.1-r1, x11-libs/libXtst-1.2.1-r1, x11-libs/libXt-1.1.3-r1, x11-libs/libXpm-3.5.10-r1, x11-libs/libXrandr-1.4.0-r1, x11-libs/libXcomposite-0.4.4-r1, x11-libs/libXv-1.0.7-r1, x11-proto/xineramaproto-1.2.1-r1, x11-libs/libXxf86vm-1.1.2-r1, x11-proto/printproto-1.0.5-r1, x11-proto/inputproto-2.3, x11-libs/libXdamage-1.1.4-r1, x11-proto/xf86bigfontproto-1.2.0-r1, x11-libs/libXaw-1.0.11-r2, x11-libs/libICE-1.0.8-r1, x11-libs/libvdpau-0.5-r1, x11-proto/xproto-7.0.23-r2, x11-libs/libX11-1.5.0-r1, x11-libs/libXi-1.7, x11-libs/libXinerama-1.1.2-r1, x11-libs/libXrender-0.9.7-r1, x11-libs/libXmu-1.1.1-r1, x11-libs/libXp-1.0.1-r1, media-libs/freetype-2.4.11-r2, x11-libs/libXxf86dga-1.1.3-r1, x11-proto/renderproto-0.11.1-r1, x11-proto/damageproto-1.2.1-r1, x11-proto/recordproto-1.14.2-r1, x11-proto/scrnsaverproto-1.2.2-r1, x11-libs/libXScrnSaver-1.2.2-r1, x11-libs/libXfixes-5.0-r1, x11-libs/libXext-1.3.1-r1, x11-proto/xf86vidmodeproto-2.3.1-r1, x11-libs/libSM-1.2.1-r1, x11-proto/kbproto-1.0.6-r1, x11-libs/libXau-1.0.7-r1, x11-proto/compositeproto-0.4.2-r1, dev-libs/libpthread-stubs-0.3-r1, x11-proto/xcb-proto-1.8-r2, x11-proto/randrproto-1.4.0-r1, x11-proto/xf86dgaproto-2.1-r2, x11-proto/fixesproto-5.0-r1, x11-libs/libXvMC-1.0.7-r1, x11-libs/libpciaccess-0.13.1-r1, x11-libs/libXcursor-1.1.13-r1, x11-libs/libxcb-1.9-r1, x11-proto/xextproto-7.2.1-r1, x11-proto/videoproto-2.3.1-r1, x11-libs/libXft-2.3.1-r1)
[blocks B ] x11-libs/libXau[abi_x86_32] ("x11-libs/libXau[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXfixes[abi_x86_32] ("x11-libs/libXfixes[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libxcb[abi_x86_32] ("x11-libs/libxcb[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXmu[abi_x86_32] ("x11-libs/libXmu[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXrender[abi_x86_32] ("x11-libs/libXrender[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libSM[abi_x86_32] ("x11-libs/libSM[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libICE[abi_x86_32] ("x11-libs/libICE[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXaw[abi_x86_32] ("x11-libs/libXaw[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXpm[abi_x86_32] ("x11-libs/libXpm[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXv[abi_x86_32] ("x11-libs/libXv[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXdmcp[abi_x86_32] ("x11-libs/libXdmcp[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXcomposite[abi_x86_32] ("x11-libs/libXcomposite[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXtst[abi_x86_32] ("x11-libs/libXtst[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXdamage[abi_x86_32] ("x11-libs/libXdamage[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXext[abi_x86_32] ("x11-libs/libXext[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libXt[abi_x86_32] ("x11-libs/libXt[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] media-libs/fontconfig[abi_x86_32] ("media-libs/fontconfig[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)
[blocks B ] x11-libs/libX11[abi_x86_32] ("x11-libs/libX11[abi_x86_32]" is blocking app-emulation/emul-linux-x86-xlibs-20130224)

Total: 2 packages (2 downgrades, 5 uninstalls), Size of downloads: 0 kB
Conflict: 32 blocks (29 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/fontconfig:1.0

(media-libs/fontconfig-2.10.2-r1::gentoo, installed) pulled in by
media-libs/fontconfig[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXft-2.3.1-r1::gentoo, installed)

(media-libs/fontconfig-2.10.2::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)



If you read down to here, thanks.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4613
Location: Saint Amant, Acadiana

PostPosted: Sat Apr 20, 2013 10:50 am    Post subject: Reply with quote

The culprit is downgrade of fontconfig and freetype, I unmasked installed versions and conflicts went away.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Maitreya
Apprentice
Apprentice


Joined: 11 Jan 2006
Posts: 217

PostPosted: Sat Apr 20, 2013 10:52 am    Post subject: Reply with quote

setting USE="abi_x86_32 abi_x86_x32" and ABI_X86="32 x32"
And keywording the emul packages with ~amd64 solved it.
I do not know if it's the right way to do it but it worked for me.
Back to top
View user's profile Send private message
blietaer
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2006
Posts: 103

PostPosted: Sun Apr 21, 2013 11:31 am    Post subject: Reply with quote

Yeah abi is still getting my config into trouble here too...

Code:

emerge -auvDN world:
Total: 21 packages (18 upgrades, 2 downgrades, 1 new), Size of downloads: 24,286 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/fontconfig:1.0

  (media-libs/fontconfig-2.10.2-r1::gentoo, installed) pulled in by
    media-libs/fontconfig[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)
    media-libs/fontconfig[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXft-2.3.1-r1::gentoo, installed)

  (media-libs/fontconfig-2.10.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/freetype:2

  (media-libs/freetype-2.4.11::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/freetype-2.4.11-r2::gentoo, installed) pulled in by
    media-libs/freetype[abi_x86_32] required by (app-emulation/emul-linux-x86-xlibs-20130224-r1::gentoo, installed)
    >=media-libs/freetype-2.2.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/fontconfig-2.10.2-r1::gentoo, installed)
    media-libs/freetype[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXft-2.3.1-r1::gentoo, installed)

dev-util/geany:0

  (dev-util/geany-1.22-r1::gentoo, installed) pulled in by
    ~dev-util/geany-1.22 required by (x11-themes/geany-themes-1.22.2::gentoo, installed)

  (dev-util/geany-1.23::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


I only have one line in make.conf about ABI:
Code:
ABI_X86="64 32"


Should I put USE flags too ?
Back to top
View user's profile Send private message
chaseguard
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2004
Posts: 135

PostPosted: Mon Apr 22, 2013 1:30 pm    Post subject: Reply with quote

Yes, I unmask these packages and all the warnings do go away:

=media-libs/fontconfig-2.10.2-r1
=x11-libs/libXft-2.3.1-r1

But my puzzlement remains, what will happen with this ABI issue in the long term? Hopefully a growing list of unmasked packages is not the answer. If the x11 libs now have the 32 bit info provided by emul-linux, then all the packages that need the 32 bit files should be changed to accomodate.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum