Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved ;)]wireless shows up as ethernet on 'ifconfig'
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
adubschavy
n00b
n00b


Joined: 19 Apr 2013
Posts: 5

PostPosted: Fri Apr 19, 2013 5:57 am    Post subject: [solved ;)]wireless shows up as ethernet on 'ifconfig' Reply with quote

Hey guys,

I just installed gentoo and rebooted, and my wireless does not work. My wireless shows up as ethernet for some reason.

ifconfig -a
Code:

enp2s0f2: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 20:6a:8a:90:b5:9d  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

sit0: flags=128<NOARP>  mtu 1480
        sit  txqueuelen 0  (IPv6-in-IPv4)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 20:68:9d:ab:c3:34  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


cat /etc/conf.d/net
Code:

# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc*/net.example* and save your configuration
# in /etc/conf.d/net (this file :]!).
config_wlp3s0="dhcp"
config_wlan0="dhcp"
config_eth0="dhcp"


let me know if you guys need me to run any other commands to better help you guys help me.
thank you


Last edited by adubschavy on Sun Apr 21, 2013 3:25 am; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6516
Location: Goose Creek SC

PostPosted: Fri Apr 19, 2013 6:29 am    Post subject: Reply with quote

read latest udev news
Code:
eselect news read all
decide whether you wish to use kernel assigned names eth0, wlan0 or the udev assigned names enp2s0f2, wlp3s0 . then
either
create: If /etc/udev/rules.d/80-net-name-slot.rules is an empty file or a
symlink to /dev/null, the new names will be disabled and the kernel will
do all the interface naming, and the resulting names may vary by kernel
configuration, hardware configuration and kernel version. After which you can use eth0 and wlan0
or
run
Code:
 ifconfig -a
which should give the device names that udev has assigned, check against my copy of your copy below
create symlinks, add to run level, start, check on them
cd /etc/init.d
ln -s net.lo net.wlp3s0 #wireless
ln -s net.lo net.enp2s0f2 #wired
rc-update add net.wlp3s0 default
rc-update add net.enp2s0f2 default
/etc/init.d/net.wlp3s0 restart
/etc/init.d/net.enp2s0f2 restart
ifconfig
_________________
Defund the FCC.


Last edited by DONAHUE on Fri Apr 19, 2013 12:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
adubschavy
n00b
n00b


Joined: 19 Apr 2013
Posts: 5

PostPosted: Fri Apr 19, 2013 10:35 am    Post subject: Reply with quote

You miss understood me. wlp3s0 is supposed to be a wireless adapter but it shows up as an eternity adapter. I have the ath9k module loaded and the related gigabit module.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Fri Apr 19, 2013 10:54 am    Post subject: Reply with quote

From the perspective of a tool that deals in IPs (like ifconfig), there's no difference between a wired and a wireless adapter. Both transmit/receive ethernet frames.

The reason your wireless doesn't work, going from the configs you posted, is that you haven't configured it.
Back to top
View user's profile Send private message
adubschavy
n00b
n00b


Joined: 19 Apr 2013
Posts: 5

PostPosted: Sat Apr 20, 2013 11:47 pm    Post subject: Reply with quote

ok i set up my wireless according to the wiki and the same problem persists:

/etc/conf.d/net
Code:

# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc*/net.example* and save your configuration
# in /etc/conf.d/net (this file :]!).

modules="wpa_supplicant"

config_wlan0="dhcp"

wpa_supplicant_wlan0="-Dwext"


/etc/wpa_supplicant/wpa_supplicant.conf
Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=1

network={
   ssid="Stop Procrastinating"
   psk="1234567890"
}


the network I am trying to connect is wpa2

ifconfig -a
Code:

eth0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 20:6a:8a:90:b5:9d  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 8  bytes 560 (560.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 560 (560.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

sit0: flags=128<NOARP>  mtu 1480
        sit  txqueuelen 0  (IPv6-in-IPv4)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 20:68:9d:ab:c3:34  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0



I will post the results of net.wlan0 restart soon
Back to top
View user's profile Send private message
adubschavy
n00b
n00b


Joined: 19 Apr 2013
Posts: 5

PostPosted: Sun Apr 21, 2013 12:08 am    Post subject: Reply with quote

net.wlan0 restart
Code:

net.wlan0   | * Bringing down interface wlan0
net.wlan0   | *   Removing addresses
net.wlan0   | *     Stopping wpa_cli on wlan0 ...
net.wlan0   | *     Stopping wpa_supplicant on wlan0 ...
net.wlan0   | * Bringing up interface wlan0
net.wlan0   | *   Starting wpa_supplicant on wlan0 ...
net.wlan0   |iotctl[SIOCSIWPMKSA]: Invalid argument
net.wlan0   |iotctl[SIOCSIWMODE]: Invalid argument
net.wlan0   |iotctl[SIOCSIWRANGE]: Invalid argument
net.wlan0   |iotctl[SIOCSIWMODE]: Invalid argument
net.wlan0   |iotctl[SIOCSIWAP]: Invalid argument
net.wlan0   |iotctl[SIOCSIWENCODEEXT]: Invalid argument
net.wlan0   |iotctl[SIOCSIWENCODEEXT]: Invalid argument
net.wlan0   |iotctl[SIOCSIWENCODEEXT]: Invalid argument
net.wlan0   |iotctl[SIOCSIWENCODEEXT]: Invalid argument
net.wlan0   |iotctl[SIOCSIWPMKSA]: Invalid argument
net.wlan0   | *   Starting wpa_cli on wlan0 ...
net.wlan0   | *   Backgrounding ...
net.wlan0   | * WARNING: net.wlan0 has started, but is inactive

I had to type this out by hand because 'net.wlan0 > file' didn't work so good. so if something is misspeled dont worry about it.

I can't connect to the network. let me know If you guys need more info to help me out.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6516
Location: Goose Creek SC

PostPosted: Sun Apr 21, 2013 12:24 am    Post subject: Reply with quote

/etc/conf.d/net:
Quote:
modules_wlan0="wpa_supplicant"
#wpa_supplicant_wlan0="-Dwext"
wpa_supplicant_wlan0="-Dnl80211"
wpa_timeout_wlan0=15
iwconfig_wlan0_mode="Managed"
config_wlan0="dhcp"
dhcpcd_wlan0="-t 10"

/etc/wpa_supplicant/wpa_supplicant.conf:
Code:
DIR=/var/run/wpa_supplicant GROUP=wheel
ap_scan=1
update_config=1

menuconfig
Quote:
[*] Networking support --->
-*- Wireless --->
<M> cfg80211 - wireless configuration API
<M> Generic IEEE 802.11 Networking Stack (mac80211)
Device Drivers --->
[*] Network device support --->
Wireless LAN --->
<M> Atheros Wireless Cards --->
<M> Atheros 5xxx wireless cards support
keep
Quote:
[*] cfg80211 wireless extensions compatibility
if you want to but ath5k wants nl80211 which is built in.

If you have a GUI and wpa_supplicant was emerged with qt4 you can use wpa_gui to configure and save your network.
If wpa_gui is not available:
Code:
emerge iw
iw wlan0 scan
Use the values returned to set up your network in wpa_supplicant.conf:
Quote:
network={
ssid="yourssid"
proto=yourproto
key_mgmt=your key management
pairwise=your pairwise
group=your group
psk="your psk"
priority=your priority, will not be in the return, not required
}


Ensure that no vestige of wicd or networkmanager exists on your machine. Ensure that wpa_supplicant and dhcp are not in any run level (rc-update show).
_________________
Defund the FCC.
Back to top
View user's profile Send private message
adubschavy
n00b
n00b


Joined: 19 Apr 2013
Posts: 5

PostPosted: Sun Apr 21, 2013 3:28 am    Post subject: Reply with quote

Thank you. You have given me much to study about networking :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum