Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
User rights
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
nikitas350
n00b
n00b


Joined: 09 Sep 2009
Posts: 19

PostPosted: Sun Apr 14, 2013 10:47 am    Post subject: User rights Reply with quote

Hi,

I just installed gentoo with stage 3, and setted up everything.
I've installed gnome too, but the problem is that even though I am a sudoer and member of all the relevant groups, i can't do basic operations like mounting a usb, connecting to a wireless with NetworkManager etc.

I've installed policykit but couldn't figure out what is happening.
Can you give me some guidelines on what should I read about understanding and fixing the permissions?

Thanks a lot

Nikitas
Back to top
View user's profile Send private message
DirtyHairy
l33t
l33t


Joined: 03 Jul 2006
Posts: 604
Location: Würzburg, Deutschland

PostPosted: Mon Apr 15, 2013 6:37 am    Post subject: Reply with quote

Sounds like dbus not running. Please check "eselect rc list" whether dbus is included in your default runlevel, add it if not.
Back to top
View user's profile Send private message
nikitas350
n00b
n00b


Joined: 09 Sep 2009
Posts: 19

PostPosted: Tue Apr 16, 2013 10:37 am    Post subject: Reply with quote

It's running on default. :?
[edit]
Well, after playing a little bit with polkit, I've made it work.
Sorry for the stupid questions.

Thanks!
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7825

PostPosted: Wed Apr 17, 2013 3:46 am    Post subject: Reply with quote

nikitas350 wrote:
Well, after playing a little bit with polkit, I've made it work.
Which raises the question: what did you need to do to make it work?
nikitas350 wrote:
Sorry for the stupid questions.
The wiki entries appear to mostly assume that it will just work when installed and running, so wondering why it did not work hardly seems stupid. Not to mention, even if it is a mistake only someone totally unfamiliar with polikt would make, not everyone who tries to use it is familiar with it.
Back to top
View user's profile Send private message
nikitas350
n00b
n00b


Joined: 09 Sep 2009
Posts: 19

PostPosted: Fri Apr 19, 2013 11:47 am    Post subject: Reply with quote

desultory wrote:
nikitas350 wrote:
Well, after playing a little bit with polkit, I've made it work.
Which raises the question: what did you need to do to make it work?
nikitas350 wrote:
Sorry for the stupid questions.
The wiki entries appear to mostly assume that it will just work when installed and running, so wondering why it did not work hardly seems stupid. Not to mention, even if it is a mistake only someone totally unfamiliar with polikt would make, not everyone who tries to use it is familiar with it.



At first I tried playing with the polkit configuration files, but then i used this guide:

http://forums.gentoo.org/viewtopic-t-858965-highlight-.html

I had a lot of essential packets not installed, and also gdm was not set up.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum