Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] unity-gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 24, 25, 26  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Wed Apr 10, 2013 5:13 pm    Post subject: Reply with quote

brothermechanic wrote:
shiznix, can you remove ubuntuone from depends or make it with use flag?
Than you for overlay!

I only looked at doing this today but haven't done so for the following reason.
In keeping with the idea that once unity-meta is emerged you should pretty much have a base desktop experience that is as close to what you would get on Ubuntu (and even better in some respects, such as systray functionality).

Unity-lens-music is part of that base experience, and it requires rhythmbox-ubuntuone which in turn requires all the ubuntuone stuff.
Another package that requires ubuntuone is indicator-sync (just realised should add ubuntuone as an RDEPEND for that).

Of course you could always roll your own unity-meta ebuild for your local overlay that doesn't include unity-lens-music and indicator-sync if you wish.
Then you can unmerge all the ubuntuone stuff and not worry about ubuntuone being pulled in ;)

EDIT: Since moved all the indicator ebuilds into unity-indicators/ category and all the lens ebuilds into unity-lenses/ category and created unity-lens-meta and unity-indicators-meta ebuilds.
Lenses and indicators are now enabled/disabled via USE flags and all are enabled by default to provide that base desktop posted about earlier.
This means that if you disable the 'music' USE flag for unity-lens-meta, it will not install the unity-lens-music package and so won't trigger the installation of all the UbuntuOne packages as it won't need rhythmbox-ubuntuone.


Last edited by shiznix on Sat Apr 13, 2013 8:42 am; edited 1 time in total
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Sat Apr 13, 2013 7:52 am    Post subject: Reply with quote

Hi, shiznix.
Can you add media-plugins/gst-plugins-ffmpeg-1.x to your overlay ( it needed for videothumbs), because in portage is only media-plugins/gst-plugins-libav-1.0.5

Thank you.
Back to top
View user's profile Send private message
yaront
n00b
n00b


Joined: 18 Jan 2012
Posts: 16

PostPosted: Sat Apr 13, 2013 9:49 am    Post subject: Reply with quote

I haven't really been following, are the Raring packages the only ones supported now?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Sat Apr 13, 2013 10:03 am    Post subject: Reply with quote

brothermechanic wrote:
Hi, shiznix.
Can you add media-plugins/gst-plugins-ffmpeg-1.x to your overlay ( it needed for videothumbs), because in portage is only media-plugins/gst-plugins-libav-1.0.5

Thank you.

Hey brothermechanic, what needs it for videothumbs ?

gst-plugins-ffmpeg stops at 0.10.13 for gstreamer:0.10 and becomes gst-plugins-libav for gstreamer:1.0, see here -> http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-1.x-README.txt

Latest gst-plugins-libav in portage is 1.1.0_pre20130128.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Sat Apr 13, 2013 10:59 am    Post subject: Reply with quote

All ebuilds are bumped up to Raring release (FinalBeta) now.
Raring FinalRelease happens on April 25th.

Was hoping to have Raring packages missing keyword masked until the final release date but my hand has been forced partly by the sheer effort needed to maintain two streams of package releases (ie. Quantal and Raring), and partly in keeping the overlay gnome packages in sync with gnome packages in the portage tree.

I'll try not to bore with too much detail, but the big packages holding the Raring upgrade back were dev-libs/glib-2.36 and gcc:4.8.
glib-2.36 and gcc:4.8 made it into the portage tree just as Unity's nautilus-3.6 patchset required glib-2.36, and unity-7.0 required gcc:4.8.
Unity-7.0 could have been kept masked, but we needed to move forward with nautilus-3.6 patchset and glib-2.36 to keep the gnome-3.6 packages in sync with main tree anyway.

Everything has been hugely tested and I'm very impressed with the shiny new features.
A quick rundown here -> https://www.youtube.com/watch?v=ySJhFCtVTUQ

The only packages that have not been bumped to Raring are rhythmbox-ubuntuone and appmenu-libreoffice, these are still working ok as Quantal versions.
appmenu-libreoffice is going through some upstream changes to make it ready for Raring.
rhythmbox-ubuntuone has had it's rhythmbox music store user interface removed in Raring in favour of the web store as a webapp instead -> http://launchpadlibrarian.net/127944616/rhythmbox-ubuntuone_4.1.2-0ubuntu1_source.changes
For now the rhythmbox UbuntuOne music store UI still works until it gets upgraded to the Raring version.

Any problems, changes or additions, don't hesitate to post here or as issues on the github project page.
And if you're interested in helping maintain the overlay ebuilds, drop me a PM.
Thanks! 8)

Also, if anyone can provide a decent Gentoo logo for the launcher's Dash HUD (top icon on the launcher), I'd be happy to include it instead of the Canonical logo.
Back to top
View user's profile Send private message
yaront
n00b
n00b


Joined: 18 Jan 2012
Posts: 16

PostPosted: Sat Apr 13, 2013 1:40 pm    Post subject: Reply with quote

shiznix, have you considered trying to get your awesome work into the main tree?
Back to top
View user's profile Send private message
javispedro
n00b
n00b


Joined: 11 Mar 2013
Posts: 13

PostPosted: Sat Apr 13, 2013 2:00 pm    Post subject: Reply with quote

Why do raring packages require gcc 4.8? Ubuntu only ships with 4.7.

EDIT: Oh, I see the problem. Ubuntu ships with 4.7.3 which is not in portage yet. Maybe you could change the DEPEND to >= gcc 4.7.3? 4.8.0 has a incredibly large performance regression for a program I use.
(Though I obviously can just install both compilers, so it is not very important).
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Mon Apr 15, 2013 12:56 pm    Post subject: Reply with quote

BUG BUG BUG
The compilation of unity-base/nux-4.0.0_p0_p01 get error http://bpaste.net/show/91497/
The compilation of unity-base/unity-7.0.0_p0_p01 get error http://bpaste.net/show/91492/
The x11-themes/unity-asset-pool-0.8.24_p0_p01 has collision with skype
Code:

 * package x11-themes/unity-asset-pool-0.8.24_p0_p01 NOT merged
 *
 * Detected file collision(s):
 *
 *      /usr/share/icons/hicolor/32x32/apps/skype.png
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * net-im/skype-4.1.0.20:0::gentoo
 *      /usr/share/icons/hicolor/32x32/apps/skype.png

Please fix.


Last edited by brothermechanic on Mon Apr 15, 2013 1:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
javispedro
n00b
n00b


Joined: 11 Mar 2013
Posts: 13

PostPosted: Mon Apr 15, 2013 1:04 pm    Post subject: Reply with quote

brothermechanic wrote:
The compilation of unity-base/unity-7.0.0_p0_p01 get error http://bpaste.net/show/91492/

What's /etc/portage/patches//unity-base/unity/launcher.patch ? unity-base/unity builds perfectly here (even with LTO). The problem is with that file.

I can reproduce the Skype conflict, though.
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Mon Apr 15, 2013 1:09 pm    Post subject: Reply with quote

>What's /etc/portage/patches//unity-base/unity/launcher.patch?
Oh! I am so sorry! that's my patch)))) Surry for that)))

But, what about others bugs?
Back to top
View user's profile Send private message
javispedro
n00b
n00b


Joined: 11 Mar 2013
Posts: 13

PostPosted: Mon Apr 15, 2013 1:12 pm    Post subject: Reply with quote

brothermechanic wrote:
The compilation of unity-base/nux-4.0.0_p0_p01 get error http://bpaste.net/show/91497/.

You need to either add this patch to media-libs/glew http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/raring/glew/raring/view/head:/debian/patches/git_glxew_export_fix.patch

OR mask >=media-libs/glew-1.7.0 (aka ensure only glew 1.6.0-r1 is installed)

I personally use the second option -- ever since I first enabled the Unity overlay.
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Mon Apr 15, 2013 1:31 pm    Post subject: Reply with quote

Thank you! I return to old glew-1.6
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Mon Apr 15, 2013 1:48 pm    Post subject: Reply with quote

Solved!
I create nano /etc/portage/env/net-im/skype
Code:

src_install() {
        into /opt
        dobin ${PN}
        fowners root:audio /opt/bin/${PN}

        insinto /etc/dbus-1/system.d
        doins ${PN}.conf

        insinto /usr/share/skype
        doins -r avatars lang sounds

        dodoc README

#       local res
#       for res in 16 32 48; do
#               newicon -s ${res} icons/SkypeBlue_${res}x${res}.png ${PN}.png
#       done

        make_desktop_entry ${PN} 'Skype VoIP' ${PN} 'Network;InstantMessaging;Telephony'

        if use pax_kernel; then
                pax-mark Cm "${ED}"/opt/bin/${PN} || die
                eqawarn "You have set USE=pax_kernel meaning that you intend to run"
                eqawarn "${PN} under a PaX enabled kernel.  To do so, we must modify"
                eqawarn "the ${PN} binary itself and this *may* lead to breakage!  If"
                eqawarn "you suspect that ${PN} is being broken by this modification,"
                eqawarn "please open a bug."
        fi

        echo PRELINK_PATH_MASK=/opt/bin/${PN} > ${T}/99${PN}
        doenvd "${T}"/99${PN} #430142
}


and collision solved!

Sorry for noise)))
Back to top
View user's profile Send private message
javispedro
n00b
n00b


Joined: 11 Mar 2013
Posts: 13

PostPosted: Mon Apr 15, 2013 6:09 pm    Post subject: Reply with quote

By the way, notify-osd is kind a of must install in order to get Unity-style notifications, yet unity-meta does not depend on it.

Sadly, Gentoo's gnome-fallback depends on notification-daemon, which conflicts with notify-osd :(

No idea how to fix at the moment other than just changing the gnome-fallback ebuild. Does not seem to break anything.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Tue Apr 16, 2013 2:38 am    Post subject: Reply with quote

Some fixes:
* unity-base/unity now deps. on >=sys-devel/gcc-4.7.3 so it can use that when it becomes available in portage tree and can still use gcc:4.8 in the meantime
* net-im/skype file collision is fixed
* media-libs/glew versions for nux and compiz have been fixed. Nux is fine with <glew-1.8.0 and compiz can use any currently available glew version.

Thanks for reporting :)
Haven't looked at x11-misc/notify-osd yet.

Have started converting the libs. ebuilds and the ebuilds that depend on them over to EAPI5 with subslotting.
There won't be any noticeable difference yet until packages start to get upgraded into the future, then those packages that need to be rebuilt against upgraded libs. will automatically do so.
Only done bamf, compiz, dee and nux so far.

@yaront
That'd certainly be nice, and some other main tree devs. have shown some interest in that.
But we may have to wait for next Ubuntu release to see where they go with the unity-next/mir project.
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Tue Apr 16, 2013 5:28 am    Post subject: Reply with quote

Hi
Now i get this
emerge unity-asset-pool
Code:

rm: cannot remove '/usr/share/icons/hicolor/32x32/apps/skype.png': Permission denied


And after upgrade to gcc-4.8 i can't compile gnome-extra/nm-applet-0.9.8.0_p1_p02
http://bpaste.net/show/91699/

Please fix.

Thank you for work!

[added]
I have a segmentation fault with gnome-base/gnome-control-center-3.6.3_p0_p24
Code:

$ gnome-control-center
Segmentation fault

my sys-libs/glibc version is 2.15-r3
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Wed Apr 17, 2013 6:20 am    Post subject: Reply with quote

brothermechanic wrote:
Hi
Now i get this
emerge unity-asset-pool
Code:

rm: cannot remove '/usr/share/icons/hicolor/32x32/apps/skype.png': Permission denied

This should be fixed now.

brothermechanic wrote:
And after upgrade to gcc-4.8 i can't compile gnome-extra/nm-applet-0.9.8.0_p1_p02
http://bpaste.net/show/91699/

Please fix.

Thank you for work!

Yes it seems many are having some problems with gcc-4.8 (note I can't reproduce the error you get but our USE flags for networkmanager probably differ), however unity-base/unity simply will not build with anything lower than gcc-4.7.3 and that's not in portage tree yet.
Some options may be to patch unity-base/unity to be <gcc-4.7.3 compatible, or add gcc-4.7.3 to the overlay, or live with it in the hope gcc-4.7.3 makes it into Gentoo over the next few days and in the meantime switch gcc-config to gcc:4.8 only for the emerge of unity-base/unity.

brothermechanic wrote:
[added]
I have a segmentation fault with gnome-base/gnome-control-center-3.6.3_p0_p24
Code:

$ gnome-control-center
Segmentation fault

my sys-libs/glibc version is 2.15-r3

What is happening when it segfaults ?
Does it segfault immediately on trying to run it, or is it segfaulting when you click on a particular setting in gnome-control-center ?
Also, can you provide a gdb backtrace like this:
Code:
$ gdb gnome-control-center

Type 'run' when prompted by gdb, then when it segfaults, type 'bt full' at the gdb prompt, paste the output in a post here.
Thanks ;)
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Thu Apr 18, 2013 7:22 am    Post subject: Reply with quote

Hi
Thank you for skype fix!

I switch to gcc-4.8 for upgrade to unity-base/unity-7, and all fine, but nm-applet don't compile yet.

I folow your instructions, reinstall gnome-control-center: USE="debug" emerge -1av gnome-control-center, and run gdb
Code:

$ gdb gnome-control-center
GNU gdb (Gentoo 7.5.1 p2) 7.5.1
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/gnome-control-center...(no debugging symbols found)...done.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Sat Apr 20, 2013 7:07 am    Post subject: Reply with quote

brothermechanic wrote:
Hi
Thank you for skype fix!

I switch to gcc-4.8 for upgrade to unity-base/unity-7, and all fine, but nm-applet don't compile yet.

I folow your instructions, reinstall gnome-control-center: USE="debug" emerge -1av gnome-control-center, and run gdb
Code:

$ gdb gnome-control-center
GNU gdb (Gentoo 7.5.1 p2) 7.5.1
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/gnome-control-center...(no debugging symbols found)...done.

So far so good.
Did you manage to get it to segfault through gdb ?
Still need that backtrace if it's still a problem.

Once it segfaults, then type 'bt full' at the gdb prompt and post the output here, thanks ;)
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Sun Apr 21, 2013 4:57 am    Post subject: Reply with quote

shiznix wrote:
renegart wrote:
Small question about 'auto mount' of USB-sticks in Unity.
Every time I plugin a USB-Stick under Unity, a program with the 'free disk space' is opened instead of nautilus. Also the created launcher icon opens this disk usage program. How can I change the behaviour to open the nautilus?

What is this program called ?
Do you get the same behaviour when plugging a usb stick in while inside a Gnome session ?

I was hit by this recently and it occurs because I missed installing nautilus-folder-handler.desktop file.
This provides the inode/directory mimetype as specified in /usr/share/gnome/applications/defaults.list so when it wasn't available it fell through to the next available application that provides an inode/directory mimetype which happens to be baobab.
Back to top
View user's profile Send private message
russK
Apprentice
Apprentice


Joined: 27 Jun 2006
Posts: 220

PostPosted: Thu Apr 25, 2013 11:55 pm    Post subject: Reply with quote

shiznix wrote:

So far so good.
Did you manage to get it to segfault through gdb ?
Still need that backtrace if it's still a problem.

Once it segfaults, then type 'bt full' at the gdb prompt and post the output here, thanks ;)


I had the gnome-control-center segfault too, but I managed to make it go away.

The USE="debug" emerge did not keep it from stripping the symbols, so the backtrace only showed that it was in libclutter.so when it crashed.

I took it as an opportunity to upgrade my clutter-gtk to 1.4.4 with
Code:
emerge --ask  =media-libs/clutter-gtk-1.4.4 --autounmask-write


In the process it updated three clutter related packages. I now have:
Code:
equery list -f clutter
 * Searching for clutter ...
[IP-] [  ] media-libs/clutter-1.14.2:1.0
[IP-] [  ] media-libs/clutter-gst-2.0.0:2.0
[IP-] [  ] media-libs/clutter-gtk-1.4.4:1.0
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Fri Apr 26, 2013 7:57 am    Post subject: Reply with quote

russK wrote:
I had the gnome-control-center segfault too, but I managed to make it go away.

The USE="debug" emerge did not keep it from stripping the symbols, so the backtrace only showed that it was in libclutter.so when it crashed.

I took it as an opportunity to upgrade my clutter-gtk to 1.4.4 with
Code:
emerge --ask  =media-libs/clutter-gtk-1.4.4 --autounmask-write


In the process it updated three clutter related packages. I now have:
Code:
equery list -f clutter
 * Searching for clutter ...
[IP-] [  ] media-libs/clutter-1.14.2:1.0
[IP-] [  ] media-libs/clutter-gst-2.0.0:2.0
[IP-] [  ] media-libs/clutter-gtk-1.4.4:1.0

That's some good info!
Interesting that it went away after upgrading those clutter packages.
I'm still using the old versions clutter-1.12.2 and clutter-gtk-1.4.2 and don't get the segfault (also using clutter-gst-2.0.2).
So maybe one or all of those clutter packages simply needed rebuilding (perhaps triggered by the glib-2.36 upgrade) ?

BTW, to stop the debug symbols being stripped you can use the following:
Code:
FEATURES="nostrip splitdebug" USE="debug" CFLAGS="${CFLAGS} -ggdb"

Which I easily forget so I set a bash alias.
/etc/bash/bashrc
Code:
alias DEBUG='FEATURES="nostrip splitdebug" USE="debug" CFLAGS="${CFLAGS} -ggdb"'

Then all I need to remember is 'DEBUG emerge whatever' ;)
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Sat Apr 27, 2013 5:54 pm    Post subject: Reply with quote

Hi all)))
Still gnome-control-center don't start)))
And have a problem with dev-libs/libdbusmenu
Code:

* ERROR: dev-libs/libdbusmenu-12.10.3_p0_p01 failed (prepare phase):
 *   No installed vala in || ( dev-lang/vala:0.20[vapigen] )

and http://bpaste.net/show/94642/

Thank you for overlay!
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Sun Apr 28, 2013 2:12 am    Post subject: Reply with quote

brothermechanic wrote:
Hi all)))
Still gnome-control-center don't start)))
And have a problem with dev-libs/libdbusmenu
Code:

* ERROR: dev-libs/libdbusmenu-12.10.3_p0_p01 failed (prepare phase):
 *   No installed vala in || ( dev-lang/vala:0.20[vapigen] )

and http://bpaste.net/show/94642/

Thank you for overlay!

OK the vala issue should be fixed now.

RE: gnome-control-center not starting
shiznix wrote:
Did you manage to get it to segfault through gdb ?
Still need that backtrace if it's still a problem.

Once it segfaults, then type 'bt full' at the gdb prompt and post the output here, thanks ;)

Also, did you try rebuilding your clutter packages ?
russK's upgrading those clutter packages fixed gnome-control-center for him above ^^
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Sun Apr 28, 2013 7:11 am    Post subject: Reply with quote

I try to upgrade clutter to 1.14 versoin and give new problem with dev-libs/libunity-misc http://bpaste.net/show/94785/

And, please fix problem with dev-libs/libdbusmenu-12.10.3_p0_p01
Code:

* Running aclocal -I m4 ...
 [ !! ]

 * Failed Running aclocal !

http://bpaste.net/show/94642/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 24, 25, 26  Next
Page 19 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum