Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
locales not defined after boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
DeIM
Tux's lil' helper
Tux's lil' helper


Joined: 11 Apr 2006
Posts: 128

PostPosted: Wed Apr 10, 2013 6:45 pm    Post subject: locales not defined after boot Reply with quote

Hi, I have problem with locales:
Code:
$ locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

Code:
$ cat /etc/env.d/02locale
LANG="cs_CZ.utf8"

Code:
$ locale -a
C
POSIX
cs_CZ
cs_CZ.iso88592
cs_CZ.utf8
czech
en_US
en_US.iso88591
en_US.utf8


after boot I have POSIX locales :(

Code:
$ source /etc/profile
$ locale
LANG=cs_CZ.utf8
LC_CTYPE="cs_CZ.utf8"
LC_NUMERIC="cs_CZ.utf8"
LC_TIME="cs_CZ.utf8"
LC_COLLATE="cs_CZ.utf8"
LC_MONETARY="cs_CZ.utf8"
LC_MESSAGES="cs_CZ.utf8"
LC_PAPER="cs_CZ.utf8"
LC_NAME="cs_CZ.utf8"
LC_ADDRESS="cs_CZ.utf8"
LC_TELEPHONE="cs_CZ.utf8"
LC_MEASUREMENT="cs_CZ.utf8"
LC_IDENTIFICATION="cs_CZ.utf8"
LC_ALL=
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5263

PostPosted: Wed Apr 10, 2013 9:21 pm    Post subject: Reply with quote

Hm, all I need to do is edit /etc/locale.gen and then run locale-gen. Have you tried that?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4269

PostPosted: Wed Apr 10, 2013 11:07 pm    Post subject: Re: locales not defined after boot Reply with quote

DeIM wrote:

Code:
$ cat /etc/env.d/02locale
LANG="cs_CZ.utf8"

Code:


Assuming it was well done in locale.gen, change to
Code:
$ cat /etc/env.d/02locale
LANG="cs_CZ.UTF-8"
Back to top
View user's profile Send private message
DeIM
Tux's lil' helper
Tux's lil' helper


Joined: 11 Apr 2006
Posts: 128

PostPosted: Fri Apr 12, 2013 2:23 pm    Post subject: Reply with quote

now I found I have "cs_CZ.UTF-8" in console (login in terminal Ctrl+Alt+F1).
But when I login to openbox (by slim) and open console emulator (roxterm) it's set to "POSIX".
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4269

PostPosted: Fri Apr 12, 2013 2:26 pm    Post subject: Reply with quote

then reread the doc about utf8 and localization to fix locale.gen part
Back to top
View user's profile Send private message
DeIM
Tux's lil' helper
Tux's lil' helper


Joined: 11 Apr 2006
Posts: 128

PostPosted: Sat Apr 13, 2013 4:48 pm    Post subject: Reply with quote

my locale.gen contains only:
Code:
cs_CZ ISO-8859-2
cs_CZ.UTF-8 UTF-8
en_US ISO-8859-1
en_US.UTF-8 UTF-8


/usr/share/i18n/SUPPORTED includes:
Code:
cs_CZ.UTF-8 UTF-8
cs_CZ ISO-8859-2


only different is locale -a:
Code:
C
POSIX
cs_CZ
cs_CZ.iso88592
cs_CZ.utf8
czech
en_US
en_US.iso88591
en_US.utf8


in guide:
Code:
# locale -a | grep 'cs_CZ'
cs_CZ
cs_CZ.UTF-8
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4269

PostPosted: Sat Apr 13, 2013 9:45 pm    Post subject: Reply with quote

All looking fine for me. I don't know, try rebuild slim and the term.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum