Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Keyboard partially not working in enlightenment
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
relkai
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 96
Location: Hamburg, Germany

PostPosted: Fri Apr 05, 2013 1:31 pm    Post subject: [solved] Keyboard partially not working in enlightenment Reply with quote

Hi Guys and Gals,

This is a really strange problem and again I'm very sure that I misconfigured anything.

The background:
I've got a headless server to which I only connect using SSH and VNC (for the few mandatory GUIs like mythtv-setup).
Until now I used iceWM for VNC because it's small and lightning fast.
After many years using iceWM I just don't like the minimalistic interface anymore and decided to give enlightenment/e17 a shot.
It really looks modern and stylish without eating up too much resources.

The problem:
Some of my keys aren't working in enlightenment.
For example if I start xterm and try to type anything, some keys just don't do anything.

The following keys are working:
qetzuopghjycvbüöä1234567890ß´,.-#+

These keys aren't working:
wriasdfklxnm

If I switch VNC back to iceWM, all keys are working again in xterm.

The most strange thing:
If I hold the "Alt" key pressed while using the non working keys, all characters are being typed correctly.

To my understanding, there can't be a problem with my VNC or Xorg configs, otherwise I should have the same problem in iceWM.
In enlightenment I selected the german keyboard layout and also tried to change some options using setxkbmap, but nothing seems to solve this issue.

Google also isn't very helpful and I seem to be the only one with this kind of problem.

Thanks,
relkai
_________________
Server: Pentium D-3,2GHz / 2 GB DDR-RAM / TerraTec Cynergy 1400 DVB-T
Notebook: IBM Thinkpad T60 / Core 2 Duo 2,2GHz / 2GB DDR-RAM / Intel 945GM
MythTV Box: Zotac ZBOX HD-ID33 1,8GHz / 2 GB DDR2-RAM / 32GB SSD-HDD


Last edited by relkai on Mon Apr 08, 2013 8:51 am; edited 1 time in total
Back to top
View user's profile Send private message
Sansavarous
n00b
n00b


Joined: 15 Feb 2004
Posts: 22
Location: My computer.

PostPosted: Fri Apr 05, 2013 4:25 pm    Post subject: Reply with quote

What do you have set for your keyboard in E?
Main menu->Settings->All->Input->Keyboard
Back to top
View user's profile Send private message
relkai
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 96
Location: Hamburg, Germany

PostPosted: Fri Apr 05, 2013 5:04 pm    Post subject: Reply with quote

It's set to the following:
- Configuration: de (default, basic)
- Model: Automatic (already tried different layouts like "pc102", "pc104" or "pc105"
- Options: None activated
_________________
Server: Pentium D-3,2GHz / 2 GB DDR-RAM / TerraTec Cynergy 1400 DVB-T
Notebook: IBM Thinkpad T60 / Core 2 Duo 2,2GHz / 2GB DDR-RAM / Intel 945GM
MythTV Box: Zotac ZBOX HD-ID33 1,8GHz / 2 GB DDR2-RAM / 32GB SSD-HDD
Back to top
View user's profile Send private message
Sansavarous
n00b
n00b


Joined: 15 Feb 2004
Posts: 22
Location: My computer.

PostPosted: Fri Apr 05, 2013 6:04 pm    Post subject: Reply with quote

Check your Xserver config to be sure that you're using the same keyboard layout under "InputDevice" and what your xmodmaps are.
Also check your locale settings in xterm and what TERM is set to. echo $TERM
Might be good to read up on man infocmp and man locale and of course man xterm
Back to top
View user's profile Send private message
relkai
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 96
Location: Hamburg, Germany

PostPosted: Fri Apr 05, 2013 7:20 pm    Post subject: Reply with quote

My xorg.conf is set to "pc105". Therefore I already tried to manually set this layout in E.
The locale is set to de_DE and I ran locale-gen, of course:
Code:

LANG=de_DE
LC_CTYPE="de_DE"
LC_NUMERIC="de_DE"
LC_TIME="de_DE"
LC_COLLATE="de_DE"
LC_MONETARY="de_DE"
LC_MESSAGES="de_DE"
LC_PAPER="de_DE"
LC_NAME="de_DE"
LC_ADDRESS="de_DE"
LC_TELEPHONE="de_DE"
LC_MEASUREMENT="de_DE"
LC_IDENTIFICATION="de_DE"
LC_ALL=de_DE

$TERM is set to "term".
Though I mentioned xterm as an example for my problem, the mentioned keys don't work in any application started in E.

I don't have a ~/.Xmodmap file and don't remember that I ever configured any.

By the way: Letters in capitals are working for every key.
I just installed terminology and the same problem exists here. But if I press one of the dead keys, terminology is flashing red. Therefore the key press itself is recognized somehow.

I just tried to connect to the desktop using an Xserver and there all keys are working fine.
Because VNC is faster for connections from the internet (using a VPN, of course), I would really like to use this instead.

Because I use this server for about 15 years with the same Gentoo installation, it's possible that there's a relict from earlier configurations which I don't remember anymore.
I just don't understand why it's working fine in iceWM, which should use the same xorg.conf, $TERM variable and locale settings.
_________________
Server: Pentium D-3,2GHz / 2 GB DDR-RAM / TerraTec Cynergy 1400 DVB-T
Notebook: IBM Thinkpad T60 / Core 2 Duo 2,2GHz / 2GB DDR-RAM / Intel 945GM
MythTV Box: Zotac ZBOX HD-ID33 1,8GHz / 2 GB DDR2-RAM / 32GB SSD-HDD
Back to top
View user's profile Send private message
relkai
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 96
Location: Hamburg, Germany

PostPosted: Mon Apr 08, 2013 8:51 am    Post subject: Reply with quote

Finally I solved this issue by removing all key bindings from "Settings -> All -> Input -> Key Bindings" and all keys are working as expected, now.

Because I don't use these key bindings with VNC it's not a big drawback for me.
It's just a bit strange, that a normal key press like "a" was recognized as a key binding (e.g. CTRL+ALT+a) using e17 with VNC, because this didn't happen using an xserver connection.
_________________
Server: Pentium D-3,2GHz / 2 GB DDR-RAM / TerraTec Cynergy 1400 DVB-T
Notebook: IBM Thinkpad T60 / Core 2 Duo 2,2GHz / 2GB DDR-RAM / Intel 945GM
MythTV Box: Zotac ZBOX HD-ID33 1,8GHz / 2 GB DDR2-RAM / 32GB SSD-HDD
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum