Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gdm]clavier qwerty
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5283
Location: ~Brussels - Belgique

PostPosted: Tue Feb 26, 2013 8:01 pm    Post subject: Reply with quote

Hello,

Avez-vous essayé sans passer par GDM ?
- via startx
- via un autre login manager ?

Si ça peut vous aider, mon keyboard.conf est le suivant :
/etc/X11/xorg.conf.d/10-keyboard.conf:
Section "InputClass"
        Identifier "keyboard-all"
        Driver "evdev"
        Option "XkbLayout" "be"
        Option "XkbRules" "xorg"
        MatchIsKeyboard "on"
EndSection


Pour le reste, je ne peux pas trop aider : j'ai un clavier Cherry (mais eu un Dell), et utilise slim et razorqt, le tout en "instable".
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3136

PostPosted: Tue Feb 26, 2013 8:12 pm    Post subject: Reply with quote

'alute
il me reste une vieille hypothèse ou 2 que je n'ai jamais pu tester à l'époque faute de les avoir trouvé avant de passer par slim
Sait-on jamais :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
HazeC5
Apprentice
Apprentice


Joined: 16 May 2007
Posts: 222
Location: Devant l'écran

PostPosted: Tue Feb 26, 2013 9:02 pm    Post subject: Reply with quote

Re .

Merci pour réactivité, c'est très apprécié. :wink:

Quote:
Avez-vous essayé sans passer par GDM ?
- via startx
- via un autre login manager ?

Si ça peut vous aider, mon keyboard.conf est le suivant :
/etc/X11/xorg.conf.d/10-keyboard.conf:
Section "InputClass"
Identifier "keyboard-all"
Driver "evdev"
Option "XkbLayout" "be"
Option "XkbRules" "xorg"
MatchIsKeyboard "on"
EndSection


Alors oui j'ai testé avec d'autre login manager, le problème y est aussi présent! Avec startx non je n'ai jamais essayé car je ne connais pas cet outil, ou du moins je n'ai jamais réussi à le faire fonctionner.
Cependant startx n'est pas 1 LM, ou si ? Car si ce n'en est pas un le problème n'y sera pas, car c'est uniquement avec le LM que le clavier est en Qwerty, tout le reste de mon système est bien en français.

J'aimerai bien testé la solution du:
Code:
/etc/X11/xorg.conf.d/10-keyboard.conf


Mais depuis je ne sais quelle version de xorg, je n'ai plus ce dossier, ni même la présence de "evdev" ou de "fr" dans mon xorg.conf.
Alors comment puis-je procéder pour tester cette éventuelle solution ? Svp !

Par avance merci. :wink:



_________________
<--Pentium Quad-Core Q8400 -- Ram 6Go -- AsusTek P5QL-VM-- Intel G 43/45 HD --Son 5.1 Logitech -->
<-Enlightenment 17-svn Kernel CK-sources-3.7.10->


Last edited by HazeC5 on Wed Feb 27, 2013 11:10 am; edited 1 time in total
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 817

PostPosted: Wed Feb 27, 2013 12:47 am    Post subject: Reply with quote

Je vient de me rendre compte que j'ai le même problème avec GDM et peut-être ibus qui restent en qwerty, pareil ma config clavier est bien prise en compte :
Code:

[   227.621] (II) XINPUT: Adding extended input device "Genius 2.4G Wireless Mouse and Keyboard" (type: KEYBOARD, id 8)
[   227.621] (**) Option "xkb_rules" "evdev"
[   227.621] (**) Option "xkb_model" "latin9"
[   227.621] (**) Option "xkb_layout" "fr"
[   227.621] (**) Option "xkb_variant" "compose:menu"


Par contre j'ai aussi ce message :
Code:

[   227.593] (EE) Error loading keymap /var/lib/xkb/server-0.xkm
[   227.593] (EE) XKB: Failed to load keymap. Loading default keymap instead.

Peut-être un bug de xkb qui ne compile pas la keymap ?
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5283
Location: ~Brussels - Belgique

PostPosted: Wed Feb 27, 2013 7:33 am    Post subject: Reply with quote

Ah, voilà du concret ! on va pouvoir avancer :)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
HazeC5
Apprentice
Apprentice


Joined: 16 May 2007
Posts: 222
Location: Devant l'écran

PostPosted: Wed Feb 27, 2013 11:34 am    Post subject: Reply with quote

Salut

Bien de mon côté je viens juste de résoudre le soucis et GDM est enfin en Azerty.

C'est le post de GentooUser@Clubic qui m'a mis sur la piste. En effet après avoir vu son erreur xkb, j'ai donc tapé la commande:
Code:
grep xkb /var/log/Xorg.0.log

dans laquelle j'ai pu trouver ceci:
Quote:

[ 2838.385] (**) Option "xkb_rules" "evdev"
[ 2838.385] (**) Option "xkb_model" "evdev"
[ 2838.385] (**) Option "xkb_layout" "us"
[ 2838.407] (**) Option "xkb_rules" "evdev"
[ 2838.407] (**) Option "xkb_model" "evdev"
[ 2838.407] (**) Option "xkb_layout" "us"


Du coup j'ai donc crée le dossier
Code:
/etc/X11/xorg.conf.d/
et éditer 1 fichier que j'ai nommé:
Quote:
10-evdev.conf

et dans lequel j'y ai mis:
Code:
Section "InputClass"
   Identifier "keyboard0"     
   MatchIsKeyboard "on"
#       MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "fr"
        Option "XkbVariant" "latin9"
        Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection


Et voilà que GDM est en français.

Je dois dire que c'est aussi 1 peu de ma faute car il y a de nombreux mois de cela il m'avait semblé que les fichiers relatifs à la config du clavier et de la souris étaient devenus obsolètes.... Grossière erreur visiblement.


_________________
<--Pentium Quad-Core Q8400 -- Ram 6Go -- AsusTek P5QL-VM-- Intel G 43/45 HD --Son 5.1 Logitech -->
<-Enlightenment 17-svn Kernel CK-sources-3.7.10->
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5283
Location: ~Brussels - Belgique

PostPosted: Wed Feb 27, 2013 12:08 pm    Post subject: Reply with quote

En effet, tout est obsolète à condition d'accepter les valeurs par défaut :lol:
- clavier US
- pilote X plutôt que Y
- ...
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 817

PostPosted: Wed Feb 27, 2013 9:02 pm    Post subject: Reply with quote

Ça remarche aussi chez moi, mes options Xkb était en vrac (pourtant j'ai pas touché ce fichier depuis la disparition de hal, et avant ça marchait oO)

Mon nouveau fichier de config :
Code:
% cat /etc/X11/xorg.conf.d/80-keyboard-all.conf
Section "InputClass"
   Identifier "evdev keyboard catchall"
   MatchIsKeyboard "on"
   MatchDevicePath "/dev/input/event*"
   Driver "evdev"
   Option "XkbLayout" "fr"
   Option "XkbVariant" "latin9"
   Option "XkbOptions" "compose:menu"
EndSection


Par contre ibus reste sur un backend qwerty :/ j’essaierai de voir si c'est un problème avec ibus ou son intégration dans Gnome.
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2634
Location: Paris

PostPosted: Wed Feb 27, 2013 11:54 pm    Post subject: Reply with quote

Là tout de suite j'ai cassé mon ordi (noyau, udev, tout ça) mais j'ai hâte de tester pour corriger ce problème...
Back to top
View user's profile Send private message
HazeC5
Apprentice
Apprentice


Joined: 16 May 2007
Posts: 222
Location: Devant l'écran

PostPosted: Thu Feb 28, 2013 12:08 am    Post subject: Reply with quote

Re-Salut.

Bon je suis super satisfait d'avoir pu résoudre ce soucis. Par contre je me suis rendu compte d'une chose.
si j'utilise le layout latin9 avec l'option Option "XkbOptions" "terminate:ctrl_alt_bksp cette commande permet effectivement de relancer X.

Par contre avec le layout oss cette commande ne fonctionne plus...
Mais en même temps j'ai rajouté ceci:
Code:
Option "XkbOptions" "terminate:ctrl_alt_bksp,compose:menu"


Serait-ce à cause du compose:menu que cela ne fonctionne plus ?
Je pose la question, car j'ai pas mal de taf et je devais utiliser le PC , je ne peux donc me permettre de relancer X toutes les 2mns, sinon j'avance pas dans mon travail...

Je me rends compte que je ne sais pas trop à quoi sert finalement ce compose:menu, m'est-il nécessaire, et à quoi sert-il s'il vous plait ?

Merci d'avance :!:


_________________
<--Pentium Quad-Core Q8400 -- Ram 6Go -- AsusTek P5QL-VM-- Intel G 43/45 HD --Son 5.1 Logitech -->
<-Enlightenment 17-svn Kernel CK-sources-3.7.10->
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 817

PostPosted: Thu Feb 28, 2013 1:10 am    Post subject: Reply with quote

compose:menu sert à utiliser la touche menu comme touche morte pour taper certains caractères : <compose> + <a> + <`> = à, mais je vient de me rendre que ça ne marche pas chez moi, donc XkbOptions ne dois pas être le bon endroit pour le mettre, donc c'est probablement ça qui empêche de fonctionner ton terminate:ctrl_alt_bksp
Back to top
View user's profile Send private message
HazeC5
Apprentice
Apprentice


Joined: 16 May 2007
Posts: 222
Location: Devant l'écran

PostPosted: Thu Feb 28, 2013 1:36 am    Post subject: Reply with quote

Je viens juste de tester,avant de voir ton post GentooUser@Clubic en supprimant compose:menu que le ctrl+alt+bcksp ne fonctionnait pas non plus!

Je suis d'avis que cela viendrai donc de la Variante utilisée, je testerai demain, là il se fait tard.
Quand au compose:menu je ne vois déjà pas où est la touche compose... Puis je pense pas que j'en aurai l'utilité puisque jusqu'ici j'ai toujours pu me servir du clavier et taper tout e que je désirai avec... Saus si maintenant on vient à m'expliquer et me démontrer son utilité, j'y reflechirai certainement.

Pour tuer la session par contre, ça avait fonctionné juste après mon 1er login avec GDM en azerty, et j'avais la variante latin-9 activée à ce moment.

Bonne soirée. Et Merci @ vous :!: :wink:

_________________
<--Pentium Quad-Core Q8400 -- Ram 6Go -- AsusTek P5QL-VM-- Intel G 43/45 HD --Son 5.1 Logitech -->
<-Enlightenment 17-svn Kernel CK-sources-3.7.10->
Back to top
View user's profile Send private message
christophe_y2k
n00b
n00b


Joined: 07 Jan 2008
Posts: 28
Location: EUROPE-FRANCE-MANDELIEU

PostPosted: Sun Mar 17, 2013 6:18 pm    Post subject: Reply with quote

GentooUser@Clubic wrote:
Ça remarche aussi chez moi, mes options Xkb était en vrac (pourtant j'ai pas touché ce fichier depuis la disparition de hal, et avant ça marchait oO)

Mon nouveau fichier de config :
Code:
% cat /etc/X11/xorg.conf.d/80-keyboard-all.conf
Section "InputClass"
   Identifier "evdev keyboard catchall"
   MatchIsKeyboard "on"
   MatchDevicePath "/dev/input/event*"
   Driver "evdev"
   Option "XkbLayout" "fr"
   Option "XkbVariant" "latin9"
   Option "XkbOptions" "compose:menu"
EndSection


Par contre ibus reste sur un backend qwerty :/ j’essaierai de voir si c'est un problème avec ibus ou son intégration dans Gnome.


Pour moi ça fonctionne pas avec gnome-base/gdm-2.20.11-r1
impossible d'obtenir un clavier en AZERTY
avec ou sans fichier xorg.conf.d
Back to top
View user's profile Send private message
Tetsumaki
n00b
n00b


Joined: 07 Feb 2013
Posts: 11

PostPosted: Tue Apr 02, 2013 12:00 pm    Post subject: Reply with quote

HazeC5 même avec un clavier bien configuré en fr dans /etc/X11/xorg.conf.d/10-keyboard.conf ça ne suffit pas si le driver HID_LOGITECH_DJ est compilé avec le kernel, le clavier sera toujours en us.
Pour ma part il est toujours nécessaire d'avoir 10-keyboard.conf bien configuré + un kernel compilé avec l'option # CONFIG_HID_LOGITECH_DJ is not set.
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2634
Location: Paris

PostPosted: Thu Apr 04, 2013 10:00 pm    Post subject: Reply with quote

Tetsumaki wrote:
HazeC5 même avec un clavier bien configuré en fr dans /etc/X11/xorg.conf.d/10-keyboard.conf ça ne suffit pas si le driver HID_LOGITECH_DJ est compilé avec le kernel, le clavier sera toujours en us.
Pour ma part il est toujours nécessaire d'avoir 10-keyboard.conf bien configuré + un kernel compilé avec l'option # CONFIG_HID_LOGITECH_DJ is not set.


Merci car je suis dans le même cas et je tournais en rond, j'avais bien mis la configuration qui allait bien mais c'était toujours inopérant... Personnellement je n'aurai pas pensé à cette histoire d'option du noyau pour les périphériques type "Logitech Unifying receivers". A priori j'ai lu que ça fonctionne bien même sans cet élément du noyau, est-ce le cas quand on a 2 périphériques sur le même récepteur ?
Back to top
View user's profile Send private message
Tetsumaki
n00b
n00b


Joined: 07 Feb 2013
Posts: 11

PostPosted: Fri Apr 05, 2013 2:42 am    Post subject: Reply with quote

DuF wrote:
Tetsumaki wrote:
HazeC5 même avec un clavier bien configuré en fr dans /etc/X11/xorg.conf.d/10-keyboard.conf ça ne suffit pas si le driver HID_LOGITECH_DJ est compilé avec le kernel, le clavier sera toujours en us.
Pour ma part il est toujours nécessaire d'avoir 10-keyboard.conf bien configuré + un kernel compilé avec l'option # CONFIG_HID_LOGITECH_DJ is not set.


Merci car je suis dans le même cas et je tournais en rond, j'avais bien mis la configuration qui allait bien mais c'était toujours inopérant... Personnellement je n'aurai pas pensé à cette histoire d'option du noyau pour les périphériques type "Logitech Unifying receivers". A priori j'ai lu que ça fonctionne bien même sans cet élément du noyau, est-ce le cas quand on a 2 périphériques sur le même récepteur ?

Je n'ai pas eu l'occasion de tester avec 2 périphériques, à tester donc, à vu de nez je dirais que ça fonctionne mais je ne peux pas le promettre.
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2634
Location: Paris

PostPosted: Fri Apr 05, 2013 8:44 pm    Post subject: Reply with quote

Tetsumaki wrote:

Je n'ai pas eu l'occasion de tester avec 2 périphériques, à tester donc, à vu de nez je dirais que ça fonctionne mais je ne peux pas le promettre.


Ca fonctionne mais il faut utiliser un petit outil pour appairer les 2 éléments sur le même récepteur ce qui des fois occasionnent des problèmes de configuration (il choisit le mauvais hidrawX). Au final je vais garder les 2 récepteurs car ça fonctionne tout le temps, sans se mélanger les pinceaux.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum