Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with grub
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
jfha73
n00b
n00b


Joined: 30 Mar 2013
Posts: 3

PostPosted: Sat Mar 30, 2013 3:46 pm    Post subject: Problem with grub Reply with quote

Hey guys,

I'm trying to install Gentoo on a Virtual Machine following the instructions in the Installation guide, but when I get to:

Code:
livecd conf.d # grub
Probing devices to guess BIOS drives. This may take a long time.

grub> root (hd0,0)
 Filesystem type is ext2fs, partition type 0xfd

grub> setup (hd0)


I get this:

Code:
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/boot/stage1" exists... no


I checked /boot/grub and stage1 is there, so I don't know why it says it doesn't exist.

Also I noticed that when I setup the partitions using mkfs.ext3 or mkfs.ext4 grub doesn't recognize the partition type and it says type unknown and it won't run setup (hd0)

Any ideas?

Thanks
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32099
Location: 56N 3W

PostPosted: Sat Mar 30, 2013 4:48 pm    Post subject: Reply with quote

jfha73,

Welcome to Gentoo.

Old versions of grub do not support ext3 and ext4 - which version of grub do you have?

How you go about installing grun into a Virtual Machine (VM) varies between virtualisation types.
You may need to write a device.map file for grub. I think thats described in the
Code:
info grub
command.

--- edit ---
Code:
grub> root (hd0,0)
 Filesystem type is ext2fs, partition type 0xfd
Partition type 0xfd means kernel raid. What type of raid superblock do you have for /boot and what raid level?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
jfha73
n00b
n00b


Joined: 30 Mar 2013
Posts: 3

PostPosted: Sun Mar 31, 2013 2:06 am    Post subject: Reply with quote

It can't be version, I'm trying the newest one there now (build 20130207).

About the partition type I'll have to try again, I don't remember.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32099
Location: 56N 3W

PostPosted: Sun Mar 31, 2013 12:15 pm    Post subject: Reply with quote

jfha73,

grub is something you build for yourself. The date does not help.

What does
Code:
emerge grub -pv
show?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
jfha73
n00b
n00b


Joined: 30 Mar 2013
Posts: 3

PostPosted: Mon Apr 01, 2013 11:26 pm    Post subject: Reply with quote

This is getting weirder, I'm trying from zero and when I get to grub I get this:

Code:
 * ERROR: sys-boot/grub-0.97-r12 failed (compile phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_compile
 *        environment, line 4136:  Called econf '--libdir=/lib' '--datadir=/usr/lib/grub' '--exec-prefix=/' '--disable-auto-linux-mem-opt' '--with-curses'
 *   phase-helpers.sh, line  501:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=sys-boot/grub-0.97-r12'`,
 * the complete build log and the output of `emerge -pqv '=sys-boot/grub-0.97-r12'`.
 * The complete build log is located at '/var/tmp/portage/sys-boot/grub-0.97-r12/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-boot/grub-0.97-r12/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-boot/grub-0.97-r12/work/grub-0.97'
 * S: '/var/tmp/portage/sys-boot/grub-0.97-r12/work/grub-0.97'

>>> Failed to emerge sys-boot/grub-0.97-r12, Log file:

>>>  '/var/tmp/portage/sys-boot/grub-0.97-r12/temp/build.log'

 * Messages for package sys-boot/grub-0.97-r12:

 * ERROR: sys-boot/grub-0.97-r12 failed (compile phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_compile
 *        environment, line 4136:  Called econf '--libdir=/lib' '--datadir=/usr/lib/grub' '--exec-prefix=/' '--disable-auto-linux-mem-opt' '--with-curses'
 *   phase-helpers.sh, line  501:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=sys-boot/grub-0.97-r12'`,
 * the complete build log and the output of `emerge -pqv '=sys-boot/grub-0.97-r12'`.
 * The complete build log is located at '/var/tmp/portage/sys-boot/grub-0.97-r12/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-boot/grub-0.97-r12/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-boot/grub-0.97-r12/work/grub-0.97'
 * S: '/var/tmp/portage/sys-boot/grub-0.97-r12/work/grub-0.97'


When I do :

Code:
emerge grub
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32099
Location: 56N 3W

PostPosted: Tue Apr 02, 2013 8:42 pm    Post subject: Reply with quote

jfha73,

Make friends with wgetpaste and use it to post /var/tmp/portage/sys-boot/grub-0.97-r12/temp/build.log
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum