Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] unity-gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 24, 25, 26  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
yaront
n00b
n00b


Joined: 18 Jan 2012
Posts: 16

PostPosted: Wed Mar 13, 2013 3:55 pm    Post subject: Reply with quote

Another thing: currently the chromium USE flag is set for x11-misc/webaccounts-browser-extension in unity-portage.puse, which makes it a hassle to turn it off (I don't want to modify files from the overlay and maintain my own version). Since it's an overlay ebuild, wouldn't it be better to declare the flag as +chromium if you want it to be on by default?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Thu Mar 14, 2013 10:19 pm    Post subject: Reply with quote

@yaront
The eclass check now performs 'grep -R' instead of 'grep -r'.
I've removed x11-misc/webaccounts-browser-extension from unity-portage.puse and instead added '+chromium' to the webaccounts-browser-extension ebuild.
I'm preferring chromium over firefox at the moment for webapps support as they all work in Chromium, but only some work in Firefox.
It could be because I'm using firefox-bin and so might need to package firefox with some Ubuntu patches.

@jarvispedro
You're welcome, I really like it too!
Thanks for the offer but I won't accept donations.
There's been so many others who have made contributions of their time with testing, reporting and discussion that I wouldn't feel comfortable cashing in on that.

I'll look at moving the check from the eclass to the unity-meta ebuild, in the meantime I've adjusted 'grep -r' to 'grep -R' as above.

The language file conflict for activity-log-manager has been fixed and should belong to unity-language-pack, thanks for reporting :)
Ubuntu generally don't maintain language translations within the source of their individual packages but have their own central translations project where they are maintained instead, ( see https://translations.launchpad.net/ ).

Can you elaborate on what you mean with the menu bar problem using nautilus-3.6 ?
I'll look at adding the old nautilus-3.4.2 from Quantal back in but it will need testing against the existing 3.6 packages, and once re-added when does it get removed ?
In the meantime you can add it into your local overlay, old ebuild available here -> https://github.com/shiznix/unity-gentoo/blob/8aff5f341ee1bc1d323ebf388f8fdb03a3e52b6e/gnome-base/nautilus/nautilus-99.3.4.2.ebuild
The 99. prefixing will need removal, or you may choose to keep the prefixing so it never gets updated to the unwanted version, though masking the higher versions would be the Gentoo preferred technique.

@brothermechanic
I can't reproduce this on my normal system, nor on a fresh Gentoo install.
What version of dev-python/python-distutils-extra do you have installed ?

Does anyone else run into this problem ?
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Sat Mar 16, 2013 5:03 pm    Post subject: Reply with quote

Hi, shiznix!
>What version of dev-python/python-distutils-extra do you have installed ?
dev-python/python-distutils-extra-2.37-r1 PYTHON_TARGETS="python2_7 python3_2 -pypy1_9 -pypy2_0 -python2_6 (-python3_3)"
And after today's resynth overlay i have a trouble, please help
http://bpaste.net/show/84146/
i have unmased versions of
http://bpaste.net/show/84147/
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sat Mar 16, 2013 10:28 pm    Post subject: Reply with quote

brothermechanic wrote:
Hi, shiznix!
>What version of dev-python/python-distutils-extra do you have installed ?
dev-python/python-distutils-extra-2.37-r1 PYTHON_TARGETS="python2_7 python3_2 -pypy1_9 -pypy2_0 -python2_6 (-python3_3)"

OK all seems good there so not sure why or what is triggering the access to /root/.cache/dconf/user as my root user does not have that file or directory, yet it emerges fine with no such error.
I'll put an addpredict line in the ebuild's src_compile and will need you to test but sure would be nice to find what is causing the access. Nothing jumps out at me from the source.

Quote:
And after today's resynth overlay i have a trouble, please help
http://bpaste.net/show/84146/
i have unmased versions of
http://bpaste.net/show/84147/

This doesn't have anything to do with the overlay but is a smart new multilib feature being implemented into the portage tree that will eventually do away with the need for the 'emul-linux-x86-*...' 32bit library ebuilds.
Instead of packages needing a 32bit version of a library as provided by the old emul-linux-x86 pre-compiled 32bit binaries, they now just need to set the 'abi_x86_32' USE flag for the package that provides the library and it will automatically build and install the 32bit library as well as the standard 64bit library.

You're seeing the block because you have keyword unmasked some x11 libs that implement the new 'abi_x86_32' USE flag.
But to co-exist with the old emul-linux-x86 packages, the system needs to use the newer emul-linux-x86 package versions for backwards compatibility (lots of stuff in the tree still depends on emul-linux-x86 packages).

So you have two choices:
1. package.unmask 'app-emulation/emul-linux-x86-xlibs'
OR
2. Remove the x11 packages from package.keywords
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sun Mar 17, 2013 6:04 am    Post subject: Reply with quote

@brothermechanic
Can you sync up and try to emerge indicator-weather again ?

I've added the addpredict lines which should workaround the dconf sandbox violation issue, but I need you to test and let me know if it works as I can't reproduce the problem.

Thanks! :D
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Sun Mar 17, 2013 2:42 pm    Post subject: Reply with quote

Hi, shiznix
indicator-weather installed!!! Thank's!
But don't work forecast
Code:

forecast information cannot be fetched. connection cannot be established



I solved block a problem!!!
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Fri Mar 22, 2013 9:16 am    Post subject: Reply with quote

BUG BUG BUG
I found a bug in chromium browser.
after sleep/hibernation flash (movies/commercial banners) has wrong work (like error in frame buffer or fps error with random overlays).
It fixed when restart chromium

ps: with firefox all is ok.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Fri Mar 22, 2013 10:24 am    Post subject: Reply with quote

brothermechanic wrote:
BUG BUG BUG
I found a bug in chromium browser.
after sleep/hibernation flash (movies/commercial banners) has wrong work (like error in frame buffer or fps error with random overlays).
It fixed when restart chromium

ps: with firefox all is ok.

Sounds minor but no less annoying.
Could be chromium and/or video driver bug ?
Is it flash maybe ?

You remind me that we should package a Ubuntu patched Firefox to get all those webapps working in Firefox.
Or do all the webapps work out of the box with the standard firefox Gentoo package (ie. not firefox-bin) ?

PS> Whole bunch of version bumps just in...
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Wed Mar 27, 2013 4:50 pm    Post subject: Reply with quote

Hi,
while try to update 'libXi-1.6.99.1_p0_p03' I get following error http://bpaste.net/show/87031/
aclocal.out is following http://bpaste.net/show/87035/
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Thu Mar 28, 2013 12:02 am    Post subject: Reply with quote

renegart wrote:
Hi,
while try to update 'libXi-1.6.99.1_p0_p03' I get following error http://bpaste.net/show/87031/
aclocal.out is following http://bpaste.net/show/87035/

Do you have x11-misc/util-macros installed ?
I've added x11-misc/util-macros to x11-libs/libXi deps. list as it definitely needs it to build.
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Fri Mar 29, 2013 10:46 am    Post subject: Reply with quote

shiznix wrote:
renegart wrote:
Hi,
while try to update 'libXi-1.6.99.1_p0_p03' I get following error http://bpaste.net/show/87031/
aclocal.out is following http://bpaste.net/show/87035/

Do you have x11-misc/util-macros installed ?
I've added x11-misc/util-macros to x11-libs/libXi deps. list as it definitely needs it to build.

The package wasn't installed on my system.
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Fri Mar 29, 2013 11:09 am    Post subject: Reply with quote

Hi

Does anyone happen to know how the lock-screen background (when using unity from the overlay) can be changed? I somehow expected that it changes with the gdm3 background (not the grey one but the one shown just before the wallpaper gets painted). But that is not given for me. The lock-screen still shows the same picture that was originally used by gdm3.


Any input appreciated. Thanks!

Cheers


EDIT: Just after posting I found a "solution" (funny because before I posted I searched a lot..). Solution (or better workaround) is: replace all three jpgs (for the time related picture change: morning, bright-day, good-night) in /usr/share/themes/<put theme name here>/backgrounds with my Wallpaper/GDM background picture.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Mon Apr 01, 2013 6:28 am    Post subject: Reply with quote

Raring release is almost upon us and most of the larger more critical packages are in overlay as testing, masked with missing keyword.

If you want to try latest compiz, unity etc. there is unity-gentoo.pkeywords.raring file in the root directory of the overlay that can be symlinked into /etc/portage/package.keywords/

unity-gentoo.pkeywords.raring
Code:
dev-libs/libindicator **
dev-libs/libunity **
unity-base/bamf **
unity-base/compiz **
unity-base/indicator-session **
unity-base/indicator-sync **
unity-base/nux **
unity-base/unity **

Raring release schedule here -> https://wiki.ubuntu.com/RaringRingtail/ReleaseSchedule
Hoping to get most everything in for FinalBetaRelease on April 4th, or when Raring versions stop being daily builds and become real version releases.

Only gotcha if you're wanting to try the new packages is that unity-base/unity requires >=gcc-4.7.3 to build and it's not in the portage tree yet.
Not including the needed gcc in overlay as you can get it from the 'toolchain' overlay until Gentoo devs. can add it into the portage tree.
gcc-4.8 was released on 22nd March so it should be real close to inclusion into main tree.

Thanks! 8)
Back to top
View user's profile Send private message
javispedro
n00b
n00b


Joined: 11 Mar 2013
Posts: 13

PostPosted: Tue Apr 02, 2013 12:18 am    Post subject: Reply with quote

shiznix wrote:
Can you elaborate on what you mean with the menu bar problem using nautilus-3.6 ?

It's just that the HUD is much more useful with the old nautilus, as it exports the entire menu bar in D-Bus and not just the new "Gnome Appmenu" which contains only a few options. We'll see what Ubuntu does.


By the way, I've also found another issue when using binhosts.
As the dependencies of unity-meta ebuild are RDEPENDS, it means you can succesfully install a binary package of unity-meta without actually pulling in ANY of the overlay packages :(
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Tue Apr 02, 2013 1:49 pm    Post subject: Reply with quote

javispedro wrote:
It's just that the HUD is much more useful with the old nautilus, as it exports the entire menu bar in D-Bus and not just the new "Gnome Appmenu" which contains only a few options. We'll see what Ubuntu does.

Totally agree. Staying true to upstream as much as possible gives us a nice easy base to work from and if you need extra or changed functionality, either attempt to persuade upstream and/or maintain your own patches.

Apart from just applying Ubuntu's own patchsets I'm not really maintaining any patches, in the interests of being future proof with minimal maintenance.
The only exception made is to maintain the systray functionality patch that was put forward by one of the Ubuntu devs. in the interests of ~85% of Ubuntu users.

javispedro wrote:
By the way, I've also found another issue when using binhosts.
As the dependencies of unity-meta ebuild are RDEPENDS, it means you can succesfully install a binary package of unity-meta without actually pulling in ANY of the overlay packages :(

unity-meta ebuild only has DEPEND and not RDEPEND.
Back to top
View user's profile Send private message
javispedro
n00b
n00b


Joined: 11 Mar 2013
Posts: 13

PostPosted: Tue Apr 02, 2013 2:06 pm    Post subject: Reply with quote

shiznix wrote:
unity-meta ebuild only has DEPEND and not RDEPEND.

Err.. yes, I meant that, sorry. DEPENDs. When installing from binary package, only RDEPENDs are checked, so unity-meta succesfully installs even if none of the unity packages are installed.

On the other hand, using DEPENDs allows for unity packages to be unmerged while keeping unity-meta installed, which may be desirable for some.
I guess I'll add a "unity-meta-strict" to my local portage.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Apr 03, 2013 1:07 am    Post subject: Reply with quote

javispedro wrote:
shiznix wrote:
unity-meta ebuild only has DEPEND and not RDEPEND.

Err.. yes, I meant that, sorry. DEPENDs. When installing from binary package, only RDEPENDs are checked, so unity-meta succesfully installs even if none of the unity packages are installed.

On the other hand, using DEPENDs allows for unity packages to be unmerged while keeping unity-meta installed, which may be desirable for some.
I guess I'll add a "unity-meta-strict" to my local portage.

Aah I see, perhaps if we add a RDEPEND="${DEPEND}" line to the unity-meta ebuild ?
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Wed Apr 03, 2013 8:17 pm    Post subject: Reply with quote

I try to build the new Unity.
At the moment I've a problem with 'geis-2.2.12_p0_p03' http://bpaste.net/show/88772/ and 'compiz-0.9.9_p0_p01' http://bpaste.net/show/88771/
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Apr 03, 2013 9:42 pm    Post subject: Reply with quote

renegart wrote:
I try to build the new Unity.
At the moment I've a problem with 'geis-2.2.12_p0_p03' http://bpaste.net/show/88772/ and 'compiz-0.9.9_p0_p01' http://bpaste.net/show/88771/

Looks to be a problem similar to http://forums.gentoo.org/viewtopic-t-948422-start-0.html
Can you try re-compiling your python installations ?

@javispedro
I've added that RDEPEND line to the unity-meta ebuild.

Most of the packages that can be bumped up to Raring versions are now in the overlay.

With the exception of those larger packages already mentioned pretty much everything that can be bumped, has been.
Just waiting for upstream's '...daily...' source tarballs to click over to being real releases now.

unity-base/unity-language-pack has been re-worked to include extra languages that lag behind Ubuntu's upgrade cycle (ak,jv,kok,la,no,rm,sco,zh).
www-client/firefox-bin has been removed as an option from x11-misc/webaccounts-browser-extension as a lot of webapps don't work with it but work fine with the compiled Gentoo version.
Back to top
View user's profile Send private message
javispedro
n00b
n00b


Joined: 11 Mar 2013
Posts: 13

PostPosted: Sat Apr 06, 2013 1:40 pm    Post subject: Reply with quote

Thanks, rebuilding right now!

There is a new language file conflict between unity-base/unity-language-pack-13.04 and unity-base/indicator-bluetooth-0.0.6_p0_p01:
/usr/share/locale/es/LC_MESSAGES/indicator-bluetooth.mo

Going to assume the owner should be the language-pack again.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sun Apr 07, 2013 1:51 pm    Post subject: Reply with quote

javispedro wrote:
Thanks, rebuilding right now!

There is a new language file conflict between unity-base/unity-language-pack-13.04 and unity-base/indicator-bluetooth-0.0.6_p0_p01:
/usr/share/locale/es/LC_MESSAGES/indicator-bluetooth.mo

Going to assume the owner should be the language-pack again.

Yep. And looks like indicator-bluetooth would only install a language file if your LINGUA was ca, es or fr.
Fix committed to remove any of those files at install time.
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Mon Apr 08, 2013 4:45 am    Post subject: Reply with quote

shiznix, please add firefox-bin support to webaccounts-browser-extension.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Mon Apr 08, 2013 10:13 pm    Post subject: Reply with quote

brothermechanic wrote:
shiznix, please add firefox-bin support to webaccounts-browser-extension.

The webaccounts-browser-extension ebuild did have firefox-bin as an option to fulfill the 'firefox' USE flag.
But so many webapps don't work with www-client/firefox-bin so it was removed.

I can add the option back in if you like, still making www-client/firefox the 1st choice between it and firefox-bin.
Then throw up an elog message at package installation time saying something like:
"Firefox-bin is known to not work with many webapps and so is completely unsupported but is merely included for your convenience should you choose to use it."

EDIT: OK www-client/firefox-bin is back in the webaccounts-browser-extension ebuild ;)
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Tue Apr 09, 2013 6:59 pm    Post subject: Reply with quote

Thank you!
(i don't like to compile firefox)))
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Wed Apr 10, 2013 1:54 pm    Post subject: Reply with quote

shiznix, can you remove ubuntuone from depends or make it with use flag?
Than you for overlay!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 24, 25, 26  Next
Page 18 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum