Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't play DVD.
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2101
Location: Finland

PostPosted: Sun Mar 24, 2013 3:11 pm    Post subject: Reply with quote

Budoka wrote:
desultory wrote:
That was addressed earlier by ssuominen. In short, if you are using sys-fs/udisks:0 leaving them uncommented could cause conflicts with the automounter, but with sys-fs/udisks:2 no such conflicts are present. So just check which slot you are using and go from there, if you are even using the automounter, if you are not then leave them active.


OK. So I umnerged sys-fs/udisks:0, emerged sys-fs/udisks:2, and uncommented the 2 lines in fstab in question.

Now my DVD does not mount at all nor is it recognized by any media player. What's up?

All I want is to be able to stick a disc in the box, have it automount,and be able to play it.


Right, listen to NeddySeagoon. We discussed multiple related issues that might have confused here at the same time. Sorry if it did.
DVDs shouldn't be mounted. That's why I provided examples for using mplayer directly with the device.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 338
Location: Tokyo, Japan

PostPosted: Mon Mar 25, 2013 3:17 am    Post subject: Reply with quote

ssuominen wrote:
Budoka wrote:
desultory wrote:
That was addressed earlier by ssuominen. In short, if you are using sys-fs/udisks:0 leaving them uncommented could cause conflicts with the automounter, but with sys-fs/udisks:2 no such conflicts are present. So just check which slot you are using and go from there, if you are even using the automounter, if you are not then leave them active.


OK. So I umnerged sys-fs/udisks:0, emerged sys-fs/udisks:2, and uncommented the 2 lines in fstab in question.

Now my DVD does not mount at all nor is it recognized by any media player. What's up?

All I want is to be able to stick a disc in the box, have it automount,and be able to play it.


Right, listen to NeddySeagoon. We discussed multiple related issues that might have confused here at the same time. Sorry if it did.
DVDs shouldn't be mounted. That's why I provided examples for using mplayer directly with the device.


Yes the thread did become a bit confusing.

Maybe I am not using the appropriate terminology when I say "mounted".

There are 2 issues at hand here for me.

1- Being able to play a DVD.
2- Being able to access a DVD in a file manager. (This is what I was speaking of when I was saying "mount" and this is the error the file manger throws. "Can't mount...")

So maybe I am missing something in the thread but when I had sys-fs/udisks:0 and the fstab commented out the behaviour was what I would expect. DVD's are recognized, playable in a media player, and accessible from a file manager.

I set my system up to fail as suggested. So now I have sys-fs/udisks:2 and the lines uncommented as instructed in this thread and I can do neither. So sorry if it is a totally NooB question and clear to evryone else but I just am not sure what I am suppose to be doing "next"?

Thanks.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2101
Location: Finland

PostPosted: Mon Mar 25, 2013 6:49 am    Post subject: Reply with quote

Budoka wrote:

So maybe I am missing something in the thread but when I had sys-fs/udisks:0 and the fstab commented out the behaviour was what I would expect. DVD's are recognized, playable in a media player, and accessible from a file manager.

I set my system up to fail as suggested. So now I have sys-fs/udisks:2 and the lines uncommented as instructed in this thread and I can do neither. So sorry if it is a totally NooB question and clear to evryone else but I just am not sure what I am suppose to be doing "next"?


"from a file manager", can you specific which file manager? if you are using nautilus or thunar, make sure gnome-base/gvfs is built using USE="udev udisks -gdu" if you want to use sys-fs/udisks:2
USE="udev gdu -udisks" would use sys-fs/udisks:0

(or perhaps I should have reread whole thread to find out if you tried this already or not)

anyway, I don't think I have much to add here, good luck!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31711
Location: 56N 3W

PostPosted: Mon Mar 25, 2013 8:12 pm    Post subject: Reply with quote

Budoka,

Its maybe worth a recap.
In this post, mounting means attaching the file system on the DVD to your filesystem tree, regardless of how that is achieved. e.g. with the mount command, manually or with an auto mounter of some sort.

Video DVDs (bought ones anyway) are not mounted to play the video. If they are mounted, the file system is not used to play the DVD.
Data DVDs on the other hand, must be mounted to be used.

If it helps, you can compare music CDs to Video DVDs. Music CDs do not contain a filesystem at all and can never be mounted. Video DVDs contain a carefully corrupted filesystem that is almost useless but they can normally be mounted.

Therefore, there are two apparently overlapping problem areas.
Mounting DVDs
Playing video DVDs
I say 'apparently overlapping' because they are really quite separate problems.

You can demonstrate this by building a kernel with no UDF or iso9660 support. They are the filesystems used on DVDs.
You will still be able to play video DVDs but not mount any DVDs.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 338
Location: Tokyo, Japan

PostPosted: Tue Mar 26, 2013 2:02 am    Post subject: Reply with quote

ssuominen wrote:
Budoka wrote:

So maybe I am missing something in the thread but when I had sys-fs/udisks:0 and the fstab commented out the behaviour was what I would expect. DVD's are recognized, playable in a media player, and accessible from a file manager.

I set my system up to fail as suggested. So now I have sys-fs/udisks:2 and the lines uncommented as instructed in this thread and I can do neither. So sorry if it is a totally NooB question and clear to evryone else but I just am not sure what I am suppose to be doing "next"?


"from a file manager", can you specific which file manager? if you are using nautilus or thunar, make sure gnome-base/gvfs is built using USE="udev udisks -gdu" if you want to use sys-fs/udisks:2
USE="udev gdu -udisks" would use sys-fs/udisks:0

(or perhaps I should have reread whole thread to find out if you tried this already or not)

anyway, I don't think I have much to add here, good luck!


Any file manager. Dolphin, Thunar, Konqueror, etc. All generate some version of the same message. "Can't "mount""
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 338
Location: Tokyo, Japan

PostPosted: Tue Mar 26, 2013 2:05 am    Post subject: Reply with quote

NeddySeagoon wrote:
Budoka,

Its maybe worth a recap.
In this post, mounting means attaching the file system on the DVD to your filesystem tree, regardless of how that is achieved. e.g. with the mount command, manually or with an auto mounter of some sort.

Video DVDs (bought ones anyway) are not mounted to play the video. If they are mounted, the file system is not used to play the DVD.
Data DVDs on the other hand, must be mounted to be used.

If it helps, you can compare music CDs to Video DVDs. Music CDs do not contain a filesystem at all and can never be mounted. Video DVDs contain a carefully corrupted filesystem that is almost useless but they can normally be mounted.

Therefore, there are two apparently overlapping problem areas.
Mounting DVDs
Playing video DVDs
I say 'apparently overlapping' because they are really quite separate problems.

You can demonstrate this by building a kernel with no UDF or iso9660 support. They are the filesystems used on DVDs.
You will still be able to play video DVDs but not mount any DVDs.


Thanks Neddy. That actually clarifies it quite a bit for me. I almost "get it" but will do more homework.

But, and I am sorry to say this again, what am I suppose to do with my configuration now??? Am I missing something in the thread?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31711
Location: 56N 3W

PostPosted: Tue Mar 26, 2013 8:02 pm    Post subject: Reply with quote

Budoka,

Its no longer clear what your problem is. Mounting DVDs in general (attaching the filesystem somewhere in your filesystem tree) or playing videos.
The problems are quite separate.

Which one would you like to solve, or solve first ?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 338
Location: Tokyo, Japan

PostPosted: Fri Mar 29, 2013 2:42 am    Post subject: Reply with quote

NeddySeagoon wrote:
Budoka,

Its no longer clear what your problem is. Mounting DVDs in general (attaching the filesystem somewhere in your filesystem tree) or playing videos.
The problems are quite separate.

Which one would you like to solve, or solve first ?


Thanks Neddy.

If I am understanding correctly I currently have both problems.

I would like to be able to play DVD's (movies) so should probably deal with that first.

When I initially encountered the problem of not being able to play them, I commented out the 2 lines in fstab and was able to successfully play them. But then based on the information in his thread, I thought, that wasn't the way it should have been done. So as suggested I emerged sys-fs/udisks:2 and un-commented the 2 lines in fstab. Now the behavior is the same as it was originally. It fails.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31711
Location: 56N 3W

PostPosted: Fri Mar 29, 2013 6:43 pm    Post subject: Reply with quote

Budoka,

Lets deal with playing DVD movies first. You must be in the cdrom group as you have to send raw commands to the optical drive.
The file system on the DVD is not used.

All DVD player applications are the same in this respect - its the way DVDs were designed to be played.

You must set your DVD player application to use the device name for your DVD player. It will be /dev/sr0 if you only have a single optical drive. If you have several optical drives, the first one willbe /dev/sr0, the next /dev/sr1, and so on.

This is why helpers were suggesting mplayer -dvd-device ...

Exactly what you have to do varies from DVD player to DVD player. Typically they all have a configuration file in your /home/<username> that you can edit, either directly or using the GUI provided with the player.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 338
Location: Tokyo, Japan

PostPosted: Sat Apr 06, 2013 2:08 am    Post subject: Reply with quote

desultory wrote:
Budoka wrote:
Sorry guys. Although I appreciate all the comments/assistance I am still not clear what "I" am suppose to be doing on my box.

I use VLC not mplayer.
Have you tried setting the default DVD device used by VLC? From what I read here, it seems that modifying ~/.config/vlc/vlcrc to include the following should suffice:
Code:
dvd=/dev/sr0


Whenever I try this the change isn't preserved. If I launch VLC after the edit, it will clobber the edit and revert back to the commented line. Is vlcrc generated dynamically some how?
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 338
Location: Tokyo, Japan

PostPosted: Sat Apr 06, 2013 2:21 am    Post subject: Reply with quote

NeddySeagoon wrote:
Budoka,

Lets deal with playing DVD movies first. You must be in the cdrom group as you have to send raw commands to the optical drive.
The file system on the DVD is not used.

All DVD player applications are the same in this respect - its the way DVDs were designed to be played.

You must set your DVD player application to use the device name for your DVD player. It will be /dev/sr0 if you only have a single optical drive. If you have several optical drives, the first one willbe /dev/sr0, the next /dev/sr1, and so on.

This is why helpers were suggesting mplayer -dvd-device ...

Exactly what you have to do varies from DVD player to DVD player. Typically they all have a configuration file in your /home/<username> that you can edit, either directly or using the GUI provided with the player.


OK. I successfully set VLC to use /dev/sr0 and that allows me to play my dvd. Thanks!

But there is still something wacko going on.

When I first started this thread I would stick a dvd in the player and I could 1) See the disk label ) Was presented with the options to "Open in VLC", Eject, Open in File manager, etc

But now if I insert the disk it just sees it as a "cdrom" offering no options except to open in a file manager. This was even before I made the edit to sr0. Given I haven't done anything since my last post except my updates I assume something came down in one of them to change my system? Any ideas?

This isn't a huge issue for me because as I said, now I can play the DVD's, but it is a bit disconcerting.

Going to test DVD/RW stuff this weekend.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7904

PostPosted: Sat Apr 06, 2013 4:05 am    Post subject: Reply with quote

Budoka wrote:
Whenever I try this the change isn't preserved. If I launch VLC after the edit, it will clobber the edit and revert back to the commented line. Is vlcrc generated dynamically some how?
Not that I know of nor that I could find with a bit of searching, though I do not use VLC and what you are experiencing would indicate that it is.

One way to try to find out what is changing the file would be to to set the immutable attribute (sudo chattr +i ~/.config/vlc/vlcrc), given sufficient support for same, and waiting for something to complain about not being able to write to the file.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum