Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]samsung series 7 laptop does not connect to 2.4Ghz
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2739
Location: Bay Area, CA

PostPosted: Sun Mar 17, 2013 8:19 am    Post subject: [SOLVED]samsung series 7 laptop does not connect to 2.4Ghz Reply with quote

When booted into Linux the driver iwlwifi is not able to connect to 2.4Ghz band of any router. The output from 'dmesg' shows it is timing out during authentication phase. The iwlist scan shows 70/70 signal strength and all parameters check out fine. But it just won't connect. There MAC filtering but the MAC of this laptop is allowed.

It connects fine to 5Ghz band on both the routers in the house.

If I boot into Windows 7, the same hardware connects to 2.4 Ghz band fine on both the routers. So, what gives? The card is Intel Centrino 6300 (the ultimate one).

This is a major headache because 5Ghz does not have a wide range (higher frequency signal dies shorter distances) and there are blind spots in my house where the laptop just can't connect to the network. I have to boot into Windows to be able to connect. This is unacceptable for a Linux geek...:)

Any ideas?

Edit: Finally, with kernel 3.10.7, I have a resolution to this issue. I can now connect to 2.4Ghz band as well. If you are wondering why I need 2.4Ghz while 5Ghz works, the reason is that 5Ghz is very lossy and range is small. So, I get 2.4Ghz signal better and more reliable at larger distances. I am a happy camper now.


Last edited by devsk on Sun Aug 25, 2013 5:47 am; edited 1 time in total
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4122
Location: Houston, Republic of Texas

PostPosted: Sun Mar 17, 2013 9:36 am    Post subject: Reply with quote

tried with 11n_disable=1 or 5ghz_disable=1 ?

shots in the dark. iwlwifi seems to be a very finicky beast. I have an iwl-1000 that just plain wont stay connected to the same AP (at home) my iwl-6005 stays connected to beautifully.
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2336

PostPosted: Sun Mar 17, 2013 9:41 am    Post subject: Reply with quote

devsk ...

You can disable 5GHz by disabling 802.11n ...

/etc/modprobe.d/iwlwifi.conf
Code:
options iwlwifi 11n_disable=1

I don't have an intel N card ... so thats the theory, never had to do it in practice.

best ... khay

EDIT: cach0rr0 beat me to it while I was chomping breakfast.


Last edited by khayyam on Sun Mar 17, 2013 9:43 am; edited 1 time in total
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2739
Location: Bay Area, CA

PostPosted: Sun Mar 17, 2013 9:43 am    Post subject: Reply with quote

Does anybody know what this message means? It seems to be precursor to all "timeouts" to authenticate.

Code:
wlan0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded


Looks like my laptop is being prohibited from accessing the AP while running Linux whereas it is allowed when running Windows.


Last edited by devsk on Sun Mar 17, 2013 9:45 am; edited 1 time in total
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2739
Location: Bay Area, CA

PostPosted: Sun Mar 17, 2013 9:44 am    Post subject: Reply with quote

I tried both those options in /etc/modprobe.d/iwlwifi.conf, did a reload of the iwlwifi module and it still does not allow me to connect.
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2336

PostPosted: Sun Mar 17, 2013 9:51 am    Post subject: Reply with quote

devsk wrote:
Does anybody know what this message means? It seems to be precursor to all "timeouts" to authenticate. wlan0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded

devsk ... the 'regulatory domain' provides information on what capablities (channels, etc) are restricted for the domain.

You can try providing your regulatory domain to cfg80211 (assuming its a module)

/etc/modprobe.d/cfg80211.conf
Code:
options cfg80211 ieee80211_regdom=US

I'm not entirely sure this will work without net-wireless/wireless-regdb ... but you can try. Otherwise you can do the same with net-wireless/iw

Code:
#iw reg set US


See: /usr/src/linux/Documentation/networking/regulatory.txt

best ... khay


Last edited by khayyam on Sun Mar 17, 2013 9:52 am; edited 1 time in total
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2739
Location: Bay Area, CA

PostPosted: Sun Mar 17, 2013 9:51 am    Post subject: Reply with quote

Code:
http://wireless.kernel.org/en/developers/Regulatory
What is this crap? Do we need to do something about this in Gentoo distro? Seems like kernel interacts with udev and some regulatory database in user space is being used to enforce the use of certain frequencies and channels. Why do these folks make life harder for us folks?...:(

Why would 2.4Ghz band be not allowed? And why only on Linux?
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2739
Location: Bay Area, CA

PostPosted: Sun Mar 17, 2013 9:57 am    Post subject: Reply with quote

khayyam wrote:
devsk wrote:
Does anybody know what this message means? It seems to be precursor to all "timeouts" to authenticate. wlan0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded

devsk ... the 'regulatory domain' provides information on what capablities (channels, etc) are restricted for the domain.

You can try providing your regulatory domain to cfg80211 (assuming its a module)

/etc/modprobe.d/cfg80211.conf
Code:
options cfg80211 ieee80211_regdom=US

I'm not entirely sure this will work without net-wireless/wireless-regdb ... but you can try. Otherwise you can do the same with net-wireless/iw

Code:
#iw reg set US


See: /usr/src/linux/Documentation/networking/regulatory.txt

best ... khay
net-wireless/wireless-regdb is there. But adding that option to the cfg80211 does not do anything. I will now try the iw utility.
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2336

PostPosted: Sun Mar 17, 2013 10:01 am    Post subject: Reply with quote

devsk wrote:
Code:
http://wireless.kernel.org/en/developers/Regulatory

What is this crap? Do we need to need something about this in Gentoo distro?

devsk ... its in the same realm as licences, gentoo can't do anything about the regulation set on radio frequency restrictions for certain juristictions.

devsk wrote:
Seems like kernel interacts with udev and some regulatory database in user space is being used to enforce the use of certain frequencies and channels. Why do these folks make life harder for us folks?...

No, its not enforced ... you can set it to BO if you so choose, but note: setting the wrong regulatory domain could break the law in your country..

devsk wrote:
Why would 2.4Ghz band be not allowed? And why only on Linux?

I'm not entirely sure this is your issue ...

best ... khay
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2739
Location: Bay Area, CA

PostPosted: Sun Mar 17, 2013 10:08 am    Post subject: Reply with quote

Since that laptop is not on the net, I can't cut&paste. But here is the what appeared in the dmesg:

Hardware Name: 700Z7C
db.txt is empty, you should update it....
...backtrace here

And regulatory domain changed to US and one more frequency band got added. All frequencies between 2.4 and 5.2 Ghz are shown there.
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2336

PostPosted: Sun Mar 17, 2013 10:08 am    Post subject: Reply with quote

devsk wrote:
Code:
wlan0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded

devsk ... looking at the above again, I think this is the result of disabling 802.11n ... I think HT is only available for N networks. So, I don't think its the cause of your authentication issue.

best ... khay
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2739
Location: Bay Area, CA

PostPosted: Sun Mar 17, 2013 10:20 am    Post subject: Reply with quote

I still can't figure out why it works when booted in Windows.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3209

PostPosted: Fri Mar 29, 2013 4:25 am    Post subject: Reply with quote

Are you using 3.8? I ran into the same problem after upgrading to 3.8. Currently I am on 3.8.2. I also found the following, and think it might be a related regression:

http://comments.gmane.org/gmane.linux.kernel.wireless.general/104268
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde4 :-/
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2739
Location: Bay Area, CA

PostPosted: Fri Mar 29, 2013 4:52 am    Post subject: Reply with quote

That's much newer code than what's in 3.8.3 (I am on 3.8.3). So, the patch provided there won't even apply because the function being modified does not exist in 3.8.3 code.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3209

PostPosted: Fri Mar 29, 2013 4:58 am    Post subject: Reply with quote

Hmm.. never mind. I found the bug corresponding to my wireless card.

http://www.spinics.net/lists/linux-wireless/msg104449.html

I am downgrading to 3.7. Enough with the "latest and greatest". :evil:
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde4 :-/
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2739
Location: Bay Area, CA

PostPosted: Sun Aug 25, 2013 5:48 am    Post subject: Reply with quote

It took 6 months, but the fix is here. Update to kernel 3.10.7 fixed the issue for me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum