Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] media-video/avidemux-2.6.2-r1 GUI question
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 395
Location: Cracow, Poland

PostPosted: Thu Mar 28, 2013 1:56 pm    Post subject: [solved] media-video/avidemux-2.6.2-r1 GUI question Reply with quote

Hi,
I recently update avidemux (after split into 3 packages). Always I had -qt4 USE set for avidemux, so I believe I had gtk gui built (it was in this way for 2.5.*, 2.6.1 and 2.6.2). Since 2.6.2-r1 I notice there is no GUI at all only avidemux3_cli. So, I set qt4 USE flag and after emerge I got avidemux3_qt4. The point is do I really need qt4 flag to have GUI, I preffered previouse look of avidemux.

When I stalk the emerge od avidemux (call me freak, I do it often ;)) during configuration I notice there is a option use gtk and or qt4, so ebuild isn't rady still?

Secondlly I notice starnge thing, I got enabled fontconfig and truetype USE
Code:
eix avidemux
[I] media-libs/avidemux-core
     Available versions:  (2.6) (~)2.6.2-r1
        {{a52 aften alsa amr debug dts fontconfig jack lame libsamplerate linguas_ca linguas_cs linguas_de linguas_el linguas_es linguas_fr linguas_it linguas_ja linguas_pt_BR linguas_ru linguas_sr linguas_sr@latin linguas_tr mmx nls oss sdl -system-ffmpeg truetype vorbis x264 xv xvid}}
     Installed versions:  2.6.2-r1(2.6)(02:46:54 PM 03/26/2013)(a52 alsa dts fontconfig lame libsamplerate mmx nls sdl truetype vorbis x264 xv xvid -aften -amr -debug -jack -linguas_ca -linguas_cs -linguas_de -linguas_el -linguas_es -linguas_fr -linguas_it -linguas_ja -linguas_pt_BR -linguas_ru -linguas_sr -linguas_sr@latin -linguas_tr -oss -system-ffmpeg)
     Homepage:            http://fixounet.free.fr/avidemux
     Description:         Core libraries for a video editor designed for simple cutting, filtering and encoding tasks.

[I] media-libs/avidemux-plugins
     Available versions:  (2.6) (~)2.6.2-r2
        {{a52 aften alsa amr debug dts fontconfig jack lame libsamplerate linguas_ca linguas_cs linguas_de linguas_el linguas_es linguas_fr linguas_it linguas_ja linguas_pt_BR linguas_ru linguas_sr linguas_sr@latin linguas_tr mmx nls oss qt4 sdl truetype vorbis x264 xv xvid}}
     Installed versions:  2.6.2-r2(2.6)(12:11:05 AM 03/28/2013)(a52 alsa dts fontconfig lame libsamplerate mmx nls qt4 sdl truetype vorbis x264 xv xvid -aften -amr -debug -jack -linguas_ca -linguas_cs -linguas_de -linguas_el -linguas_es -linguas_fr -linguas_it -linguas_ja -linguas_pt_BR -linguas_ru -linguas_sr -linguas_sr@latin -linguas_tr -oss)
     Homepage:            http://fixounet.free.fr/avidemux
     Description:         Plugins for avidemux; a video editor designed for simple cutting, filtering and encoding tasks.

[I] media-video/avidemux
     Available versions: 
        (2)     [M]2.5.6-r2
        (2.6)   (~)2.6.2-r1
        {{a52 aac aften alsa amr debug dts fontconfig gtk jack lame libsamplerate linguas_bg linguas_ca linguas_cs linguas_de linguas_el linguas_es linguas_fr linguas_it linguas_ja linguas_pt_BR linguas_ru linguas_sr linguas_sr@latin linguas_tr linguas_zh_TW mmx +mp3 nls opengl oss pulseaudio qt4 sdl (+)truetype vorbis vpx (+)x264 (+)xv (+)xvid}}
     Installed versions:  2.6.2-r1(2.6)(11:46:38 PM 03/27/2013)(a52 alsa dts fontconfig lame libsamplerate mmx nls qt4 sdl truetype vorbis x264 xv xvid -aften -amr -debug -jack -linguas_ca -linguas_cs -linguas_de -linguas_el -linguas_es -linguas_fr -linguas_it -linguas_ja -linguas_pt_BR -linguas_ru -linguas_sr -linguas_sr@latin -linguas_tr -oss)
     Homepage:            http://fixounet.free.fr/avidemux
     Description:         Video editor designed for simple cutting, filtering and encoding tasks.

But when I check in program at Help->Build option I fontconfig, freetype and sdl are uncheck. Why?

TomWij, can you commant on that? ;)


Last edited by emc on Thu Mar 28, 2013 5:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Thu Mar 28, 2013 4:00 pm    Post subject: Reply with quote

I don't generally follow everything on the forum, but out of pure luck I came across your topic.

Quote:
so I believe I had gtk gui built


http://www.avidemux.org/smf/index.php?topic=11907.0

Avidemux GTK is broken and needs developers to fix its bugs, an user reported its menu items as broken which makes it seem not really usable to me therefore I removed it altogether; if you see upstream considering gtk again then please let me know, I can opt to add it as a masked USE flag for a while.

Quote:
But when I check in program at Help->Build option I fontconfig, freetype and sdl are uncheck.


Please file this as a bug at http://bugs.gentoo.org such that we both can keep track of this.

This may be one of the latest things that's still broken, for the rest it looks like it is all working again.

I also still need to look further into trying to get system ffmpeg as a possible option as well as putting the USE flags on the packages that they affect, and not on all three of them.
Back to top
View user's profile Send private message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 395
Location: Cracow, Poland

PostPosted: Thu Mar 28, 2013 4:52 pm    Post subject: Reply with quote

TomWij wrote:
I don't generally follow everything on the forum, but out of pure luck I came across your topic.

Lucky bastard I am ;)
Bug 463628 filed. I will attach some logs later on.

*EDIT: Yes Tom, you can add masked USE flag.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum