Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[xhprof + php 5.4] Comment installer ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
ibasaw
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 130
Location: France

PostPosted: Mon Mar 18, 2013 12:55 pm    Post subject: [xhprof + php 5.4] Comment installer ? Reply with quote

Bonjour,

Comment je fais pour installer xhprof sur mon php 5.4 ?

Merci pour votre aide.

Cordialement
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5480
Location: ~Brussels - Belgique

PostPosted: Mon Mar 18, 2013 1:09 pm    Post subject: Reply with quote

emerge xhprof ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ibasaw
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 130
Location: France

PostPosted: Mon Mar 18, 2013 1:10 pm    Post subject: Reply with quote

non, il le bloque sur php 5.3, j'ai besoin de php 5.4
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3756
Location: Lyon, France

PostPosted: Mon Mar 18, 2013 1:53 pm    Post subject: Reply with quote

Il n'y a pas encore de release de xhprof supportant PHP 5.4, mais tu peux toujours l'installer à la main (ou pondre un ebuild qui va bien) depuis le git, ça fonctionne nickel : https://github.com/facebook/xhprof
_________________
Google+ | Twitter
Back to top
View user's profile Send private message
ibasaw
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 130
Location: France

PostPosted: Mon Mar 18, 2013 2:13 pm    Post subject: Reply with quote

J'ai essayer de le faire a la main à partir de ceci http://michaelsanford.com/compiling-xhprof-for-php-5-4/

lors du make, j'obtiens cette erreur:

Code:

make
/bin/sh /home/xhprof-master/extension/libtool --mode=compile cc  -I. -I/home/xhprof-master/extension -DPHP_ATOM_INC -I/home/xhprof-master/extension/include -I/home/xhprof-master/extension/main -I/home/xhprof-master/extension -I/usr/lib64/php5.4/include/php -I/usr/lib64/php5.4/include/php/main -I/usr/lib64/php5.4/include/php/TSRM -I/usr/lib64/php5.4/include/php/Zend -I/usr/lib64/php5.4/include/php/ext -I/usr/lib64/php5.4/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /home/xhprof-master/extension/xhprof.c -o xhprof.lo
/home/xhprof-master/extension/libtool: line 481: CDPATH: command not found
libtool: Version mismatch error.  This is libtool 2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4
libtool: and run autoconf again.
make: *** [xhprof.lo] Error 63


Je ne sais pas comment aller plus loin ...
Back to top
View user's profile Send private message
ibasaw
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 130
Location: France

PostPosted: Thu Mar 28, 2013 9:59 am    Post subject: Reply with quote

personne pour m'aiguiller pour faire ca ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum