Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] sys-apps/sysvinit-2.88-r4 blocking
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
pgu
Guru
Guru


Joined: 30 Jul 2009
Posts: 514
Location: Oslo, Norway

PostPosted: Sun Mar 24, 2013 1:03 pm    Post subject: [SOLVED] sys-apps/sysvinit-2.88-r4 blocking Reply with quote

I tried a emerge --update world and got:

Code:
[blocks B      ] <sys-apps/sysvinit-2.88-r4 ("<sys-apps/sysvinit-2.88-r4" is blocking sys-apps/util-linux-2.22.2)


But is it safe to unmerge sys-apps/sysvinit and then emerge sys-apps/util-linux?


Last edited by pgu on Sun Mar 24, 2013 9:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2482
Location: Austria

PostPosted: Sun Mar 24, 2013 1:15 pm    Post subject: Reply with quote

just

Code:
emerge -1v =sysvinit-2.88-r4


and the block should be solved.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pgu
Guru
Guru


Joined: 30 Jul 2009
Posts: 514
Location: Oslo, Norway

PostPosted: Sun Mar 24, 2013 1:19 pm    Post subject: Reply with quote

That shows even more dependencies:

Code:
emerge -1v =sysvinit-2.88-r4

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-apps/sysvinit-2.88-r4 [2.88-r3] USE="(-ibm) (-selinux) -static" 104 kB
[blocks B      ] <sys-apps/util-linux-2.22 ("<sys-apps/util-linux-2.22" is blocking sys-apps/sysvinit-2.88-r4)

Total: 1 package (1 upgrade), Size of downloads: 104 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/sysvinit-2.88-r4::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/sysvinit-2.86-r6 required by (virtual/init-0::gentoo, installed)
    =sysvinit-2.88-r4

  (sys-apps/util-linux-2.21.2::gentoo, installed) pulled in by
    >=sys-apps/util-linux-2.20 required by (sys-fs/udev-197-r4::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (x11-libs/libSM-1.2.1::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/lvm2-2.02.97-r1::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/mdadm-3.1.4::gentoo, installed)
    >=sys-apps/util-linux-2.17.2 required by (sys-fs/cryptsetup-1.4.3::gentoo, installed)
    sys-apps/util-linux required by @system
    >=sys-apps/util-linux-2.16 required by (dev-libs/apr-1.4.5::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2482
Location: Austria

PostPosted: Sun Mar 24, 2013 1:24 pm    Post subject: Reply with quote

Just shows the same conflict in more detail. Well, what about

Code:
emerge -1v =util-linux-2.22.2


then?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4971

PostPosted: Sun Mar 24, 2013 2:20 pm    Post subject: Reply with quote

this was discussed long ago, running:
Code:
emerge sys-apps/sysvinit sys-apps/util-linux
should solve the issue.

please search the forum next time.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2482
Location: Austria

PostPosted: Sun Mar 24, 2013 2:27 pm    Post subject: Reply with quote

First of all, always add '--oneshot' to such emerge commands as good practise.

Secondly, I'm wondering how this would be any different from the 'emerge -u world' command - unless of course one of the two packages would only be covered by adding '--deep'.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4971

PostPosted: Sun Mar 24, 2013 2:47 pm    Post subject: Reply with quote

genstorm wrote:
First of all, always add '--oneshot' to such emerge commands as good practise.

Secondly, I'm wondering how this would be any different from the 'emerge -u world' command - unless of course one of the two packages would only be covered by adding '--deep'.


frankly I did it by removing one an installing other, later on someone suggested to use that line and it worked so it stayed as is.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2482
Location: Austria

PostPosted: Sun Mar 24, 2013 2:56 pm    Post subject: Reply with quote

I don't remember anymore how I solved it myself, so whutevs. :)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pgu
Guru
Guru


Joined: 30 Jul 2009
Posts: 514
Location: Oslo, Norway

PostPosted: Sun Mar 24, 2013 3:13 pm    Post subject: Reply with quote

DaggyStyle wrote:
this was discussed long ago, running:
Code:
emerge sys-apps/sysvinit sys-apps/util-linux
should solve the issue.

please search the forum next time.


Thanks! It did resolve the issue. I tried to searching the forum, but just got hit in unsupported software. But searching on google using
Code:
"util-linux-2.22" :site forums.gentoo.org
is returned the solution. I'll stick with google for searching the forum...
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4971

PostPosted: Sun Mar 24, 2013 4:14 pm    Post subject: Reply with quote

glad it helped, please mark as solved.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum