Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Circular dependency problem: kmod and virtual/modutils
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
LostInGentoo
Apprentice
Apprentice


Joined: 27 Jun 2002
Posts: 269
Location: Denmark

PostPosted: Fri Mar 22, 2013 5:08 pm    Post subject: Circular dependency problem: kmod and virtual/modutils Reply with quote

Hi

I'm really having problems with circular dependencies: kmod and virtual/modutils

When trying to merge:
Code:

preben@xs36v /usr/src/linux $ sudo emerge -av1 kmod virtual/modutils kmod

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!


[ebuild  N     ] virtual/modutils-0  0 kB
[ebuild  N     ]  sys-apps/kmod-12-r1  USE="tools zlib -debug -doc -lzma -static-libs" 1,246 kB

Total: 2 packages (2 new), Size of downloads: 1,246 kB

 * Error: circular dependencies:

(sys-apps/kmod-12-r1::gentoo, ebuild scheduled for merge) depends on
 (virtual/modutils-0::gentoo, ebuild scheduled for merge) (buildtime)
  (sys-apps/kmod-12-r1::gentoo, ebuild scheduled for merge) (runtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.
preben@xs36v /usr/src/linux $


I have tried oneshot, combinations of kmod and virtual/modutils, unmerged module-init-tools and modutils - but none of this changes the message above.

What can I do?


Last edited by LostInGentoo on Fri Mar 22, 2013 5:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
LostInGentoo
Apprentice
Apprentice


Joined: 27 Jun 2002
Posts: 269
Location: Denmark

PostPosted: Fri Mar 22, 2013 5:15 pm    Post subject: Reply with quote

Emerge --info gives the following: http://invers.dk/public/info.txt
Back to top
View user's profile Send private message
toddaaro
n00b
n00b


Joined: 22 Mar 2013
Posts: 1

PostPosted: Fri Mar 22, 2013 11:23 pm    Post subject: Reply with quote

I'm having the exact same issue, same kmod-modutils circular dependency.
Back to top
View user's profile Send private message
thanny
n00b
n00b


Joined: 15 Aug 2005
Posts: 44

PostPosted: Sat Mar 23, 2013 7:50 am    Post subject: Reply with quote

Ran into the same thing. Don't know enough about how dependencies are specified in ebuild files to say exactly what the problem is, but I worked around it by creating an overlay for virtual/modutils (called it modutils-1 to make sure it overrides the buggy version) with all dependencies removed. I was then able to emerge kmod.
Back to top
View user's profile Send private message
Naib
Advocate
Advocate


Joined: 21 May 2004
Posts: 4103
Location: Removed by Neddy

PostPosted: Sat Mar 23, 2013 2:40 pm    Post subject: Reply with quote

USE -tools

what does that do for you?
_________________
A free press is the unsleeping guardian of every other right that free men prize; it is the most dangerous foe of tyranny. Where men have the habit of liberty, the Press will continue to be the vigilant guardian of the rights of the ordinary citizen.
Back to top
View user's profile Send private message
LostInGentoo
Apprentice
Apprentice


Joined: 27 Jun 2002
Posts: 269
Location: Denmark

PostPosted: Sat Mar 23, 2013 4:36 pm    Post subject: Reply with quote

tried the "-tools" also, and the same error...

Besides, I would understand that this would actually cause an error since virtual/modutils requires either kmod with the tools useflag or modutils sysapp or module-init-tools! However, having the tools use flag defined does not make sense to me why this causes trouble!


Regards
Preben
Back to top
View user's profile Send private message
asdc
n00b
n00b


Joined: 03 Jul 2012
Posts: 2

PostPosted: Sat Mar 23, 2013 10:51 pm    Post subject: Reply with quote

I ran into the same problem as you today...

I fixed it by forcing kmod to update with no dependency checks

Code:
emerge --oneshot --nodeps kmod


After tht my modutils update worked. I don't know how safe it is, but it worked...

Good luck.
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Sun Mar 24, 2013 12:38 pm    Post subject: Reply with quote

After syncing the portage tree and updateing portage itself this morning the problem seems to be solved. The circular dependency is gone for me
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum