Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Startx slow and networking too
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
aim nano
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2006
Posts: 115
Location: Jackson, MS

PostPosted: Mon Mar 18, 2013 5:59 pm    Post subject: [solved]Startx slow and networking too Reply with quote

I'm getting about a 20 second delay after typing startx. I think it's hanging on something like "xauth: /mnt/archive/Users/Andrew/Desktop/archive/.serverauthXXXX does not exist." *concerning this, i moved home to another partition by editing /etc/passwd, could that be causing problems?

cat /etc/passwd | grep andrew
Code:
andrew:x:1000:1000::/mnt/archive/Users/Andrew/Desktop/archive:/bin/bash


cat /etc/fstab | grep sdb2
Code:
/dev/sdb2      /mnt/archive   auto      defaults,noatime 0 3


Following that, once X (xfce) loads, it's another 60-120 seconds before my network 'works.' I have a static lan IP.

I think the two may be related. I've gone over my networking related files over and over, but I can't seem to resolve it.

/etc/resolv.conf:
Code:
# Generated by net-scripts for interface eth0
nameserver 68.94.156.1
nameserver 68.94.157.1


/etc/conf.d/net:
Code:
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc*/net.example* and save your configuration
# in /etc/conf.d/net (this file :]!).
dns_domain_lo="nanohome"
config_eth0="192.168.1.55 netmask 255.255.255.0 brd 192.168.1.255"
routes_eth0="default via 192.168.1.254"
dns_servers_eth0="68.94.156.1 68.94.157.1"


/etc/conf.d/hostname:
Code:
# Set to the hostname of this machine
hostname="desktop"


/etc/hosts:
Code:
# /etc/hosts: Local Host Database
#
# This file describes a number of aliases-to-address mappings for the for
# local hosts that share this file.
#
# In the presence of the domain name service or NIS, this file may not be
# consulted at all; see /etc/host.conf for the resolution order.
#

# IPv4 and IPv6 localhost aliases
127.0.0.1   desktop.nanohome desktop localhost
#::1      localhost

#
# Imaginary network.
#10.0.0.2               myname
#10.0.0.3               myfriend
#
# According to RFC 1918, you can use the following IP networks for private
# nets which will never be connected to the Internet:
#
#       10.0.0.0        -   10.255.255.255
#       172.16.0.0      -   172.31.255.255
#       192.168.0.0     -   192.168.255.255
#
# In case you want to be able to connect directly to the Internet (i.e. not
# behind a NAT, ADSL router, etc...), you need real official assigned
# numbers.  Do not try to invent your own network numbers but instead get one
# from your network provider (if any) or from your regional registry (ARIN,
# APNIC, LACNIC, RIPE NCC, or AfriNIC.)


rc-update:
Code:
rc-update
                acpid |      default                 
            alsasound | boot                         
             bootmisc | boot                         
           consolekit |      default                 
                 dbus |      default                 
                devfs |                       sysinit
                dmesg |                       sysinit
                 fsck | boot                         
             hostname | boot                         
              hwclock | boot                         
              keymaps | boot                         
            killprocs |              shutdown       
                local |      default                 
           localmount | boot                         
              modules | boot                         
             mount-ro |              shutdown       
                 mtab | boot                         
             net.eth0 |      default                 
               net.lo | boot                         
             netmount |      default                 
               procfs | boot                         
                 root | boot                         
            savecache |              shutdown       
                 swap | boot                         
            swapfiles | boot                         
               sysctl | boot                         
                sysfs |                       sysinit
            syslog-ng |      default                 
         termencoding | boot                         
       tmpfiles.setup | boot                         
                 udev |                       sysinit
           udev-mount |                       sysinit
              urandom | boot                         
           vixie-cron |      default


Let me know if any additional info is required.


SOLVED EDIT:

1) startx slow solved by changing /etc/hosts to:

Code:
127.0.0.1   localhost   desktop
::1      localhost   desktop


2) network starting slow fixed by installing linux-firmware and rebooting.

Thanks #gentoo (irc.freenode.net)!
_________________
Unanswered posts need love too.
--
~ # emerge -pv gentoo-love


Last edited by aim nano on Fri Mar 22, 2013 6:38 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31351
Location: 56N 3W

PostPosted: Mon Mar 18, 2013 6:47 pm    Post subject: Reply with quote

aim nano,

A line in /etc/hosts
Code:
192.168.1.55  desktop.nanohome desktop
might help, so the systems real IP address resolves to itself.
Xorg really does talk to itself over the network.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
aim nano
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2006
Posts: 115
Location: Jackson, MS

PostPosted: Tue Mar 19, 2013 2:35 am    Post subject: Reply with quote

In addition to the line I already have? Or replace it?

Code:
127.0.0.1   desktop.nanohome desktop localhost


***Edit*** Well I tried both ways: commenting out the existing lines AND adding an additional line. Neither seemed to work.

Crazy thing is it all works fine after ~20 seconds for startx and ~60+ for networking/dns/etc. I just can't figure out what's hanging it up.
_________________
Unanswered posts need love too.
--
~ # emerge -pv gentoo-love
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31351
Location: 56N 3W

PostPosted: Tue Mar 19, 2013 6:55 pm    Post subject: Reply with quote

aim nano,

It was intended as a new entry. You need the localhost entry too.

What does
Code:
hostname -f
show?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
aim nano
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2006
Posts: 115
Location: Jackson, MS

PostPosted: Tue Mar 19, 2013 11:22 pm    Post subject: Reply with quote

desktop.nanohome

(that's with my original /etc/hosts, since i reverted after trying those two other variations)
_________________
Unanswered posts need love too.
--
~ # emerge -pv gentoo-love
Back to top
View user's profile Send private message
wcg
Guru
Guru


Joined: 06 Jan 2009
Posts: 588

PostPosted: Wed Mar 20, 2013 3:07 am    Post subject: Reply with quote

Code:

man strace


(strace must be installed, of course. It has a log facility with system call
timestamping options.)

You likely need a kernel/userspace that is not slow as well as one that
is slow to compare strace logs and see which system calls are taking a long time
to return.
_________________
TIA
Back to top
View user's profile Send private message
aim nano
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2006
Posts: 115
Location: Jackson, MS

PostPosted: Fri Mar 22, 2013 5:30 am    Post subject: Reply with quote

Fixed the startx issue by editing my /etc/hosts as follows:

Code:
127.0.0.1   localhost   desktop
::1      localhost   desktop


But it still takes my network about 2 minutes to load after boot. Any ideas what's taking it so long with a static config?

Edit:

New info via dmesg...could this be causing my network to come up late? It's not slowing my boot-up at all, but my network definitely isn't available as early as it should be:

# dmesg | grep 8169
[ 1.037546] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[ 1.039798] r8169 0000:05:00.0: irq 72 for MSI/MSI-X
[ 1.040038] r8169 0000:05:00.0 eth0: RTL8168evl/8111evl at 0xffffc90000c70000, bc:5f:f4:7a:1d:18, XID 0c900800 IRQ 72
[ 1.042166] r8169 0000:05:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[ 8.809887] r8169 0000:05:00.0 eth0: unable to load firmware patch rtl_nic/rtl8168e-3.fw (-2)
[ 8.818935] r8169 0000:05:00.0 eth0: link down
[ 8.818959] r8169 0000:05:00.0 eth0: link down
[ 10.566042] r8169 0000:05:00.0 eth0: link up
_________________
Unanswered posts need love too.
--
~ # emerge -pv gentoo-love
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Fri Mar 22, 2013 10:54 am    Post subject: Reply with quote

aim nano wrote:
eth0: unable to load firmware patch rtl_nic/rtl8168e-3.fw (-2)


Code:

# emerge -v linux-firmware
# qfile -v /lib/firmware/rtl_nic/rtl8168e-3.fw
sys-kernel/linux-firmware-20130113 (/lib/firmware/rtl_nic/rtl8168e-3.fw)


Could be worth seeing how things improve with firmware installed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum