Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rxvt-unicode acting up ... or is it X?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
james_d
n00b
n00b


Joined: 20 Mar 2013
Posts: 2

PostPosted: Thu Mar 21, 2013 12:51 am    Post subject: rxvt-unicode acting up ... or is it X? Reply with quote

i really like rxvt-unicode, but the past few months it's been acting up.
the first problem *was* about 1/5 of the time when i double clicked text it would select the entire line.
and when i would paste it all i would get is a new line. it's supposed to just select the word i double click.
i could alleviate the problem by opening a new terminal (not just any window) and selecting.
the effected terminal would copy/paste as expected

that problem went away.
now the problem is when i maximize the window vertically it the relevant text is overwritten with what
once scrolled off the top. or text that gets shifted to the left or right.
i can clear the corrupt window by scrolling over another window, browser, terminal, gkrellm or whatnot.

i'm not sure if it's rxvt-unicode, my WM (fvwm), input, xorg, USE flagsl, other layer or a combination.
it doesnt happen with xterm or others.

it happens with all version of rxvt-unicode and stable/release versions of x11-drivers

Code:
user@localhost ~ $ emerge -pv rxvt-unicode

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] x11-terms/rxvt-unicode-9.17  USE="256-color alt-font-width fading-colors focused-urgency font-styles mousewheel perl xft -blink -buffer-on-clear -iso14755 -pixbuf -secondary-wheel -startup-notification -unicode3 -vanilla -wcwidth" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


Code:
user@localhost ~ $ emerge -pv @x11-module-rebuild

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] x11-drivers/xf86-input-evdev-2.7.3-r1  0 kB
[ebuild   R   ~] x11-drivers/xf86-video-intel-2.21.4  USE="dri sna udev xvmc -glamor -uxa" 0 kB
[ebuild   R    ] x11-drivers/xf86-input-mouse-1.8.1  0 kB
[ebuild   R    ] x11-drivers/xf86-input-keyboard-1.6.2  0 kB
[ebuild   R   ~] x11-drivers/xf86-input-synaptics-1.6.3  0 kB
[ebuild   R   ~] media-libs/mesa-9.1  USE="classic egl gallium nptl openvg shared-glapi xorg xvmc -bindist -debug -gbm -gles1 -gles2 -llvm -osmesa -pax_kernel -pic (-r600-llvm-compiler) (-selinux) -vdpau -wayland -xa" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" VIDEO_CARDS="i915 i965 intel -nouveau -r100 -r200 -r300 -r600 -radeon (-radeonsi) -vmware" 2 kB
[ebuild   R   ~] x11-drivers/xf86-video-vesa-2.3.2-r1  0 kB
[ebuild   R   ~] x11-drivers/xf86-video-fbdev-0.4.3-r1  0 kB

Total: 8 packages (8 reinstalls), Size of downloads: 0 kB


any insight is appreciated
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum