Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WOL Not working with Supermicro X7SPA-HF-D525-O [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
KWhat
Guru
Guru


Joined: 04 Sep 2005
Posts: 551
Location: Los Angeles

PostPosted: Tue Mar 19, 2013 4:46 pm    Post subject: WOL Not working with Supermicro X7SPA-HF-D525-O [Solved] Reply with quote

I have had wake on lan working on my X7SPA-HF-D525 for a while and then one day it just stopped working. I believe I have everything enabled correctly on the system wtih `ethtool -s eth0 wol g`. There doesn't appear to be a setting anywhere in the bios to enabled WOL. I am looking for possible reasons this is not working. Could there be a problem in IPMI?

Code:

~ # ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes                                                                   
        Speed: 1000Mb/s                                                                                   
        Duplex: Full                                                                                       
        Port: Twisted Pair                                                                                 
        PHYAD: 1                                                                                           
        Transceiver: internal                                                                             
        Auto-negotiation: on                                                                               
        MDI-X: on                                                                                         
        Supports Wake-on: pumbg                                                                           
        Wake-on: g                                                                                         
        Current message level: 0x00000007 (7)                                                             
                               drv probe link                                                             
        Link detected: yes                                                                                 

~ # ethtool eth1
Settings for eth1:                                                                                         
        Supported ports: [ TP ]                                                                           
        Supported link modes:   10baseT/Half 10baseT/Full                                                 
                                100baseT/Half 100baseT/Full                                               
                                1000baseT/Full                                                             
        Supported pause frame use: No                                                                     
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: Unknown!
        Duplex: Unknown! (255)
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: no


Last edited by KWhat on Mon Apr 01, 2013 5:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
aim nano
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2006
Posts: 115
Location: Jackson, MS

PostPosted: Tue Mar 19, 2013 11:31 pm    Post subject: Reply with quote

Looks like there may be a BIOS setting: "Please check if wake up the server by MAC address; usually this is set to magic packet."

-from their website: http://www.supermicro.com/support/faqs/faq.cfm?faq=11682

If not, maybe a BIOS update is in order?
_________________
Unanswered posts need love too.
--
~ # emerge -pv gentoo-love
Back to top
View user's profile Send private message
KWhat
Guru
Guru


Joined: 04 Sep 2005
Posts: 551
Location: Los Angeles

PostPosted: Tue Mar 19, 2013 11:33 pm    Post subject: Reply with quote

I am pretty sure thats the Windows equivalent of "Wake-on: g". I have been thinking about a bios update, just wanted to check here first and make sure I didnt miss or forget something.
Back to top
View user's profile Send private message
aim nano
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2006
Posts: 115
Location: Jackson, MS

PostPosted: Tue Mar 19, 2013 11:48 pm    Post subject: Reply with quote

It sounds to me like they're talking about a BIOS option...then telling you to ADDITIONALLY check the settings in the Windows Device Manager.

So there's nothing about 'wake,' 'mac address,' or 'magic packet' anywhere in the BIOS?
_________________
Unanswered posts need love too.
--
~ # emerge -pv gentoo-love
Back to top
View user's profile Send private message
KWhat
Guru
Guru


Joined: 04 Sep 2005
Posts: 551
Location: Los Angeles

PostPosted: Wed Mar 27, 2013 4:37 pm    Post subject: Reply with quote

If there is a bios setting its not called WOL Wakup by Mac or anything similar. I have tried the following with no luck:

Reflash IPMI Firmware
Reset IPMI to factory default
Reflash BIOS
Clear CMOS
Set bios to fail safe defaults
Set bios to optimal defaults

Something looks a bit fishy with /proc/acpi/wakeup because my Ethernet cards are not showing up in there. I think we may have a case of buggy bios or rubbish hardware.

Some more information:

euclid ~ # lspci
00:00.0 Host bridge: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx DMI Bridge (rev 02)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
01:00.0 RAID bus controller: 3ware Inc 9650SE SATA-II RAID PCIe (rev 01)
02:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
03:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
04:04.0 VGA compatible controller: Matrox Electronics Systems Ltd. MGA G200eW WPCM450 (rev 0a)


euclid ~ # cat /proc/acpi/wakeup
Device S-state Status Sysfs node
P0P1 S4 *disabled pci:0000:00:1e.0
PS2K S4 *enabled pnp:00:0b
USB0 S4 *enabled pci:0000:00:1d.0
USB1 S4 *enabled pci:0000:00:1d.1
USB2 S4 *enabled pci:0000:00:1d.2
USB5 S4 *disabled
EUSB S4 *enabled pci:0000:00:1d.7
USB3 S4 *enabled pci:0000:00:1a.0
USB4 S4 *enabled pci:0000:00:1a.1
USB6 S4 *enabled pci:0000:00:1a.2
USBE S4 *enabled pci:0000:00:1a.7
P0P4 S4 *disabled pci:0000:00:1c.0
P0P5 S4 *disabled
P0P6 S4 *disabled
P0P7 S4 *disabled
P0P8 S4 *disabled pci:0000:00:1c.4
P0P9 S4 *disabled pci:0000:00:1c.5
GBE S4 *disabled
Back to top
View user's profile Send private message
KWhat
Guru
Guru


Joined: 04 Sep 2005
Posts: 551
Location: Los Angeles

PostPosted: Mon Apr 01, 2013 4:58 pm    Post subject: Reply with quote

So I finally solved the problem. It turns out that if IPMI is enabled, WOL does not work. There is no documentation about that from SuperMicro and I am not sure there is any reason it shouldn't work. Yet another bug laden bios we have come to expect from SuperMicro.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum