Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[multilib] ABI_x86 (résolu)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Wed Mar 13, 2013 9:40 am    Post subject: [multilib] ABI_x86 (résolu) Reply with quote

Bonjour,

Je viens pour une petite question de MAJ. Je vois qu'emerge veut me faire ajouter une option "ABI_x86=32 64" (apparemment pour la gestion du multilib). Cette option bloque les paquets du type app-emulation/emul-linux-x86-xlibs et je vois sur les forums anglais (http://forums.gentoo.org/viewtopic-p-7266638.html) que ça peut poser problème pour des paquets comme wine ou skype, quelqu'un a fait les tests et peut me dire ce qu'il en est? J'ai peur de faire la MAJ et de ne plus pouvoir faire marcher ces paquets jusqu'à ce qu'ils soient mis à jour à leur tour.

Merci d'avance!

Kevin
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français


Last edited by Kevin57 on Wed Mar 13, 2013 12:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5267
Location: ~Brussels - Belgique

PostPosted: Wed Mar 13, 2013 9:56 am    Post subject: Reply with quote

Hello,

Je vais regarder l'un de ces jours ;)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Wed Mar 13, 2013 9:58 am    Post subject: Reply with quote

En attendant, je préfère ne pas faire la MAJ, j'utilise wine assez régulièrement (bien obligé de contrôler l'aspect des documents sous Word dans mon métier) donc ce serait embêtant que la MAJ casse wine...
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Wed Mar 13, 2013 10:04 am    Post subject: Reply with quote

La version 1.5.25 de wine est censée gérer cette nouvelle variable ABI_X86 (qui remplace alors les USE win32 et win64).
J'ai essayé d'y passer, je ne m'en suis pas sorti, mais je suis en stable. Donc pour le moment j'attend de voir.
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Wed Mar 13, 2013 10:10 am    Post subject: Reply with quote

En effet, je l'ai déjà installée et je ne m'étais pas rendu compte qu'elle incluait cette option. Du coup, c'est sûr que wine continuera de marcher si je fais la MAJ?
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Wed Mar 13, 2013 10:35 am    Post subject: Reply with quote

Si wine compile et s'installe correctement, il n'y a pas de raison qu'il ne fonctionne pas, c'est exactement la même version qu'aurapavant.
C'est simplement la gestion du multilib côté gentoo qui est modifiée. Tu es en ~arch ?
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Wed Mar 13, 2013 10:46 am    Post subject: Reply with quote

Oui, je suis en ~amd64 (c'est écrit dans ma signature :D ). Je viens de lancer la MAJ, d'autant que je viens de voir que le ABI_x86=32 semble juste bloquer <=app-emulation/emul-linux-x86-xlibs-20130224 et que la MAJ inclut, justement, app-emulation/emul-linux-x86-xlibs-20130224-r1, donc peut-être que les deux pourront cohabiter le temps que tout l'arbre s'adapte. Cela dit, une news aurait été intéressante avant de faire un changement...
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3319
Location: Paris - France

PostPosted: Wed Mar 13, 2013 11:01 am    Post subject: Reply with quote

C'est "super" cette nouveauté : maintenant les lilbs 32bits sont assurées partiellement par les ebuids de l'arbre de portage et plus directement par le paquet emulm-linux-x86-xlibs.

Par contre du coup, il faut se taper tout un stock de USE en plus, mon package.use devient magnifiquement lisible :o
Code:
media-libs/fontconfig abi_x86_32
media-libs/freetype abi_x86_32
dev-libs/libpthread-stubs abi_x86_32
x11-libs/libX11 abi_x86_32
x11-libs/libXau abi_x86_32
x11-libs/libxcb abi_x86_32
x11-libs/libXdmcp abi_x86_32
x11-libs/libXext abi_x86_32
x11-libs/libXrender abi_x86_32
x11-proto/xproto abi_x86_32
x11-proto/xextproto abi_x86_32
x11-proto/xf86bigfontproto abi_x86_32
x11-proto/inputproto abi_x86_32
x11-proto/renderproto abi_x86_32
x11-proto/kbproto abi_x86_32
x11-proto/xcb-proto abi_x86_32

x11-libs/libICE abi_x86_32
x11-libs/libSM abi_x86_32
x11-libs/libXdamage abi_x86_32
x11-libs/libXfixes abi_x86_32
x11-libs/libXxf86vm abi_x86_32
x11-libs/libXinerama abi_x86_32
x11-libs/libXcomposite abi_x86_32
x11-libs/libXScrnSaver abi_x86_32
x11-libs/libXp abi_x86_32
x11-libs/libXv abi_x86_32
x11-libs/libXpm abi_x86_32
x11-libs/libXxf86dga abi_x86_32
x11-libs/libXt abi_x86_32
x11-libs/libXcursor abi_x86_32
x11-libs/libXft abi_x86_32
x11-libs/libXaw abi_x86_32
x11-libs/libXtst abi_x86_32
x11-libs/libpciaccess abi_x86_32
x11-libs/libXrandr abi_x86_32
x11-libs/libvdpau abi_x86_32
x11-libs/libXvMC abi_x86_32
x11-libs/libXi abi_x86_32
x11-libs/libXmu abi_x86_32
x11-proto/damageproto abi_x86_32
x11-proto/fixesproto abi_x86_32
x11-proto/xf86vidmodeproto abi_x86_32
x11-proto/randrproto abi_x86_32
x11-proto/xf86dgaproto abi_x86_32
x11-proto/xineramaproto abi_x86_32
x11-proto/scrnsaverproto abi_x86_32
x11-proto/printproto abi_x86_32
x11-proto/recordproto abi_x86_32
x11-proto/videoproto abi_x86_32
x11-proto/compositeproto abi_x86_32

_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5267
Location: ~Brussels - Belgique

PostPosted: Wed Mar 13, 2013 11:06 am    Post subject: Reply with quote

Ouais... je suis relativement content : enfin partis ces blobs pas à jour par rapport à ~arch.

Pour les use, groupe-les dans un fichier du genre /etc/portage/package.use/multilib ;)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Wed Mar 13, 2013 11:21 am    Post subject: Reply with quote

guilc wrote:

Par contre du coup, il faut se taper tout un stock de USE en plus, mon package.use devient magnifiquement lisible :o

Un :
Code:

ABI_X86="64 32"

dans le make.conf ne suffit pas ?
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5267
Location: ~Brussels - Belgique

PostPosted: Wed Mar 13, 2013 11:28 am    Post subject: Reply with quote

C'est ce que le topic pointé par Kevin propose.
Mais dans ce cas, ne va-t-on pas tout compiler en 32 bits au lieu de ne prendre que le nécessaire ?

Vivement une doc / news !
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Wed Mar 13, 2013 11:38 am    Post subject: Reply with quote

Personnellement, j'ai juste ajouté ABI_X86="64 32" dans mon make.conf et tout semble bien marcher. Mais du coup, en effet, tout doit être compilé "en double" je suppose, mais ça ne me dérange pas, j'aime autant en avoir un peu trop que pas assez...
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Wed Mar 13, 2013 11:54 am    Post subject: Reply with quote

XavierMiller wrote:
Mais dans ce cas, ne va-t-on pas tout compiler en 32 bits au lieu de ne prendre que le nécessaire ?

Ah oui je n'avais pas vu çà comme çà. Je verrai en temps voulu comment je gérerai la chose, mais je pense que j'activerai par défaut la compilation 32 bits, et si besoin je redéfinirai la variable ABI_X86 (en utilisant les fichier package.env) au cas par cas pour les paquets qui prennent du temps à compiler et dont je n'ai pas besoin (qt par exemple).
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5267
Location: ~Brussels - Belgique

PostPosted: Wed Mar 13, 2013 12:42 pm    Post subject: Reply with quote

ouais, ou un package.use ;-
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5267
Location: ~Brussels - Belgique

PostPosted: Thu Mar 14, 2013 7:52 am    Post subject: Reply with quote

Coucou,

Avec une tétrachiée d'entrées dans un package.use, c'est passé comme une lettre à la poste.
En gros, j'ai récupéré la sortie d'erreur d'emerge et tout injecté dans un package.use spécifique à multilib
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3319
Location: Paris - France

PostPosted: Thu Mar 14, 2013 7:56 am    Post subject: Reply with quote

Anéfé, pareil ici.

Au passage, je package dans mon overlay 2 applis binaires 32bits, bah ça me permet de réduire la voilure des libs 32bits au moins pour l'une d'entre elles et de dépendre seulement sur les libs X11 vraiment nécessaires au lieu de l'intégralité de emul-linux-x86-xlibs ;)
https://gentoo.xwing.info/media-gfx/AfterShotPro/AfterShotPro-1.1.1.10.ebuild
https://gentoo.xwing.info/Documentation/package.use

Donc c'est pas mal, même si c'est quand même un peu lourd à utiliser :o
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5267
Location: ~Brussels - Belgique

PostPosted: Thu Mar 14, 2013 8:16 am    Post subject: Reply with quote

Bah, j'imagine que les emul-linux disparaîtront progressivement pour donner place aux vraies dépendances 32 bits.

Je me réjouis que ces blobs binaires disparaissent enfin !
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3319
Location: Paris - France

PostPosted: Thu Mar 14, 2013 8:24 am    Post subject: Reply with quote

PFFFFFFF, bon, là ça m'énerve : https://bugs.gentoo.org/show_bug.cgi?id=461608
Code:
# Markos Chandras <hwoarang@gentoo.org> (13 Mar 2013)
# Mask because breaking updates out of the blue is bad
# See 461608. Unmask it only if you want abi_x86_32
# which means you have ABI_X86=32 set in your make.conf
=app-emulation/emul-linux-x86-xlibs-20130224-r1

Le coup du j'avance et je recule, c'est juste pénible :?


Sinon, les blobs franchement, ça me gène pas : je mets ces packages uniquement pour 1 programme binaire propriétaire que j'utilise alors bon. Je dirais même au contraire, comme ça ales trucs binaires restent dans leur coin sans impacter le reste de mon système (qui n'est multilib QUE pour ça)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Thu Mar 14, 2013 10:48 am    Post subject: Reply with quote

Xavier : je n'arrive pas à voir la différence entre ajouter les paquets dans le package.use et le faire comme je l'ai fait moi (donc direct dans le make.conf) si c'est pour, de toute manière, mettre tous les paquets dans le package.use. Tu peux m'expliquer?
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5267
Location: ~Brussels - Belgique

PostPosted: Thu Mar 14, 2013 10:51 am    Post subject: Reply with quote

La différence est que je n'ai mis que les paquets nécessaires, et pas demandé que tous les paquets proposant la double ABI se compilent aussi en 32 bits.
Au final, je n'ai qu'une trentaine de paquets, et pas une centaine (au pif).
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Thu Mar 14, 2013 10:58 am    Post subject: Reply with quote

Ah d'accord. Je demandais parce que finalement (en tout cas aujourd'hui), j'ai eu autant de paquets à recompiler en modifiant le make.conf que si j'avais édité le package.use (à un ou deux près, peut-être), donc je ne voyais pas la différence. Mais elle risque d'être visible quand tous les paquets auront été adaptés, c'est ça?
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5267
Location: ~Brussels - Belgique

PostPosted: Thu Mar 14, 2013 11:08 am    Post subject: Reply with quote

ouiche :)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Thu Mar 14, 2013 11:15 am    Post subject: Reply with quote

Bon, ben pour rester fidèle à moi-même : j'improviserai quand j'en aurai marre! :D
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5267
Location: ~Brussels - Belgique

PostPosted: Thu Mar 14, 2013 6:50 pm    Post subject: Reply with quote

C'est la procession d'Echternach ce truc ! :(
J'ai démasqué l'ebuild emul-*, mais vu le bug je crains qu'on ne revienne en arrière vers les blobs binaires avant qu'on ne fixe définitivement les bricolages de l'overlay multilib...
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
blietaer
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2006
Posts: 103

PostPosted: Mon Mar 18, 2013 11:41 am    Post subject: Reply with quote

netfab wrote:

Un :
Code:

ABI_X86="64 32"

dans le make.conf ne suffit pas ?


Nope: du coup il y a une ch*!#ée de ebuilds (29!) qui bloquent au emerge -avDNut @world suivant... 8O

Cela disparait si je laisse uniquement:
Code:

ABI_X86="64"

Mais bcp de ebuils (libx11) se font remoudre en "-32" du coup, ...pas certain que ce soit ce que je veuilles. :roll:

Donc il faut placer le:
Code:

ABI_X86="64 32"


et taper le USE abi_x86_32 dans make.conf ?!!! :?:


Edit: ah, tiens, non cela ne guéri rien: tjrs 29 ebuilds bloquants... :evil:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum