Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Properly setting Python variables[Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Tue Mar 12, 2013 2:24 pm    Post subject: Properly setting Python variables[Solved] Reply with quote

See:
Blender 2.66 - seems to be held back by Python 3.3

I would like to get this thread merged with that one once someone gives me a lead. As you can see from that post. I have properly unmasked all items and dependencies. I thought this was going to be easy, but I stayed up too late fighting PYTHON_SINGLE_TARGET and PYTHON_TARGETS. No matter what I do, I cannot get the system to accept the new settings using either portage or paludis. Things I've tried:
  1. Set PYTHON_SINGLE_TARGET to Python3_3 in use.conf
  2. Set PYTHON_TARGETS to python2_7 python3_3 in use.conf
  3. eselected package-manager to portage
  4. Repeated Step 1 and 2 in /etc/make.conf
  5. Read the python-r1 User's Guide to make sure I was setting them correctly
  6. Set the same Items from 1 and 2 as per package variables in package.use/use.conf
  7. Checked Spelling
  8. emerge'd portage with python3 set so I could:
  9. eselect python set 3 (python 3.3)
  10. Went to bed while:
  11. python updater, crashed with three packages to go because the last 3 need PYTHON_TARGETS set to python3_3, which is the same issue I'm having with blender


After Doing all this, followed by source /etc/profile each time, emerge --info still reports:
PYTHON_SINGLE_TARGET=python2_7 PYTHON_TARGETS=python2_7 python3_2. Step 3 Above is still set as I write this post. Can any readers nudge me in the right direction, or tell me what I might have forgotten :?:
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper


Last edited by eyoung100 on Tue Mar 12, 2013 4:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6250
Location: Goose Creek SC

PostPosted: Tue Mar 12, 2013 4:45 pm    Post subject: Reply with quote

you don't mention unmasking and keywording for >=dev-lang/python-3.3.0
_________________
Defund the FCC.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Tue Mar 12, 2013 4:58 pm    Post subject: Reply with quote

DONAHUE wrote:
you don't mention unmasking and keywording for >=dev-lang/python-3.3.0

At 1 AM I had lost sight of the fact that Pyton 3.3 is hard masked by /usr/portage/profiles/base/use.mask. See the thread I referred to for the ending :D FINALLY :!:
Setting Topic to [Solved]
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum