Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Qtractor fails to emerge due to "emake" error.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 131
Location: Brisbane AU

PostPosted: Sun Mar 10, 2013 6:02 am    Post subject: Qtractor fails to emerge due to "emake" error. Reply with quote

Qtractor fails to emerge due to "emake" error:

>>> Failed to emerge media-sound/qtractor-0.5.7, Log file:

>>> '/var/tmp/portage/media-sound/qtractor-0.5.7/temp/build.log'

* Messages for package media-sound/qtractor-0.5.7:

* ERROR: media-sound/qtractor-0.5.7 failed (compile phase):
* died running emake, base_src_make
*
* Call stack:
* ebuild.sh, line 93: Called src_compile
* environment, line 2565: Called qt4-r2_src_compile
* environment, line 2437: Called base_src_compile
* environment, line 434: Called base_src_make
* environment, line 472: Called die
* The specific snippet of code:
* emake "$@" || die "died running emake, $FUNCNAME";

Do you want the build log getpasted?
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 600

PostPosted: Sun Mar 10, 2013 10:34 am    Post subject: Re: Qtractor fails to emerge due to "emake" error. Reply with quote

52midnight wrote:
Do you want the build log getpasted?


It's a good idea... :lol:
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8938

PostPosted: Sun Mar 10, 2013 4:13 pm    Post subject: Re: Qtractor fails to emerge due to "emake" error. Reply with quote

52midnight wrote:
Do you want the build log getpasted?
We could guess randomly at the error if you like, but the failure message tells you to post the topmost error so that we can provide guided help on the first try.
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 131
Location: Brisbane AU

PostPosted: Sun Mar 10, 2013 6:35 pm    Post subject: Reply with quote

Done: Your paste can be seen here: http://bpaste.net/show/82741/

FYI this appears similar to the fault I reported on a recent post:

http://forums.gentoo.org/viewtopic-t-953520.html

which attracted he replies:

Quote:
It won't build with python3.
It appears you attempted to use Python3 with a Python script that is not yet compatible with Python3.
This means you should switch to python2.7 as your system Python.


I don't know how to ".. switch to python2.7 as your system Python" nor whether this should be done as a temperary fix for the duration of the emerge, or as a permant change. If you could explain these I'll give it another try.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8938

PostPosted: Sun Mar 10, 2013 10:25 pm    Post subject: Reply with quote

52midnight wrote:
Done: Your paste can be seen here: http://bpaste.net/show/82741/

FYI this appears similar to the fault I reported on a recent post:

http://forums.gentoo.org/viewtopic-t-953520.html
How are those similar? One is a C++ program that fails to compile due to a const violation and the other is that your system is configured incorrectly for Python.
52midnight wrote:
which attracted he replies:

Quote:
It won't build with python3.
It appears you attempted to use Python3 with a Python script that is not yet compatible with Python3.
This means you should switch to python2.7 as your system Python.


I don't know how to ".. switch to python2.7 as your system Python" nor whether this should be done as a temperary fix for the duration of the emerge, or as a permant change. If you could explain these I'll give it another try.
eselect python set python2.7
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 131
Location: Brisbane AU

PostPosted: Sun Mar 10, 2013 10:35 pm    Post subject: Reply with quote

Hu wrote:
How are those similar? One is a C++ program that fails to compile due to a const violation and the other is that your system is configured incorrectly for Python.

They are similar in that each failed due to emake dying:
Code:
 * emake export.h || die;
 * emake "$@" || die "died running emake, $FUNCNAME";

The fact that each derived from different causes is evident to more experienced Users, but I thought this forum also catered to the inexperienced?

> eselect python set python2.7

OK, thanks, will do it.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4646
Location: Saint Amant, Acadiana

PostPosted: Sun Mar 10, 2013 11:02 pm    Post subject: Reply with quote

Google tells us there is a ticket http://ehc.ac/p/qtractor/tickets/39/

Regarding new users. It's not important whether you are new user or not. What makes difference is whether you are asking for support or trying to provide it. In first case this should be followed.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8938

PostPosted: Mon Mar 11, 2013 12:59 am    Post subject: Reply with quote

52midnight wrote:
Hu wrote:
How are those similar? One is a C++ program that fails to compile due to a const violation and the other is that your system is configured incorrectly for Python.

They are similar in that each failed due to emake dying:
Code:
 * emake export.h || die;
 * emake "$@" || die "died running emake, $FUNCNAME";

The fact that each derived from different causes is evident to more experienced Users, but I thought this forum also catered to the inexperienced?
Yes, we do cater to the inexperienced. However, you have been here for a year according to your profile, you are making claims that are misleading, and you are not labeling such claims as uninformed speculation. Inexperienced but otherwise reasonable future readers may, upon seeing such a statement made and not challenged, believe it to be correct. I could have made my challenge less pointed by omitting the proper explanation, but it seemed more helpful to explain to you why I believe that you are wrong than to make an unsupported challenge of "How are those similar?" with no further comment.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum