Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[modules][réseau] Problèmes de config réseau [RESOLU]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
George Abitbol
n00b
n00b


Joined: 02 Feb 2006
Posts: 55

PostPosted: Fri Mar 01, 2013 8:03 am    Post subject: [modules][réseau] Problèmes de config réseau [RESOLU] Reply with quote

Bonjour à tous,

retour sur le forum après 5ans et demi d'absence, ça a été bien galère de retrouver mon mot de passe et l'adresse mail que j'avais utilisés pour m'inscrire :lol:

Alors voilà le topo, j'ai eu besoin de coller quelque chose sur un vieux laptop (qui date de 2004, pentium-m 1.7GHz, 512 Mo RAM...) qui dormait dans un coin, windows c'est trop lourd, et Ubuntu aussi, donc je me suis dit tant pis remettons les mains dans le cambouis et installons une gentoo, ça carburait bien à l'époque (pas eu le courage de partir sur FreeBSD).
Donc me voilà parti, l'install se passe bien, tout compile sans erreur, et je m'aperçois même que les drivers de ma carte wifi (ipw2200) sont maintenant direct dans le kernel, donc je les mets en module et n'installe pas l'ebuild.
Problème, au moment de booter, patatras, aucune interface réseau. Qu'à cela ne tienne, je modprobe ipw2200, et paf il me dit qu'il veut pas sous prétexte que "invalid module format". Bon. Après un petit coup au dmesg et /var/log/messages, je m'aperçois qu'il y a le petit message suivant au moment de charger le module :
Code:
exports duplicate symbol alloc_libipw (owned by kernel)

Flûte alors.

Bon du coup je me dis que je vais recompiler en mettant tout ça en dur, tout pareil. Tant pis, je me dis que je vais essayer de passer par les drivers de l'ebuild, mais pour ça, bah il me faut du réseau, donc je recompile mon noyau en ajoutant le driver de ma carte ethernet, tg3 de son petit nom. Reboot, lsmod pour vérifier que mon module et bien chargé, ifconfig pour être sur que tout va bien, et bim, pas d'interface en dehors de lo et d'un machin qui s'appelle sit0.

Alors maintenant que mon problème est exposé, viennent maintenant les question :
- qu'est-ce que c'est que ce fichu bazar de duplicate symbol ? Comment je peux trouver le symbole en doublon et l'autre module qui l'insère en premier ?
- pourquoi quand le module de ma carte ethernet est chargé j'ai pas mon eth0 qui est créé ? Qui s'occupe de faire ça ? udev ?
- pourquoi quand je démarre mon module tg3 est déjà chargé ? Il me semblait qu'à l'époque il fallait soit l'ajouter dans le fichier de module.autoload.d (ou un truc du genre), soit utiliser les services coldplug ou hotplug, là tout est fait tout seul, quelque chose a changé depuis 2007 ?
- pourquoi (mais je suppose que c'est la même raison qu'au-dessus) quand je boote le système cherche à charger le module ipw2200 même quand il est absent du noyau (j'ai complètement enlevé tout ce qui touchait au wifi) ? J'ai d'ailleurs noté que ça ralentissait considérablement le boot, ça reste coincé au moins 20 secondes dessus avant de passer à la suite.
- il me semblait également qu'à partir du moment où les drivers n'étaient pas présents dans le noyau, lspci ne détectait pas le matériel, hors ça paraît ne pas être le cas, j'ai pas mis le driver de mon lecteur SD, ni celui de ma carte ethernet, ni celui de ma carte wifi, pourtant lspci me sort toute la liste sans rien omettre. Ça a changé ou c'est mes souvenirs qui sont à mettre en doute ?

Voilà, merci aux courageux qui ont tout lu jusqu'au bout, j'attends votre aide avec impatience :)

PS : mon install date d'il y a à peu près 2 mois, j'ai un kernel 3.5.7 (gentoo-sources) compilé sans genkernel, j'ai emerge -eD system 3 fois, et dans mon world il doit y avoir à peu près rien d'autre que syslog, vixie-cron, xorg, chrome, fluxbox et peut-être bien e17.
J'essaierai de répondre aux questions dans la mesure du possible sachant que je suis au boulot, que mon PC est chez moi et que quand je suis dessus j'ai pas le net :roll:
_________________
Monde de merde


Last edited by George Abitbol on Mon Mar 04, 2013 1:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
George Abitbol
n00b
n00b


Joined: 02 Feb 2006
Posts: 55

PostPosted: Sun Mar 03, 2013 2:08 pm    Post subject: Reply with quote

Bon alors en fait je suis un boulet, mon /boot est en ext2 et j'ai pas mis le support de ext2 dans mon noyau :?
ipw2200 se charge pas plus par contre j'ai bien mon eth0 de tg3 qui se crée (et qui marche).
_________________
Monde de merde
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2874
Location: Paris

PostPosted: Sun Mar 03, 2013 2:20 pm    Post subject: Reply with quote

Il n'y aurait pas un petit firmware à dégotter, pour ta carte?
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
http://boycottsystemd.org/
Back to top
View user's profile Send private message
George Abitbol
n00b
n00b


Joined: 02 Feb 2006
Posts: 55

PostPosted: Sun Mar 03, 2013 8:48 pm    Post subject: Reply with quote

Sisi, y'a ipw2200-firmware qui fonctionne impec, j'aurais juste voulu réussir à faire fonctionner tout ça avec ce qu'il y a de dispo dans le noyau et sans passer par un package supplémentaire, mais bon, pour cette fois on dira que c'est le résultat qui compte :)
_________________
Monde de merde
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3321
Location: Paris - France

PostPosted: Sun Mar 03, 2013 9:01 pm    Post subject: Reply with quote

Heu oui mais non là ;)
Le firmware n'est pas dans le kernel, et il est indispensable pour à peu près toutes les cartes wifi. Tu ne pourra pas t'en passer !
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
George Abitbol
n00b
n00b


Joined: 02 Feb 2006
Posts: 55

PostPosted: Mon Mar 04, 2013 7:04 am    Post subject: Reply with quote

Marrant ça, pourtant j'ai bien les lignes qu'il me faut dans le noyau, et j'ai bien un ipw2200.ko une fois que c'est compilé, et vu que ça peut être compilé qu'en module et pas en dur je me disais que c'était peut-être un truc ajouté par les patch gentoo-sources.
Je regarderai ça de plus près quand j'en aurai l'occasion, histoire de voir ce qui diffère avec les fichiers du package.

Sinon dernière chose, le but était d'avoir un truc le plus light possible, donc maintenant que mon wifi fonctionne, comment je peux faire pour que le module de ma carte ethernet ne se charge pas tout seul ? (je veux quand même me le garder sous le coude en cas de souci de wifi)
_________________
Monde de merde
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5538
Location: ~Brussels - Belgique

PostPosted: Mon Mar 04, 2013 7:56 am    Post subject: Reply with quote

Hello,

Il te faut en effet 2 composantes :
- le pilote, via un module du kernel ou un module externe
- le firmware, qui est le micro-logiciel à envoyer au périphérique pour qu'il fonctionne. Dans certains cas, c'est un blob binaire, qui n'est pas inclus dans le kernel pour différentes raisons (surtout les licences).

Si l'une des deux composantes manque, ton périphérique ne fonctionnera pas correctement.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
George Abitbol
n00b
n00b


Joined: 02 Feb 2006
Posts: 55

PostPosted: Mon Mar 04, 2013 8:00 am    Post subject: Reply with quote

OK c'est plus clair, merci beaucoup :)
_________________
Monde de merde
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum