Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing an older version of a package. [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 131
Location: Brisbane AU

PostPosted: Mon Mar 04, 2013 12:14 am    Post subject: Installing an older version of a package. [SOLVED] Reply with quote

Is there a way to install an older version of a package, e.g. Xorg-1.12.2 instead of Xorg-1.13.1?

I've browsed the documentation but haven't found anything specific.


Last edited by 52midnight on Tue Mar 05, 2013 7:10 am; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6420
Location: Goose Creek SC

PostPosted: Mon Mar 04, 2013 1:03 am    Post subject: Reply with quote

put
Quote:
>=x11-base/xorg-server-1.13.1
in /etc/portage/package.mask.
Code:
emerge xorg-server

_________________
Defund the FCC.
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 131
Location: Brisbane AU

PostPosted: Mon Mar 04, 2013 1:13 am    Post subject: Reply with quote

DONAHUE wrote:
put
Quote:
>=x11-base/xorg-server-1.13.1
in /etc/portage/package.mask.
Code:
emerge xorg-server

Thanks for that. I'll add it to my list of experiments.
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 131
Location: Brisbane AU

PostPosted: Tue Mar 05, 2013 7:09 am    Post subject: Reply with quote

In addition to masking the later packages, I used the invocation suggested in another thread and got the desired result:

># emerge -av1 =xorg-server-1.12.4

For those unfamiliar with the syntax, the -1 (it's a numeral 1) means 'one-shot', and doesn't include the package in 'world' for subsequent upgrades, and the '=' is an operator specifying a package version rather than the default (latest). The -av is 'ask' and 'verbose' - `man emerge` describes them.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum