Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo ZFS on root - unmount at shutdown and other issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 370

PostPosted: Fri Mar 01, 2013 5:17 pm    Post subject: Gentoo ZFS on root - unmount at shutdown and other issues Reply with quote

Hi all -

It appears I have a 95% successful Gentoo install on a ZFS root. I created my own install CD using catalyst, releng specs, and adding zfs. I then combined https://github.com/ryao/zfs-overlay/blob/master/zfs-install and https://github.com/pendor/gentoo-zfs-install/blob/master/install/GentooInstall.mdown, so my workflow went as followed:

Code:

from pendor's guide:
sgdisk --zap-all /dev/sda (repeat for sdb-sdf)
sgdisk \
    --new=1:2048:133120 --typecode=1:EF02 --change-name=1:"grub" \
    --largest-new=2 --typecode=2:BF01 --change-name=2:"zfs" \
    /dev/sda  #(repeat for sdb-sdf)

reboot w/ installCD

zpool create -m none -R /mnt/gentoo rpool mirror sda2 sdb2 mirror sdd2 sde2 mirror sdc2 sdf2

follow ryao's notes from #create rootfs to #install gptfdisk

skip making partitions and rebooting since I already did this above

install grub2, but for each drive (sda-sdf)

Then commented out fstab and installed software according to gentoo amd64 handbook.

When trying to unmount rpool, it refused because /mnt/gentoo was busy, but I could find no processes using it, so I just crossed my fingers and rebooted because I had to take my kid to daycare :)


The last reboot resulted in a system booting off ZFS - yay. The only things I noted were:
1. Grub took a long time to start up. Is it because I installed grub onto each drive? Is there a way around this? It doesn't look like there are any bootflags marked for partitions since ZFS handles it all. Or is it just a consequence of having to do some Grub2/ZFS magic?

2. When shutting down, I again notice error messages about / being busy, ZFS unable to unmount it, but shutdown continues anyway. Is this a bug, should I be worried, or just not care since I have all the other ZFS coolness available.

Thanks - and thanks to both pendor and ryao for the guides.
Back to top
View user's profile Send private message
e3k
Apprentice
Apprentice


Joined: 01 Oct 2007
Posts: 187
Location: Slovakia

PostPosted: Sun Nov 24, 2013 1:59 pm    Post subject: Re: Gentoo ZFS on root - unmount at shutdown and other issue Reply with quote

tenspd137 wrote:

2. When shutting down, I again notice error messages about / being busy, ZFS unable to unmount it, but shutdown continues anyway. Is this a bug, should I be worried, or just not care since I have all the other ZFS coolness available.

i have the same unmount issue as you. did you get rid of it?
_________________
---__o__---
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum