Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(Solucionado) Dependencias chromium y las keywords.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
fellsword
n00b
n00b


Joined: 23 Jul 2012
Posts: 65

PostPosted: Wed Feb 27, 2013 4:00 am    Post subject: (Solucionado) Dependencias chromium y las keywords. Reply with quote

Saludos !!!!
Ya logre instalar correctamente gentoo :D jeje.
Bueno, pues tratando de instalar todos mis paquetes que uso en debian y slackware, me tope con chromium, donde no me deja instalar. Siempre me pide que use los keywords, pero nada.
Me estaba preguntando, es así gentoo con todos los paquetes o varios.
Ejemplo: Quiero instalar x paquete y me pide que coloque las dependencias en keywords, o en package, pero después, al actualizar el sistema o paquetes, ya no requiera de las keywords o de lo que modifique anteriormente. ¿Tendrá problemas al actualizar?

Por que, si es todo un relajo colocar y modificar las use o keywords o lo que se tenga que editar. Ya que, en gentoo, me fascino la fluidez del escritorio y paquetes, pero es de tiempo andar manteniendo.

Jeje la pregunta sería.

1) Como instalo chromium.
2) Es fácil de mantener gentoo.


Last edited by fellsword on Sat Mar 02, 2013 7:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 811

PostPosted: Wed Feb 27, 2013 6:21 pm    Post subject: Re: Dependencias chromium y las keywords. Reply with quote

fellsword wrote:
...
Ejemplo: Quiero instalar x paquete y me pide que coloque las dependencias en keywords, o en package, pero después, al actualizar el sistema o paquetes, ya no requiera de las keywords o de lo que modifique anteriormente. ¿Tendrá problemas al actualizar?
...

Depende bastante de 2 cosas:
    Lo que pongas en los archivos de configuración de portage, los package.*
    Lo que entiendas por problemas al actualizar

Por ejemplo, si en package.keywords pones que acepte las versiones en pruebas de un paquete sea cual sea su número de versión es mas probable que, en un futuro, al intentar actualizar, recibas un mensaje diciendo que no se puede actualizar uno o varios paquetes. Normalmente también tendrás información de lo que debes hacer. El otro tema es que consideres un problema el que emerge te diga que necesita que se configure algo. Si es así, me atrevo a decir que seguro que vas a tener problemas con gentoo.

fellsword wrote:
...
1) Como instalo chromium.
...

Code:
emerge chromium

Quizá te intere saber que existe una versión precompilada de chromium: chromium-bin

fellsword wrote:
...
2) Es fácil de mantener gentoo.

Muy fácil. Aqui lo explica:
http://www.gentoo.org/doc/es/handbook/handbook-x86.xml?part=2&chap=1#doc_chap3
Back to top
View user's profile Send private message
fellsword
n00b
n00b


Joined: 23 Jul 2012
Posts: 65

PostPosted: Wed Feb 27, 2013 10:21 pm    Post subject: Reply with quote

Saludos y gracias por responder :D

Es que busco un sistema linux estable, a nivel master jaja. Donde no tenga que andar reinstalando el sistema, me puso a pensar gentoo, ya que es rolling, se supone, no tengo que andar reinstalando el sistema.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9818
Location: Córdoba (Spain)

PostPosted: Wed Feb 27, 2013 10:59 pm    Post subject: Reply with quote

fellsword wrote:
Saludos !!!!
Ya logre instalar correctamente gentoo :D jeje.
Bueno, pues tratando de instalar todos mis paquetes que uso en debian y slackware, me tope con chromium, donde no me deja instalar. Siempre me pide que use los keywords, pero nada.
Me estaba preguntando, es así gentoo con todos los paquetes o varios.


Para responderte necesito más datos sobre tu instalación. ¿Qué arquitectura usas? ¿Rama estable, inestable, o estable con algunos paquetes de la inestable?

En todo caso, ¿por qué no puedes instalar chromium? ¿Qué mensaje de error concreto aparece y qué comando usas *exáctamente* para instalarlo?

Quote:
Ejemplo: Quiero instalar x paquete y me pide que coloque las dependencias en keywords, o en package, pero después, al actualizar el sistema o paquetes, ya no requiera de las keywords o de lo que modifique anteriormente. ¿Tendrá problemas al actualizar?


Es dificil seguir lo que quieres decir aquí. Si te refieres a que estás usando USE o ACCEPT_KEYWORDS en la línea de comandos, ten en cuenta que todo eso no se guardará. Si quieres hacer los cambios en tus USE flags o en tus keywords permanente, tendrás que hacerlos en make.conf o en /etc/portage/*.

Quote:
Por que, si es todo un relajo colocar y modificar las use o keywords o lo que se tenga que editar. Ya que, en gentoo, me fascino la fluidez del escritorio y paquetes, pero es de tiempo andar manteniendo.


Como no sé que tipo de instalación tienes solo puedo hacer conjeturas. En un sistema que use la rama estable, ningún paquete en portage va a requerir que instales paquetes de la inestable, y por tanto no te va a pedir que añadas keywords.

En un sistema que use la rama inestable, la variable ACCEPT_KEYWORDS en tu make.conf indica al sistema que acepte *TODOS* los paquetes de la inestable, así que en principio tampoco debería ser necesario añadir keywords alguno, ya que todos los paquetes de tu sistema tienen el keywords de inestable (~amd64, ~x86, o el que sea).

Por tanto, eso solo ocurre cuando, en un sistema de la rama estable (x86, amd64...) instalamos un paquete de la inestable. En ese caso el paquete en cuestión puede requerir versiones de la inestable para algunas librerías u otros componentes. También puede ocurrir si usas overlays, ya que los ebuilds de los overlays no están controlados por Gentoo, y pueden tener requisitos que quizás estén en la inestable, o incluso enmascarados (o que ni siquiera estén en portage...).

Quote:

1) Como instalo chromium.


En un sistema estable, simplemente "emerge www-client/chromium". Luego mejor te vas a tomarte un café o algo, porque tardará un poco.

Quote:
2) Es fácil de mantener gentoo.


Esto es algo completamente subjetivo. Gentoo requiere más intervención manual que cualquier otra distro, aunque, como en todo, hay una mecánica y un procedimiento para casi todo, una vez que lo asimilas, claro. El grado de dificultad depende de varios parámetros.

Si escoges la rama estable, normalmente, las actualizaciones deberían reducirse a un "emerge -auDvN world", luego revdep-rebuild, emerge --ask --depclean y etc-update, si procede. Algunos paquetes particulares necesitan de configuración extra, lo cual quiere decir que siempre cuando emerge termine deberás revisar la salida para ver si algo especial requiere de tu atención (una nueva versión de gcc, un nuevo kernel, algún servidor que requiera ser reconfigurado...).

La inestable tiene actualizaciones más frecuentes, y de vez en cuando, más dolorosas (aunque en los últimos años esto se ha suavizado muchísimo).

Pero los sistemas más complicados de mantener, por norma general, son aquellos en los que se mezcla la rama estable con la inestable, precisamente porque hay que estar pendiente de desenmascarar dependencias y puede haber embrollos complicados de trazar a la hora de actualizar.

En cualquier caso, el nivel de complejidad viene también muy condicionado por el software que tú utilices (obviamente no requiere la misma atención actualizar un juego de tetris que un servidor apache en un sitio web de producción).

La arquitectura también es determinante. x86 y amd64 son las mayoritarias, así que tienen más usuarios reportando bugs y más desarrolladores arreglándolos.


fellsword wrote:
Saludos y gracias por responder :D

Es que busco un sistema linux estable, a nivel master jaja. Donde no tenga que andar reinstalando el sistema, me puso a pensar gentoo, ya que es rolling, se supone, no tengo que andar reinstalando el sistema.


Gentoo puede ser tan estable o inestable como tú lo hagas. Aunque quizás debas investigar un poco más por ahí. Hay distros que son rolling-release. Ahora mismo me viene la edición de Mint basada en Debian, la cual conozco de primera mano y está bastante pulida, pero seguro que hay más.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
fellsword
n00b
n00b


Joined: 23 Jul 2012
Posts: 65

PostPosted: Wed Feb 27, 2013 11:30 pm    Post subject: Reply with quote

Saludos :D
1) Uso stable, amd64.
2) Trate de instalar chromium, pero quiere que use las keywords, usando --autounmask-write, dispatch. Lo hice y nada.
3) Por lo que veo en Gentoo, las USEs, package.use, package.accept_keywords, es indispensable, para la instalación y actualización. Cual me desagrada.
4) No logre instalar chromium con emerge www-client/chromium ni emerge chromium.
5) El error, pues como elimine gentoo y lo estoy reinstalando, por que requería hacer una tarea y slackware ya tiene instalado calligra.
6) Digo ¿Si es fácil de mantener gentoo? por ser rolling. Use arch 4 años y ningún error, hasta hace tiempo donde salieron 3 paquetes que hacían inservible el sistema. Desde ahí, no me gustan las Rolling.
7) No me gusta combinar las ramas stable con testing, prefiero esperar.

Considere gentoo por tener un control total sobre el sistema y se adapta muy bien a sus paquetes. Pero todo lo bueno cuesta jaja.

Aunque también considero mucho a slackware, pero la falta manejo de dependencias, me pone a dudar.

Jajaja realmente no me gustan las distros basadas en debian, no las veo integradas a sus paquetes y menos a KDE. Aunque por algo son las mas populares en Linux.

Ahora estoy instalando otra vez gentoo.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9818
Location: Córdoba (Spain)

PostPosted: Thu Feb 28, 2013 12:41 am    Post subject: Reply with quote

fellsword wrote:
2) Trate de instalar chromium, pero quiere que use las keywords, usando --autounmask-write, dispatch. Lo hice y nada.
3) Por lo que veo en Gentoo, las USEs, package.use, package.accept_keywords, es indispensable, para la instalación y actualización. Cual me desagrada.


Esto es algo con lo que tendrás que aprender a lidiar si de verdad quieres usar Gentoo. Mucha gente viene a GEntoo pensando que su máquina va a funcionar un 200% más rápida. Si es tu caso, desiste antes de perder más tiempo. Eso solo lo conseguirás comprando un ordenador más rápido. El punto principal de Gentoo es el nivel de personalización que puedes conseguir en tu distro final, y eso requiere ensuciarse las manos un poco.

Lo que tu llamas keywords son en realidad USE flags, y se usan para controlar funcionalidades de determinados paquetes. En Gentoo los "keywords" son otra cosa bien distinta.

Las USE flags además tienen un grandísimo impacto sobre las dependencias que se instalan, y determinado paquete X puede requerir que determinada librería Y está compilada con algún USE flag particular. --autounmask-write intenta adivinar un poco, pero no es perfecto por lo que leo en los foros, la verdad, ni lo he probado. Llevo más de una década controlando mis USE flags a mano y me cuesta cambiar los viejos hábitos :lol:

Quote:
4) No logre instalar chromium con emerge www-client/chromium ni emerge chromium.


En ese caso quizás deberías haber empezado el hilo por ahí. Si vuelves a intentarlo, pega aquí la salida de error de emerge, un buen trozo del final y no solo las últimas líneas, que son basura.

Gentoo no es ni fácil ni difícil. Pero para el usuario acostumbrado a otro tipo de distribuciones es simplemente... diferente. La cantidad de opciones puede parecer abrumadora, pero es por eso que existen los perfiles desktop, que son los que tu deberías estar usando. Eso debería darte un conjunto saludable de USE flags con el que empezar. Todo el proceso para seleccionar tu perfil de portage está en el handbook, como el resto de pasos para la instalación. :)
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
fellsword
n00b
n00b


Joined: 23 Jul 2012
Posts: 65

PostPosted: Thu Feb 28, 2013 2:03 am    Post subject: Reply with quote

Jejejeje Si lo entiendo, de echo tengo una buena pc :D. Pero comparando Gentoo con Debian, Arch, Chakra, Slackware, openSUSE, Fedora. En gentoo trabaja mil veces mejor.

UHHHHHHHHHHHHHHHHHHHHHHHHHHHHH
Ya se instalo :D, Agregue en las USEs de make.conf "icu" y quite lo de chromium de package.use y keywords.

Otra pregunta.
En el proceso de compilación, si un paquete no lo compila bien, por x razón y se resuelve tratando de hacer el proceso de compilación otra vez
¿Como puedo hacerlo? Ya que la primera vez que instale gentoo, tuve un problema con grub, en este con solo hacer "emerge grub" otra vez se soluciono.

Y ahora tuve un problema con vbetool en la instalación de kde-meta, pero logre solucionarlo. Como no sabia, que si coloco ACCEPT_KEYWORDS:"~x86" en make.conf, instalaba los paquetes en testing, después actualice el sistema y me di cuenta, cancele la actualización, quite ACCE***** y actualice el sistema.
Trate de nuevo y listo, termino la instalacion de kde-meta y con los paquetes stable.

Ahora que estoy aprendiendo a usar Gentoo, pues e borrado y agregado paquetes a lo bestia, no se a roto jejeje, realmente es de aplauso. En debian pfff se rompe al desinstalar iceweasel jaja. Me quedare en esta distro :D.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9818
Location: Córdoba (Spain)

PostPosted: Thu Feb 28, 2013 9:56 am    Post subject: Reply with quote

fellsword wrote:
En el proceso de compilación, si un paquete no lo compila bien, por x razón y se resuelve tratando de hacer el proceso de compilación otra vez
¿Como puedo hacerlo? Ya que la primera vez que instale gentoo, tuve un problema con grub, en este con solo hacer "emerge grub" otra vez se soluciono.


Cada fallo es diferente. No hay un proceso estándar que funcione para el 100% de los casos. Con el tiempo se aprende a identificar los fallos. Es importante leer la salida del error, y, si no es muy clara, echar un vistazo también en los logs de compilación (en la salida de error de emerge sale la ruta a los archivos de logs, casi al final).

Hay muchas causas por las que una compilación puede fallar, y unas son más fáciles de arreglar que otras.

En cualquier caso, si eso pasa, lo mejor es que abras un hilo nuevo para cada problema concreto y trataremos de ayudarte de la mejor forma posible. :)

Quote:

Y ahora tuve un problema con vbetool en la instalación de kde-meta, pero logre solucionarlo. Como no sabia, que si coloco ACCEPT_KEYWORDS:"~x86" en make.conf, instalaba los paquetes en testing, después actualice el sistema y me di cuenta, cancele la actualización, quite ACCE***** y actualice el sistema.
Trate de nuevo y listo, termino la instalacion de kde-meta y con los paquetes stable.


Es posible que alguno de los problemas que has tenido haya surgido a causa de esto. Si en algún momento has tenido el keywords ~x86, todos los paquetes que hayas instalado durante ese lapso de tiempo (dependencias incluídas) habrán sido tomados de testing. Has tenido la suerte de que no han sido paquetes de sistema, porque el downgrade de glibc (por poner un ejemplo) normalmente resulta en un sistema inusable, obligando a restaurar glibc a mano o a reinstalar todo el SO.

Hay que tener cuidado con eso.

Quote:
Ahora que estoy aprendiendo a usar Gentoo, pues e borrado y agregado paquetes a lo bestia, no se a roto jejeje, realmente es de aplauso. En debian pfff se rompe al desinstalar iceweasel jaja. Me quedare en esta distro :D.


Bienvenido. :)
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
fellsword
n00b
n00b


Joined: 23 Jul 2012
Posts: 65

PostPosted: Fri Mar 01, 2013 3:38 am    Post subject: Reply with quote

Gracias.
Estaré viendo los overlays, quiero aportar en gentoo Saludos :D

E estado notando algo.
JEjeje me gusto el logo de la vaca en libreoffice, pero tiene un bug, cuando edito.

Bla bla bla bla ble ble ble bli bli bli blu blu blu.

Y quiero copiar y pegar esto "bum bum bum bam bam bam". a la frase anterior, se borra lo anterior y solo queda lo nuevo. Como si sobre montara a lo anterior y solo queda.

bum bum bum bam bam bam

O se ve una linea negra horizontal.

No se si sea la versión.
Back to top
View user's profile Send private message
cameta
l33t
l33t


Joined: 04 Aug 2004
Posts: 695

PostPosted: Sat Mar 02, 2013 7:14 pm    Post subject: Reply with quote

Quote:
Trate de instalar chromium, pero quiere que use las keywords,

Chromium esta en blanco.
http://packages.gentoo.org/package/www-client/chromium?full_cat
No se que significa exactamente pero sin duda no acaba de funcionar.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
fellsword
n00b
n00b


Joined: 23 Jul 2012
Posts: 65

PostPosted: Sat Mar 02, 2013 7:18 pm    Post subject: Reply with quote

Gracias, pero ya logre instalar chromium, en las USEs coloque "icu" y listo. Sin editar nada mas.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum