Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Gelöst]Problem mit Update
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Hanisch
Apprentice
Apprentice


Joined: 21 Mar 2011
Posts: 186

PostPosted: Tue Feb 26, 2013 3:15 pm    Post subject: [Gelöst]Problem mit Update Reply with quote

Hallo,
ich habe ein Problem mit dem Update des Systems.
Code:
# eix-test-obsolete
...
Folgende installierte Pakete sind nicht in der Datenbank:
[U] dev-libs/qjson (0.7.1-r1@25.01.2013 -> 0.8.1): A library for mapping JSON data to QVariant objects
[U] media-plugins/gst-plugins-gio (0.10.35(0.10)@25.01.2013 -> 0.10.36(0.10)^t): plugin for gstreamer
[U] www-plugins/adobe-flash (11.2.202.261@26.01.2013 -> 11.2.202.270^ms): Adobe Flash Player
3 Treffer.

gentoo_VM ~ # emerge -av www-plugins/adobe-flash

 * IMPORTANT: 9 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "www-plugins/adobe-flash" have been masked.
!!! One of the following masked packages is required to complete your request:
- www-plugins/adobe-flash-11.2.202.270::gentoo (masked by: AdobeFlash-11.x license(s))
A copy of the 'AdobeFlash-11.x' license is located at '/usr/portage/licenses/AdobeFlash-11.x'.

- www-plugins/adobe-flash-10.3.183.61::gentoo (masked by: ~x86 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Wie behebe ich dieses Probllem?

Gruß
Ch. Hanisch


Last edited by Hanisch on Wed Feb 27, 2013 2:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
CaptainHero
n00b
n00b


Joined: 27 Nov 2009
Posts: 50
Location: Germany

PostPosted: Tue Feb 26, 2013 4:13 pm    Post subject: Reply with quote

Sieht nach einem Linzenzproblem aus.

http://www.gentoo.de/doc/de/handbook/handbook-x86.xml?part=2&chap=1#doc_chap4

Grüße
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3961
Location: Irgendwo im Nirgendwo

PostPosted: Tue Feb 26, 2013 4:14 pm    Post subject: Reply with quote

Steht doch da:
man emerge -> MASKED PACKAGES -> LICENSE -> man make.conf -> ACCEPT_LICENSE
(license sollte aus dem Kontext klar werden)
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Hanisch
Apprentice
Apprentice


Joined: 21 Mar 2011
Posts: 186

PostPosted: Wed Feb 27, 2013 11:41 am    Post subject: Reply with quote

franzf wrote:
Steht doch da:
man emerge -> MASKED PACKAGES -> LICENSE -> man make.conf -> ACCEPT_LICENSE
(license sollte aus dem Kontext klar werden)

Tut mir leid, aber ich komme damit nicht klar.
Ich habe in /etc/portage/package.license
die Zeile auf
Code:
www-plugins/adobe-flash-11.x

geändert, aber es tut sich nichts.
Was ich in /etc/portage/make.conf unter
ACCEPT_LICENSE="
eintragen soll, weiß ich leider nicht.
Ich habe dort
Code:
ACCEPT_LICENSE="* -@EULA"

stehen.


Wo muß ich noch was einstellen?

Gruß
Ch. Hanisch
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2298
Location: Germany

PostPosted: Wed Feb 27, 2013 1:02 pm    Post subject: Reply with quote

Ändere die Zeile in der
/etc/portage/package.license
zu
Code:
www-plugins/adobe-flash AdobeFlash-11.x
Damit akzeptierst du die von Adobe geforderte Lizenz für das adobe-flash Paket.
Back to top
View user's profile Send private message
Hanisch
Apprentice
Apprentice


Joined: 21 Mar 2011
Posts: 186

PostPosted: Wed Feb 27, 2013 2:35 pm    Post subject: Reply with quote

Josef.95 wrote:
Ändere die Zeile in der
/etc/portage/package.license
zu
Code:
www-plugins/adobe-flash AdobeFlash-11.x
Damit akzeptierst du die von Adobe geforderte Lizenz für das adobe-flash Paket.

Ok. - Danke, das war die Lösung.

Gruß
Ch. Hanisch
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum