Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[libstdc++] Problema con librería
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Thu Feb 14, 2013 9:03 pm    Post subject: [libstdc++] Problema con librería Reply with quote

en algunos comandos y programas como amule y sobre todo eix me da el siguiente error:

Code:
eix: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by eix)


he buscado por ahí y se supone que es por una actualización de gcc, cosa que no es

Code:
 * sys-devel/gcc

     Tue Jun 15 23:03:35 2010 >>> sys-devel/gcc-4.4.3-r2
     Wed Jun 16 00:58:39 2010 >>> sys-devel/gcc-4.4.3-r2
     Wed Jun 16 02:48:49 2010 >>> sys-devel/gcc-4.4.3-r2
     Sat Jun 19 17:53:58 2010 >>> sys-devel/gcc-4.4.3-r2
     Sat Jul 10 12:57:09 2010 >>> sys-devel/gcc-4.4.3-r2
     Sat Oct 23 18:13:06 2010 >>> sys-devel/gcc-4.4.4-r2
     Wed Dec 29 03:20:37 2010 >>> sys-devel/gcc-4.4.4-r2
     Sat Mar 26 11:15:09 2011 >>> sys-devel/gcc-4.4.5
     Sat Mar 26 18:03:24 2011 >>> sys-devel/gcc-4.4.5
     Sat Jun 25 00:14:04 2011 >>> sys-devel/gcc-4.4.5
     Sat Jun 25 10:28:49 2011 >>> sys-devel/gcc-4.4.5
     Tue Sep 20 22:54:32 2011 >>> sys-devel/gcc-4.5.3-r1
     Sat Nov  5 18:01:43 2011 >>> sys-devel/gcc-4.5.3-r1
     Tue Nov 15 18:16:03 2011 >>> sys-devel/gcc-4.5.3-r1
     Tue Dec  6 22:06:32 2011 >>> sys-devel/gcc-4.5.3-r1
     Thu Feb 23 21:58:21 2012 >>> sys-devel/gcc-4.5.3-r2
     Sun Mar  4 14:07:49 2012 >>> sys-devel/gcc-4.5.3-r2
     Sun Mar  4 21:35:46 2012 >>> sys-devel/gcc-4.5.3-r2
     Mon Mar  5 03:23:30 2012 >>> sys-devel/gcc-4.5.3-r2
     Mon Mar  5 19:26:47 2012 >>> sys-devel/gcc-4.5.3-r2
     Thu Apr  5 07:50:29 2012 >>> sys-devel/gcc-4.5.3-r2
     Tue Aug 21 21:49:16 2012 >>> sys-devel/gcc-4.5.4
     Thu Sep  6 22:03:04 2012 >>> sys-devel/gcc-4.5.4
     Sat Nov  3 21:49:56 2012 >>> sys-devel/gcc-4.5.4
     Thu Nov 22 17:59:52 2012 >>> sys-devel/gcc-4.5.4
     Wed Jan  9 10:24:03 2013 >>> sys-devel/gcc-4.6.3
     Sat Jan 19 19:24:09 2013 >>> sys-devel/gcc-4.6.3
     Thu Jan 24 17:55:35 2013 >>> sys-devel/gcc-4.6.3
     Sun Feb  3 21:42:41 2013 >>> sys-devel/gcc-4.6.3
     Mon Feb  4 22:08:31 2013 >>> sys-devel/gcc-4.6.3
     Fri Feb  8 16:40:04 2013 >>> sys-devel/gcc-4.6.3


he probado a usar fix_libtool_files.sh

Code:
# fix_libtool_files.sh 4.6.3
 * Scanning libtool files for hardcoded gcc library paths...
 *   [1/13] Scanning /lib ...
 *   [2/13] Scanning /usr/lib ...
 *   [3/13] Scanning /usr/x86_64-pc-linux-gnu/lib ...
 *   [4/13] Scanning /lib32 ...
 *   [5/13] Scanning /lib64 ...
 *   [6/13] Scanning /usr/games/lib ...
 *   [7/13] Scanning /usr/games/lib32 ...
 *   [8/13] Scanning /usr/games/lib64 ...
 *   [9/13] Scanning /usr/lib32 ...
 *   [10/13] Scanning /usr/lib64 ...
 *   [11/13] Scanning /usr/local/lib ...
 *   [12/13] Scanning /usr/local/lib32 ...
 *   [13/13] Scanning /usr/local/lib64 ...


a ver si tenía varias versiones del gcc, pero no

Code:
 gcc-config -l
 [1] x86_64-pc-linux-gnu-4.6.3 *


creo que el problema puede estar en las librerías de 32 bits, pero no se muy bien ni como confirmarlo ni como arreglarlo

Se que hay muchos mensajes por ahí con posibles soluciones pero ... no he dado con ella aún, si me pudierais indicar o dar una pista por donde tirar, estaría genial.

Un saludico a tod@s
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"


Last edited by Theasker on Sat Mar 16, 2013 8:54 pm; edited 4 times in total
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Thu Feb 14, 2013 10:33 pm    Post subject: Re: [libstdc++] Problema con librería Reply with quote

Theasker wrote:
en algunos comandos y programas como amule y sobre todo eix me da el siguiente error:

Code:
eix: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by eix)

...

http://www.gentoo.org/doc/es/gcc-upgrading.xml

Creo que se arreglaría con:
Code:
# emerge --oneshot libtool
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Fri Feb 15, 2013 7:52 am    Post subject: Reply with quote

Se me olvidó decir que lo primero que miré fué esa guía y también hice eso, y ... varias veces.
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3748

PostPosted: Fri Feb 15, 2013 11:56 am    Post subject: Reply with quote

se soluciona si ejecutas ?

Code:
fix_libtool_files.sh 4.5.4


( o cualquiera que fuera la version del gcc antes de actualizar)

saluetes
Back to top
View user's profile Send private message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 794
Location: 127.0.0.1

PostPosted: Fri Feb 15, 2013 12:31 pm    Post subject: Reply with quote

Según el manual de GCC que decías:
Quote:

3. Solucionando problemas

libstdc++.so.6: version `GLIBCXX_3.4.15' not found

Durante las actualizaciones podría tropezarse con un error como el siguiente:

Listado de Código 3.1: GLIBCXX_x.y.z not found
cmake_bootstrap_28021_test: /usr/lib/gcc/i486-pc-linux-gnu/4.1.2/libstdc++.so.6:
version `GLIBCXX_3.4.11' not found
Esto significa que está intentando construir un paquete con una versión del GCC más antigua que el usado para construir algunas de sus librerías dependientes. ¿Recuerde cuando dijimos que el ABI C++ era compatible a futuro? Esto es cierto, pero asegura solamente que versiones más recientes (o iguales) del GCC pueden ser utilizadas para construir aplicaciones y librerías enlazadas (en comparación con la versión del GCC usado para construir esas librerías).

¿Cuáles paquetes se conocen que requieren reconstrucción?

La siguiente table lista los paquetes, que de estar instalados necesitarían ser reconstruidos y por que.

Paquete Reconstrucción requerida por ...
sys-devel/libtool la aplicación libtool usa trayectorias a las librerías internas del GCC codificadas de manera fija
dev-lang/ghc la aplicación ghc usa trayectorias a las librerías internas del GCC codificadas de manera fija


¿Has probado a recompilar los 2 paquetes que mencionan al final? Si los tienes instalados. sys-devel/libtool y dev-lang/ghc

Salu2.
_________________
Localnet
Films Localnet
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Fri Feb 15, 2013 1:39 pm    Post subject: Reply with quote

Ya lo leí, y si, recompile libtool, que si que lo tengo instalado pero no ghc ya que no lo tengo instalado.

Antes de ser otra vez pesado aqui, ya he intendado arreglarlo durante algunas semanas, no me parece correcto preguntar aquí sin haberlo intentado de las maneras que conozco, más que nada porque no me gusta molestar y porque lo consigue uno mismo se aprende más.

Gracias por la preocupación :)
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Fri Feb 15, 2013 7:12 pm    Post subject: Re: [libstdc++] Problema con librería Reply with quote

Theasker wrote:
...
Code:
eix: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by eix)

...

Mira las librerías compartidas que necesita eix:
Code:
ldd -v /usr/bin/eix

Mira de qué paquete del portage ha salido la librería que no funciona con eix
Code:
equery belongs /lib64/libstdc++.so.6

Busca las librerías libstdc++.so.6 que tu sistema podría utilizar:
Code:
/sbin/ldconfig -p | grep libstdc++
Back to top
View user's profile Send private message
cameta
l33t
l33t


Joined: 04 Aug 2004
Posts: 696

PostPosted: Fri Feb 15, 2013 8:08 pm    Post subject: Reply with quote

Prueba con un revdep-rebuild.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Sun Feb 24, 2013 6:14 pm    Post subject: Reply with quote

:), el revdep-rebuild igual lo he hecho como 20 desde que tengo el problema.

hoy he intentado hacer un emerge -e world y me ha dado error en baselayout con este error que ... parece que es del mismo tema

Code:
>> Emerging (1 of 1) sys-apps/baselayout-2.1-r1
 * baselayout-2.1.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                               [ ok ]
 * Your system profile has SYMLINK_LIB=yes, so that means you need to
 * have these paths configured as follows:
 * symlinks to 'lib64': /usr/lib
 * The ebuild will attempt to fix these, but only for trivial conversions.
 * If things fail, you will need to manually create/move the directories.

 * Converting /usr/lib from a dir to a symlink


symlinks to 'lib64': /usr/lib

Os sugiere algo eso?
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Mon Feb 25, 2013 8:55 am    Post subject: Reply with quote

El tema del symlink no tiene nada que ver. Es simplemente un aviso que te dice que ese directorio no debería existir, y que debería ser un symlink a /usr/lib64. Es un tema sobre el que se discutió mucho tiempo y al final se llegó a eso. No tiene mayor importancia y sólo quiere decir que tu instalación es antigua (lo cual es bueno :)).

Puedes hacer la conversión a mano en cualquier momento simplemente moviendo todos los archivos de /usr/lib a /usr/lib64, y luego borrando /usr/lib y creando un symlink en su lugar que apunte a /usr/lib64.

Mejor desde un livecd, o al menos en el runlevel 1. Ni que decir tiene que hay que tener copias de seguridad de todo para el improbable caso de que algo malo pase en el proceso :lol:

También puedes ignorarlo.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Mon Feb 25, 2013 11:31 am    Post subject: Reply with quote

pero eso no arreglaría el problema de libstdc++ no? :(.

Ya no se qué hacer. He hecho hasta un emerge -e world (medida desesperada como el reinicio del sistema). Se supone que esto suele ser un problema a la hora de hacer un update del gcc, pero yo no lo he hecho.

He probado a hacer un downgrade de gcc y luego volver a la versión, pero na de na, eso si cuando lo instalé me decía que el profile de gcc no era correcto. ¿puede ser este el problema?,¿puede ser problema de la actualización hace muy poco de los profiles de gentoo y que yo no tenía asignado a ninguno y lo seleccioné a amd64 desktop?

Supongo que no tendrá nada que ver y no hago na más que decir y probar tonterías, chorradas y perder el tiempo.

Gracias por el interés y un saludico
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Mon Feb 25, 2013 12:08 pm    Post subject: Reply with quote

No, como dije no tiene nada que ver.

Si los métodos convencionales no funcionan, puede que haya algo en tu instalación que no esté bien. Por ejemplo, copias de libstdc++ que no estén controladas por portage (por ejemplo si alguna vez has tenido que hacer un rescate forzoso usando binarios o algo por el estilo).

Yo miraría lo siguiente, sin ningún orden particular:

1.- primero, lo que te han dicho más arrida, la info de ldd para eix
2.- usa find en tu / para ver si hay más de una copia de eix y/o libstdc++ en tu sistema
3.- usa which para identificar que copia de eix estás corriendo, a veces hay binarios por ahí que no recordamos haber puesto
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Mon Feb 25, 2013 8:05 pm    Post subject: Reply with quote

gringo wrote:
se soluciona si ejecutas ?

Code:
fix_libtool_files.sh 4.5.4


( o cualquiera que fuera la version del gcc antes de actualizar)

saluetes


Si gringo, creo que es lo primero que hice y después recompilar libtool, he intentado todo lo que sale en las ayudas y en foros antes de molestaros por aqui :/

el ldd no lo conocía y ... es muy práctico yo usaba equery

Code:
# ldd -v /usr/bin/eix
/usr/bin/eix: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/bin/eix)
   linux-vdso.so.1 (0x00007fff7f96c000)
   libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007fb4f34ee000)
   libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libgcc_s.so.1 (0x00007fb4f32d8000)
   libc.so.6 => /lib64/libc.so.6 (0x00007fb4f2f3a000)
   libm.so.6 => /lib64/libm.so.6 (0x00007fb4f2c45000)
   /lib64/ld-linux-x86-64.so.2 (0x00007fb4f37e8000)

   Version information:
   /usr/bin/eix:
      libgcc_s.so.1 (GCC_3.0) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libgcc_s.so.1
      libstdc++.so.6 (GLIBCXX_3.4.5) => /lib64/libstdc++.so.6
      libstdc++.so.6 (GLIBCXX_3.4.9) => /lib64/libstdc++.so.6
      libstdc++.so.6 (GLIBCXX_3.4.11) => /lib64/libstdc++.so.6
      libstdc++.so.6 (CXXABI_1.3) => /lib64/libstdc++.so.6
      libstdc++.so.6 (GLIBCXX_3.4.15) => not found
      libstdc++.so.6 (GLIBCXX_3.4) => /lib64/libstdc++.so.6
      libc.so.6 (GLIBC_2.14) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.4) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.3.4) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.2.5) => /lib64/libc.so.6
   /lib64/libstdc++.so.6:
      libm.so.6 (GLIBC_2.2.5) => /lib64/libm.so.6
      ld-linux-x86-64.so.2 (GLIBC_2.3) => /lib64/ld-linux-x86-64.so.2
      libgcc_s.so.1 (GCC_4.2.0) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libgcc_s.so.1
      libgcc_s.so.1 (GCC_3.3) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libgcc_s.so.1
      libgcc_s.so.1 (GCC_3.0) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libgcc_s.so.1
      libc.so.6 (GLIBC_2.14) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.3) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.3.2) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.3.4) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.2.5) => /lib64/libc.so.6
   /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libgcc_s.so.1:
      libc.so.6 (GLIBC_2.14) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.2.5) => /lib64/libc.so.6
   /lib64/libc.so.6:
      ld-linux-x86-64.so.2 (GLIBC_2.3) => /lib64/ld-linux-x86-64.so.2
      ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2
   /lib64/libm.so.6:
      libc.so.6 (GLIBC_PRIVATE) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.2.5) => /lib64/libc.so.6


con el equery no sale nada (raro raro), aqui hay un problema fijo

Code:
# equery belongs /lib64/libstdc++.so.6
 * Searching for /lib64/libstdc++.so.6 ...


pero la versión de glibc que da error que no encuentra la tengo instalada

Code:
# emerge -vp glibc

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-libs/glibc-2.15-r3:2.2  USE="(multilib) -debug -gd (-hardened) -profile (-selinux) -vanilla" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


Code:
# /sbin/ldconfig -p | grep libstdc++
   libstdc++.so.6 (libc6,x86-64) => /lib64/libstdc++.so.6
   libstdc++.so.6 (libc6,x86-64) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6
   libstdc++.so.6 (libc6) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so.6
   libstdc++.so.5 (libc6,x86-64) => /usr/lib64/libstdc++.so.5
   libstdc++.so.5 (libc6) => /usr/lib32/libstdc++.so.5
   libstdc++.so (libc6,x86-64) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so
   libstdc++.so (libc6) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so


Code:
# which eix
/usr/bin/eix



Code:
# updatedb && locate libstdc++.so.6
/lib64/libstdc++.so.6
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6.0.16
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so.6
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so.6.0.16
/usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6
/usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6.0.14
/usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6
/usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6.0.14
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6.0.14
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6.0.14
/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6.0.16-gdb.py
/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so.6.0.16-gdb.py


Code:
# find / -name libstdc++.so.6
/lib64/libstdc++.so.6
/mnt/datos1/backup/home/theasker/.djl/jeux/supertuxkart/supertuxkart-0.6.2-linuxi486/bin/libstdc++.so.6
/usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6
/usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so.6
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6


gracias de nuevo y estas cosas ya las había mirado también aunque ... no se interpretar los resultados
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Mon Feb 25, 2013 8:08 pm    Post subject: Reply with quote

también esta noche ha acabado de hacer el emerge -e world y un montón de paquetes han dado error

Code:
The following 61 packages have failed to build or install:
 *
 *  (sys-apps/baselayout-2.1-r1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/sys-apps/baselayout-2.1-r1/temp/build.log'
 *  (media-libs/faac-1.28-r3::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-libs/faac-1.28-r3/temp/build.log'
 *  (net-misc/nx-3.5.0.15::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/net-misc/nx-3.5.0.15/temp/build.log'
 *  (app-dicts/aspell-es-1.9a::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/app-dicts/aspell-es-1.9a/temp/build.log'
 *  (app-dicts/aspell-en-6.0.0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/app-dicts/aspell-en-6.0.0/temp/build.log'
 *  (dev-util/cmake-2.8.9::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-util/cmake-2.8.9/temp/build.log'
 *  (net-misc/mediatomb-0.12.1-r2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/net-misc/mediatomb-0.12.1-r2/temp/build.log'
 *  (media-video/transcode-1.1.7::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-video/transcode-1.1.7/temp/build.log'
 *  (media-plugins/gst-plugins-ffmpeg-0.10.13-r2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/temp/build.log'
 *  (dev-lang/php-5.4.8::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-lang/php-5.4.8/temp/build.log'
 *  (x11-libs/gtk+-3.4.4::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/x11-libs/gtk+-3.4.4/temp/build.log'
 *  (xfce-base/xfce4-panel-4.10.0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/xfce-base/xfce4-panel-4.10.0/temp/build.log'
 *  (dev-python/pycairo-1.10.0-r2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/pycairo-1.10.0-r2/temp/build.log'
 *  (dev-cpp/cairomm-1.10.0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-cpp/cairomm-1.10.0/temp/build.log'
 *  (dev-python/pygtk-2.24.0-r2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/pygtk-2.24.0-r2/temp/build.log'
 *  (media-gfx/imagemagick-6.7.8.7::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-gfx/imagemagick-6.7.8.7/temp/build.log'
 *  (dev-perl/Pango-1.223.0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-perl/Pango-1.223.0/temp/build.log'
 *  (dev-cpp/pangomm-2.28.4::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-cpp/pangomm-2.28.4/temp/build.log'
 *  (dev-python/gnome-python-base-2.28.1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/gnome-python-base-2.28.1/temp/build.log'
 *  (dev-perl/gtk2-perl-1.244.0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-perl/gtk2-perl-1.244.0/temp/build.log'
 *  (x11-libs/vte-0.28.2-r204::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/x11-libs/vte-0.28.2-r204/temp/build.log'
 *  (media-video/dvdauthor-0.7.0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-video/dvdauthor-0.7.0/temp/build.log'
 *  (dev-cpp/gtkmm-2.24.2::sabayon, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-cpp/gtkmm-2.24.2/temp/build.log'
 *  (dev-python/pygtksourceview-2.10.1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/pygtksourceview-2.10.1/temp/build.log'
 *  (dev-python/libgnomecanvas-python-2.28.1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/temp/build.log'
 *  (dev-perl/gtk2-ex-formfactory-0.670.0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-perl/gtk2-ex-formfactory-0.670.0/temp/build.log'
 *  (x11-themes/gtk-engines-murrine-0.98.2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/x11-themes/gtk-engines-murrine-0.98.2/temp/build.log'
 *  (media-libs/libcanberra-0.29::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-libs/libcanberra-0.29/temp/build.log'
 *  (dev-libs/libunique-3.0.2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-libs/libunique-3.0.2/temp/build.log'
 *  (gnome-base/dconf-0.12.1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/gnome-base/dconf-0.12.1/temp/build.log'
 *  (x11-misc/xdg-user-dirs-gtk-0.9::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/x11-misc/xdg-user-dirs-gtk-0.9/temp/build.log'
 *  (gnome-extra/gucharmap-3.4.1.1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/gnome-extra/gucharmap-3.4.1.1/temp/build.log'
 *  (x11-themes/gtk-engines-unico-1.0.2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/x11-themes/gtk-engines-unico-1.0.2/temp/build.log'
 *  (net-print/foomatic-filters-4.0.17::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/net-print/foomatic-filters-4.0.17/temp/build.log'
 *  (gnome-extra/polkit-gnome-0.105::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/gnome-extra/polkit-gnome-0.105/temp/build.log'
 *  (x11-misc/notification-daemon-0.5.0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/x11-misc/notification-daemon-0.5.0/temp/build.log'
 *  (dev-python/gconf-python-2.28.1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/gconf-python-2.28.1/temp/build.log'
 *  (dev-python/gnome-vfs-python-2.28.1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/gnome-vfs-python-2.28.1/temp/build.log'
 *  (gnome-base/libgnome-2.32.1-r1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/gnome-base/libgnome-2.32.1-r1/temp/build.log'
 *  (gnome-base/libbonoboui-2.24.5::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/gnome-base/libbonoboui-2.24.5/temp/build.log'
 *  (dev-python/libbonobo-python-2.28.1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/libbonobo-python-2.28.1/temp/build.log'
 *  (gnome-base/libgnomeui-2.24.5::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/gnome-base/libgnomeui-2.24.5/temp/build.log'
 *  (dev-python/libgnome-python-2.28.1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/libgnome-python-2.28.1/temp/build.log'
 *  (gnome-base/nautilus-2.32.2.1-r2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/gnome-base/nautilus-2.32.2.1-r2/temp/build.log'
 *  (media-libs/gegl-0.1.6::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-libs/gegl-0.1.6/temp/build.log'
 *  (media-plugins/audacious-plugins-3.2.2-r1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-plugins/audacious-plugins-3.2.2-r1/temp/build.log'
 *  (net-libs/webkit-gtk-1.8.3-r200::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/net-libs/webkit-gtk-1.8.3-r200/temp/build.log'
 *  (xfce-base/thunar-1.4.0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/xfce-base/thunar-1.4.0/temp/build.log'
 *  (dev-java/swt-3.7.2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-java/swt-3.7.2/temp/build.log'
 *  (xfce-base/xfdesktop-4.10.0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/xfce-base/xfdesktop-4.10.0/temp/build.log'
 *  (sys-libs/pam-1.1.6-r2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/sys-libs/pam-1.1.6-r2/temp/build.log'
 *  (net-libs/c-client-2007f-r4::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/net-libs/c-client-2007f-r4/temp/build.log'
 *  (sys-devel/llvm-3.1-r2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/sys-devel/llvm-3.1-r2/temp/build.log'
 *  (media-libs/mesa-9.0.1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-libs/mesa-9.0.1/temp/build.log'
 *  (sys-block/thin-provisioning-tools-0.1.5-r1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/sys-block/thin-provisioning-tools-0.1.5-r1/temp/build.log'
 *  (media-libs/libvisio-0.0.23::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-libs/libvisio-0.0.23/temp/build.log'
 *  (dev-cpp/libcmis-0.2.3-r1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-cpp/libcmis-0.2.3-r1/temp/build.log'
 *  (app-text/libwps-0.2.7::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/app-text/libwps-0.2.7/temp/build.log'
 *  (dev-java/sun-jdk-1.6.0.41::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-java/sun-jdk-1.6.0.41/temp/build.log'
 *  (games-puzzle/world-of-goo-1.41-r1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/games-puzzle/world-of-goo-1.41-r1/temp/build.log'
 *  (x11-drivers/nvidia-drivers-310.32::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/x11-drivers/nvidia-drivers-310.32/temp/build.log'
 *

 * Regenerating GNU info directory index...
 * Processed 130 info files.
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.

_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Mon Feb 25, 2013 10:36 pm    Post subject: Reply with quote

El hecho de que /lib64/libstdc++.so.6 no pertenezca a ningún paquete ya debería darte una pista de por donde va el problema. Si miras la fecha de la última modificación de dicho archivo seguramente te lleves una sorpresa. Si mis sospechas son ciertas, lo único que resta es quitar ese archivo huérfano de ahí. Y luego, a pensar cómo ha podido llegar ahí, si portage no lo ha puesto...

EDITADO: Ese archivo no existe en mi sistema, pero aún así antes de borrarlo muévelo o renómbralo, por si acaso.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Mon Feb 25, 2013 10:55 pm    Post subject: Reply with quote

Después de renombrar/mover/eliminar ese /lib64/libstdc++.so.6 podrías intentar un revdep-rebuild.

Para el tema de los paquetes que han fallado con emerge -e world mira cualquiera de los log que te dicen.
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Tue Feb 26, 2013 8:13 am    Post subject: Reply with quote

he renombrado la librería a .bak, y al hacer un revdep-rebuild ha dado error al compilar, aunque los paquetes no tenían nada que ver con libstdc
Code:

Calculating dependencies... done!
[ebuild   R    ] media-plugins/gst-plugins-ffmpeg-0.10.13-r2:0.10  USE="orc" 0 kB
[ebuild   R    ] net-misc/mediatomb-0.12.1-r2  USE="exif ffmpeg inotify javascript mp4 taglib thumbnail -debug -lastfm -libextractor -mysql" 0 kB
[ebuild   R    ] media-video/transcode-1.1.7  USE="X a52 aac alsa dvd iconv jpeg mjpeg mmx mp3 mpeg ogg oss sdl sse sse2 truetype vorbis x264 xml xvid -3dnow (-altivec) -dv -imagemagick -lzo (-nuv) (-pic) -postproc -quicktime -theora -v4l" 0 kB
[ebuild   R    ] media-plugins/audacious-plugins-3.2.2-r1  USE="aac alsa cdda cue ffmpeg flac gtk lame libnotify mp3 nls oss sdl vorbis wavpack -adplug -bs2b -fluidsynth -gnome -gtk3 -ipv6 -jack -libsamplerate -midi -mms -mtp -pulseaudio -scrobbler -sid -sndfile" 1,854 kB

Total: 4 packages (4 reinstalls), Size of downloads: 1,854 kB
 * Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild.


Code:
 # ldd -v /usr/bin/eix
   linux-vdso.so.1 (0x00007fffbafff000)
   libstdc++.so.6 => not found
   libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libgcc_s.so.1 (0x00007f785370a000)
   libc.so.6 => /lib64/libc.so.6 (0x00007f785336c000)
   /lib64/ld-linux-x86-64.so.2 (0x00007f7853920000)

   Version information:
   /usr/bin/eix:
      libgcc_s.so.1 (GCC_3.0) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libgcc_s.so.1
      libstdc++.so.6 (GLIBCXX_3.4.5) => not found
      libstdc++.so.6 (GLIBCXX_3.4.9) => not found
      libstdc++.so.6 (GLIBCXX_3.4.11) => not found
      libstdc++.so.6 (CXXABI_1.3) => not found
      libstdc++.so.6 (GLIBCXX_3.4.15) => not found
      libstdc++.so.6 (GLIBCXX_3.4) => not found
      libc.so.6 (GLIBC_2.14) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.4) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.3.4) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.2.5) => /lib64/libc.so.6
   /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libgcc_s.so.1:
      libc.so.6 (GLIBC_2.14) => /lib64/libc.so.6
      libc.so.6 (GLIBC_2.2.5) => /lib64/libc.so.6
   /lib64/libc.so.6:
      ld-linux-x86-64.so.2 (GLIBC_2.3) => /lib64/ld-linux-x86-64.so.2
      ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2


he reinstalado eix para ver y :

Code:
# eix
eix: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory


he reinstalado otra vez libtool y na

y por supuesto también otra vez más fix_libtool_files.sh

Code:
# gcc-config -l
 [1] x86_64-pc-linux-gnu-4.6.3 *
Theasker64 theasker # fix_libtool_files.sh 4.6.3
 * Scanning libtool files for hardcoded gcc library paths...
 *   [1/13] Scanning /lib ...
 *   [2/13] Scanning /usr/lib ...
 *   [3/13] Scanning /usr/x86_64-pc-linux-gnu/lib ...
 *   [4/13] Scanning /lib32 ...
 *   [5/13] Scanning /lib64 ...
 *   [6/13] Scanning /usr/games/lib ...
 *   [7/13] Scanning /usr/games/lib32 ...
 *   [8/13] Scanning /usr/games/lib64 ...
 *   [9/13] Scanning /usr/lib32 ...
 *   [10/13] Scanning /usr/lib64 ...
 *   [11/13] Scanning /usr/local/lib ...
 *   [12/13] Scanning /usr/local/lib32 ...
 *   [13/13] Scanning /usr/local/lib64 ...


EDITO: Me pongo a reinstalar gcc a ver si repara el tema, pero no creo, esto tardará un buen rato en mi dual Xeon tardaré como 80 minutos o así, palmo más, palmo menos
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Tue Feb 26, 2013 8:27 am    Post subject: Reply with quote

En mi sistema, eix enlaza a /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6, que es un symlink a /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6.0.16. Ambos son propiedad del paquete gcc, por supuesto. Si tienes dichos archivos en su sitio (lo cual es más que probable), lo que tienes que recompilar no es gcc sino eix (y todo lo que enlace con libstdc++.so.6).
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Tue Feb 26, 2013 8:32 am    Post subject: Reply with quote

eso he pensado lo primero, y es lo primero que he hecho, recompilar eix, pero nada, no ha funcionado

Code:
...
...
) app-portage/eix-0.25.5
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
Theasker64 theasker # eix
eix: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory


EDITO:
Code:
# ls -la libstd*
lrwxrwxrwx 1 root root 53 nov  2 22:55 libstdc++.so.6.bak -> /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libstdc++.so

_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Tue Feb 26, 2013 8:53 am    Post subject: Reply with quote

Hay algo mal en la configuración de tu compilador de sistema y probablemente en algún que otro sitio más. Fíjate que la versión de gcc en esa ruta no es la versión que debería ser, según todo lo que has dicho más arriba (4.5.4 frente a 4.6.3).
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Tue Feb 26, 2013 8:58 am    Post subject: Reply with quote

i92guboj wrote:
En mi sistema, eix enlaza a /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6, que es un symlink a /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6.0.16. Ambos son propiedad del paquete gcc, por supuesto. Si tienes dichos archivos en su sitio (lo cual es más que probable), lo que tienes que recompilar no es gcc sino eix (y todo lo que enlace con libstdc++.so.6).


Code:
# locate libstdc++.so.6
/lib64/libstdc++.so.6
/mnt/datos1/backup/home/theasker/.djl/jeux/supertuxkart/supertuxkart-0.6.2-linuxi486/bin/libstdc++.so.6
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6.0.16
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so.6
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so.6.0.16
/usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6
/usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6.0.14
/usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6
/usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6.0.14
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6.0.14
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/32/libstdc++.so.6.0.14
/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6.0.16-gdb.py
/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so.6.0.16-gdb.py

_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Tue Feb 26, 2013 9:02 am    Post subject: Reply with quote

i92guboj wrote:
Hay algo mal en la configuración de tu compilador de sistema y probablemente en algún que otro sitio más. Fíjate que la versión de gcc en esa ruta no es la versión que debería ser, según todo lo que has dicho más arriba (4.5.4 frente a 4.6.3).


pues no me habia fijado en la versión pero cuando hago un gcc-config -l no me sale esa versión

Code:
make[3]: *** [libgstffmpeg_la-gstffmpeg.lo] Error 1
make[3]: se sale del directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13/ext/ffmpeg'
make[2]: *** [all-recursive] Error 1
make[2]: se sale del directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13/ext'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13'
make: *** [all] Error 2
 * ERROR: media-plugins/gst-plugins-ffmpeg-0.10.13-r2 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-plugins/gst-plugins-ffmpeg-0.10.13-r2'`,
 * the complete build log and the output of `emerge -pqv '=media-plugins/gst-plugins-ffmpeg-0.10.13-r2'`.
 * The complete build log is located at '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13'
 * S: '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13'

>>> Failed to emerge media-plugins/gst-plugins-ffmpeg-0.10.13-r2, Log file:

>>>  '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/temp/build.log'
 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 * To remove temporary files, please run:
 * rm /var/cache/revdep-rebuild/*.rr
Theasker64 lib64 # gcc-config -l
 [1] x86_64-pc-linux-gnu-4.6.3 *


EDITO: Pues menudo follón hay montado, y cómo arreglo eso sin reinstalar.

NO quiero ni plantearme reinstalar después de tanto tiempo :(
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Tue Feb 26, 2013 9:11 am    Post subject: Reply with quote

Está claro que algo raro ha pasado. Como dije arriba pueden ser restos de un rescate con paquete binarios, o algúna condición extraña durante la desistalación y purga de una versión antigua de gcc. En cualquier caso el problema está ahí.

Yo movería toda la basura de gcc 4.5.x que haya quedado en /usr/lib/gcc y /usr/lib64/gcc a algún otro sitio, fuera de los directorios de sistema (a /root, por ejemplo). Luego regenera la caché de ld con esto:

Code:
$ ldconfig -v


Como root, por supuesto. Puede echar un vistazo en /etc/ld.so.cache antes y después para ver que las rutas incorrectas se han eliminado.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Tue Feb 26, 2013 9:12 am    Post subject: Reply with quote

En principio no debería ser necesario re-emerger gcc, a no ser que se haya dañado con alguno de los experimentos que hemos hecho en este hilo ;)
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Tue Feb 26, 2013 9:12 am    Post subject: Reply with quote

he hecho, esto aunque no ha servido de mucho

Code:
# fix_libtool_files.sh 4.5.4
 * Scanning libtool files for hardcoded gcc library paths...
 *   [1/13] Scanning /lib ...
 *   [2/13] Scanning /usr/lib ...
 *   [3/13] Scanning /usr/x86_64-pc-linux-gnu/lib ...
 *   [4/13] Scanning /lib32 ...
 *   [5/13] Scanning /lib64 ...
 *   [6/13] Scanning /usr/games/lib ...
 *   [7/13] Scanning /usr/games/lib32 ...
 *   [8/13] Scanning /usr/games/lib64 ...
 *   [9/13] Scanning /usr/lib32 ...
 *   [10/13] Scanning /usr/lib64 ...
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libmudflap.la ...[]
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libgfortranbegin.la ...[]
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libgomp.la ...[]
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libgfortran.la ...[]
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libsupc++.la ...[]
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/32/libmudflap.la ...[v]
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/32/libgfortranbegin.la ...[v]
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/32/libgomp.la ...[v]
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/32/libgfortran.la ...[v]
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/32/libsupc++.la ...[v]
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/32/libmudflapth.la ...[v]
 *     FIXING: /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.4/libmudflapth.la ...[]
 *   [11/13] Scanning /usr/local/lib ...
 *   [12/13] Scanning /usr/local/lib32 ...
 *   [13/13] Scanning /usr/local/lib64 ...


EDITO:
He mirado a ver a qué paquete pertenecen las librerias que tengo de la versión 4.5.4 y ... no hay resultado

Code:
# equery b /usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6
 * Searching for /usr/lib/gcc-lib/x86_64-pc-linux-gnu/4.5.4/libstdc++.so.6 ...

_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"


Last edited by Theasker on Tue Feb 26, 2013 9:19 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum