Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg (udev?) kills audio
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
reasons
n00b
n00b


Joined: 26 Mar 2009
Posts: 62

PostPosted: Sun Feb 24, 2013 11:07 pm    Post subject: Xorg (udev?) kills audio Reply with quote

Using alsa + mpd in a TTY when my system first boots I'm able to play audio just fine, but not in X. If I toggle between a X session and a TTY, the audio will play when I'm in a TTY. I was able to find out that X is trying to use the evdev driver for my USB soundcard (DigiHug USB Audio) and try to block it in xorg.conf with:

Code:

Section "InputClass"
         Identifier      "Disable USB Audio due to crash"
         MatchProduct    "FiiO DigiHug USB Audio"
         Driver          "none"
EndSection


but the problem persists.

lsusb (card in the GYROCOM device)
Code:

Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04d9:4545 Holtek Semiconductor, Inc.
Bus 002 Device 003: ID 1852:7022 GYROCOM C&C Co., LTD
Bus 002 Device 004: ID 1038:1369 Ideazon, Inc.


relevant xlorg log
Code:

# cat /var/log/Xorg.0.log | grep Audio
[   977.877] (II) config/udev: Adding input device FiiO DigiHug USB Audio (/dev/input/event4)
[   977.877] (**) FiiO DigiHug USB Audio: Applying InputClass "evdev keyboard catchall"
[   977.877] (**) FiiO DigiHug USB Audio: Applying InputClass "Disable USB Audio due to crash"



I think it might be because if first applies "evdev keyboard catchall" and then applies my config?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5401

PostPosted: Sun Feb 24, 2013 11:34 pm    Post subject: Reply with quote

Whatever your problem with sound is, it's extremely unlikely to do with /dev/input nodes (that particular one is likely simply due to something like controls on your device). Only /dev/snd nodes would matter.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2641
Location: Slovenia

PostPosted: Sun Feb 24, 2013 11:34 pm    Post subject: Reply with quote

That's not how you block devices. You use
Code:
Option "Ignore" "true"

If the catchall still interferes, then instead of putting that section into xorg.conf, put it in /usr/share/X11/xorg.conf.d/5-ignore.conf. The exact name of the file is not really relevant, it's important that it comes before 10-evdev.conf in alphanumerical order.

Edit: VoidMage has a point though. Are you in the audio group? If not, then access to sound devices is controlled by ConsoleKit, and your X session may not be properly tracked by ConsoleKit, that's why no sound there.
Back to top
View user's profile Send private message
reasons
n00b
n00b


Joined: 26 Mar 2009
Posts: 62

PostPosted: Sun Feb 24, 2013 11:57 pm    Post subject: Reply with quote

I'm in groups wheel, audio, video, and "username" so that should be fine. Updating to
Code:

Section "InputClass"
         Identifier      "Disable USB Audio due to crash"
         MatchProduct    "FiiO DigiHug USB Audio"
    Option   "Ignore" "true"
EndSection


fixes the log so it reads:
Code:

[  3566.716] (II) config/udev: Adding input device FiiO DigiHug USB Audio (/dev/input/event4)
[  3566.716] (**) FiiO DigiHug USB Audio: Ignoring device from InputClass "Disable USB Audio due to crash"


but the problem persists. Tried to create /usr/share/X11/xorg.conf.d/5-ignore.conf as well but it didn't work. To verify that was the problem I temporaly remove the 10-evdev.conf knowing everything else would break, but it did fix sound (just no keyboard or mouse :P) so I'll figure out what is going on with that.
Back to top
View user's profile Send private message
reasons
n00b
n00b


Joined: 26 Mar 2009
Posts: 62

PostPosted: Mon Feb 25, 2013 1:00 am    Post subject: Reply with quote

Was able to get it in the end by messing with udev. Created a new rule with
Code:

ACTION=="add|change", SUBSYSTEM=="sound", ATTR{idVendor}=="1852", OPTIONS="ignore_device"


but it isn't perfect. I have to start the system with the device unconnected and then plug it in, not sure why because "add" should be noticed at boot.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4915

PostPosted: Mon Feb 25, 2013 10:41 am    Post subject: Reply with quote

xorg has no connection what so ever to audio devices, udev might be the guilty party here but xorg isn't for sure.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum