Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udev downgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2405
Location: Edmonton, AB

PostPosted: Fri Feb 22, 2013 6:52 am    Post subject: udev downgrade Reply with quote

Is it possible to downgrade to sys-fs/udev-171-r10
I have a bank screen with Nvidia driver and would like to go back to kernel 3.1.6 but I think I need to downgrade to udev-171.
and put back in rc "udev-postmount" isn't it?
_________________
#Joseph
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2131
Location: Finland

PostPosted: Fri Feb 22, 2013 10:48 am    Post subject: Reply with quote

You don't need to downgrade udev to use 3.1.x series. 197-r8 works down to 2.6.32 (like 2.6.32.60) series.
Back to top
View user's profile Send private message
soehest
n00b
n00b


Joined: 30 Aug 2007
Posts: 12

PostPosted: Fri Feb 22, 2013 12:26 pm    Post subject: Re: udev downgrade Reply with quote

Joseph_sys wrote:
Is it possible to downgrade to sys-fs/udev-171-r10
I have a bank screen with Nvidia driver and would like to go back to kernel 3.1.6 but I think I need to downgrade to udev-171.
and put back in rc "udev-postmount" isn't it?


I am using nvidia-drivers (x11-drivers/nvidia-drivers-304.64) successfully on several machines using kernel 3.6.11 and newest stable udev (sys-fs/udev-197-r8) You may be looking at issues i do not think you should solve by going back to an old kernel unless there are other specific needs.

Best regards
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2405
Location: Edmonton, AB

PostPosted: Fri Feb 22, 2013 12:49 pm    Post subject: Re: udev downgrade Reply with quote

soehest wrote:
Joseph_sys wrote:
Is it possible to downgrade to sys-fs/udev-171-r10
I have a bank screen with Nvidia driver and would like to go back to kernel 3.1.6 but I think I need to downgrade to udev-171.
and put back in rc "udev-postmount" isn't it?


I am using nvidia-drivers (x11-drivers/nvidia-drivers-304.64) successfully on several machines using kernel 3.6.11 and newest stable udev (sys-fs/udev-197-r8) You may be looking at issues i do not think you should solve by going back to an old kernel unless there are other specific needs.

Best regards


I went back to kernel-3.1.6 and the nvidia-driever-295.75 and 304.64
both working correctly. But when I go to kernel-3.5.7 and newer
nvidia-drivers or X are not working.

I don't know if it has something to do with my graphic card:
VGA compatible controller: NVIDIA Corporation GF116 [GeForce GTS 450] (rev a1)
_________________
#Joseph
Back to top
View user's profile Send private message
soehest
n00b
n00b


Joined: 30 Aug 2007
Posts: 12

PostPosted: Sun Feb 24, 2013 12:01 am    Post subject: Re: udev downgrade Reply with quote

Joseph_sys wrote:

I went back to kernel-3.1.6 and the nvidia-driever-295.75 and 304.64
both working correctly. But when I go to kernel-3.5.7 and newer
nvidia-drivers or X are not working.

I don't know if it has something to do with my graphic card:
VGA compatible controller: NVIDIA Corporation GF116 [GeForce GTS 450] (rev a1)


Without me knowing much detail, i am guessing that perhaps the nouveau module (open source nvidia module) was included only in later kernels, and that it may be blocking the nvidia module from being loaded. You can test this by looking at loaded modules issuing the command lsmod and checking if module nouveau exists.
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2405
Location: Edmonton, AB

PostPosted: Sun Feb 24, 2013 3:46 am    Post subject: Re: udev downgrade Reply with quote

soehest wrote:
Joseph_sys wrote:

I went back to kernel-3.1.6 and the nvidia-driever-295.75 and 304.64
both working correctly. But when I go to kernel-3.5.7 and newer
nvidia-drivers or X are not working.

I don't know if it has something to do with my graphic card:
VGA compatible controller: NVIDIA Corporation GF116 [GeForce GTS 450] (rev a1)


Without me knowing much detail, i am guessing that perhaps the nouveau module (open source nvidia module) was included only in later kernels, and that it may be blocking the nvidia module from being loaded. You can test this by looking at loaded modules issuing the command lsmod and checking if module nouveau exists.


I just found out that it is better to lookup on Nvidia webpage which driver is certified to work with which card, here is the web-page:
http://www.nvidia.com/Download/index.aspx?lang=en-us

It is not important what is stabilized by Gentoo, some of the sable one should be actually mask by those who use nvidia cards as not all of them will work with every nvidia card.
In my case I just unmask the 310.32 and it is working with with kernel 3.1.6 and 3.8 (I think)
_________________
#Joseph
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum