Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia drivers not working in X
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2405
Location: Edmonton, AB

PostPosted: Fri Feb 22, 2013 1:40 pm    Post subject: Reply with quote

I've tested it all night, nvidia driver don't kernel 3.5.7 or newer. I have:
Code:
VGA compatible controller: NVIDIA Corporation GF116 [GeForce GTS 450] (rev a1)

_________________
#Joseph
Back to top
View user's profile Send private message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Fri Feb 22, 2013 2:21 pm    Post subject: <SOLVED> Nvidia drivers not working in X Reply with quote

I have the following:

Quote:

01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [Quadro NVS 4200M] (rev a1)



That is very strange :?

I followed the process as describe above, and it is working fine...
Back to top
View user's profile Send private message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Fri Feb 22, 2013 2:39 pm    Post subject: Nvidia drivers not working in X Reply with quote

Try this wiki....they talk about different drivers for different Nvidia cards...according to this wiki Nvidia still has drivers for very old (workaround) to very new cards...

http://en.gentoo-wiki.com/wiki/Nvidia#Selecting_the_nVidia_Driver_Version


According to them your card should work:
Quote:

The nvidia-drivers package supports the full range of available nVidia cards. Multiple versions are available for installation, depending on the card(s) you have.
Newer cards such as the GeForce 8, 7 and 6 series should use the newer drivers from the 200.x series.
Older cards such as GeForce FX 5 series and related Quadro FX cards require the 173.x drivers. For these cards, you should mask >=x11-drivers/nvidia-drivers-180.00 in your /etc/portage/package.mask file.
Older cards such as the GeForce 3 or GeForce 4 and related Quadro4 and some Quadro2 series require the 96.x drivers. For these cards, you should mask >=x11-drivers/nvidia-drivers-97.00 in your /etc/portage/package.mask file. This will prevent newer versions of the driver which are incompatible with your card from being installed.
Old NV2x-based cards (such as TNT, TNT2, GeForce, GeForce 2, Quadro and Quadro2) require the older 71.x drivers (such as nvidia-drivers-71.86.01). For these cards, you should mask >=x11-drivers/nvidia-drivers-87.00 in /etc/portage/package.mask.


This wiki helped me alot. :lol:
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1167

PostPosted: Fri Feb 22, 2013 2:53 pm    Post subject: Reply with quote

my Ubuntu-12.10 installation runs

xorg-server-1.13.0
nvidia-310.14
linux-3.5.7.x - canonical maintained LTS
( see bug https://bugs.gentoo.org/show_bug.cgi?id=458384 )

Your gpu chip should be supported using newer nvidia-drivers:
http://www.nvidia.com/object/linux-display-amd64-310.32-driver.html
click "supported products"
_________________
fun2gen2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum