Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Help with dhcpd.conf
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
machspeed
n00b
n00b


Joined: 21 Aug 2012
Posts: 9

PostPosted: Thu Feb 14, 2013 4:40 am    Post subject: [SOLVED] Help with dhcpd.conf Reply with quote

I'm having problems with my dhcpd config file and wonder if anyone can spot the problem because I can't.

Section of config with problem
Code:
host node2 {
    hardware ethernet 00:0D:87:56:10:94;
    fixed-address 172.16.1.2;
    server-name "bundaleer";
    filename “pxelinux.0”;
}


First error given
Code:
/etc/dhcp/dhcpd.conf line 24: semicolon expected.
    filename


When I comment out the filename line dhcpd launches fine. On an older version of dhcpd this config has no issues.

DHCP Server 4.1-ESV-R4


Last edited by machspeed on Sat Feb 16, 2013 9:21 am; edited 1 time in total
Back to top
View user's profile Send private message
PabloEsc
n00b
n00b


Joined: 24 Dec 2009
Posts: 39

PostPosted: Thu Feb 14, 2013 6:18 am    Post subject: Reply with quote

I'm not sure if it's not a "paste in forums" problem but " differs from server-name and filename.
Maybe You copied this line from some website and pasted chars which resemble quotation marks but they're not quotation marks.
Back to top
View user's profile Send private message
machspeed
n00b
n00b


Joined: 21 Aug 2012
Posts: 9

PostPosted: Sat Feb 16, 2013 9:17 am    Post subject: Reply with quote

Not likely. I wrote this entire config myself from scratch...

EDIT: Sorry, after I commented I noticed what you meant. I backspaced the old quotes and readded them and they were different. This config now works, thanks :)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32026
Location: 56N 3W

PostPosted: Sat Feb 16, 2013 9:52 am    Post subject: Reply with quote

machspeed,

It looks like I had a problem there too
Code:
host mediaplayer {

        # the setup for our diskless system
        hardware ethernet f4:6d:04:6f:c8:0e;
        fixed-address 192.168.100.60;
#       filename
        server-name mediaserver;
        option subnet-mask 255.255.255.0;
        option broadcast-address 192.168.100.255;
        option routers 192.168.100.253;
}
but it seems to work anyway.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
machspeed
n00b
n00b


Joined: 21 Aug 2012
Posts: 9

PostPosted: Sun Feb 17, 2013 1:07 am    Post subject: Reply with quote

NeddySeagoon

The filename option specifies the file to boot. In mine this is the pxelinux boot kernel which then PXE takes over. You haven't specified a file there I don't know if this is because it just isn't working or because it's sensitive.

If you have specified - filename "bootfile";
and your tftpd is pointed correctly to where bootfile is, then this should work.

Something to note: I noticed with Gentoo's tftpd I had to link the location of my bootfiles to where tftpboot is. I think I used "ln -s /media/diskless /var/tftpboot" after removing the tftpboot directory first. I had to do this because editing /etc/conf.d/tftpd file (whichever it was) wouldn't point to the directory I specified.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32026
Location: 56N 3W

PostPosted: Sun Feb 17, 2013 1:13 pm    Post subject: Reply with quote

machspeed,

The filename is not sensitive, it was commented out to get dhcpd to start.
A filename entry is not required.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
machspeed
n00b
n00b


Joined: 21 Aug 2012
Posts: 9

PostPosted: Wed Feb 27, 2013 3:12 am    Post subject: Reply with quote

NeddySeagoon

Oh I see what you mean. I'm using diskless systems which require the filename entry. You're setup doesn't use this so you don't need it :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum