Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PulseAudio always creates /.pulse and /.pulse-cookie
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Freeky
n00b
n00b


Joined: 11 Mar 2011
Posts: 71
Location: Novosibirsk, Russia

PostPosted: Thu Nov 08, 2012 2:45 pm    Post subject: PulseAudio always creates /.pulse and /.pulse-cookie Reply with quote

PulseAudio creates /.pulse and /.pulse-cookie after reboot.
After googling I found this one:http://pulseaudio.org/ticket/315, but this bug for old pulseaudio.

I have media-sound/pulseaudio-2.1-r1 installed. I try using older version of pulseaudio like 2.0 and 1.1 but It can't help me.

Removing config files for pulseaudio and reemerging pulseaudio doesn't help me.
Back to top
View user's profile Send private message
Freeky
n00b
n00b


Joined: 11 Mar 2011
Posts: 71
Location: Novosibirsk, Russia

PostPosted: Thu Dec 13, 2012 5:31 pm    Post subject: Reply with quote

Does anyone have any ideas what could be the problem?
Back to top
View user's profile Send private message
onelove
Tux's lil' helper
Tux's lil' helper


Joined: 19 Dec 2004
Posts: 143
Location: Bielefeld, Germany

PostPosted: Tue Feb 12, 2013 6:50 pm    Post subject: Reply with quote

i have no clue. but i can confirm this issue. i have installed media-sound/pulseaudio-2.1-r1 with USE="X alsa asyncns caps dbus gdbm glib gtk ipv6 orc ssl tcpd udev webrtc-aec". besides, sound is working great for my single-user system.

anyone else?

regards
onelove
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Tue Feb 12, 2013 7:57 pm    Post subject: Reply with quote

LOL 1 !!!!

Following the link you mention, I got :
Quote:
TracError: IOError: [Errno 2] No such file or directory: '/home/lennart

This guy has got no home ! :D

LOL 2 !!!!

pulseaudio never ever put the smallest foot in my system... never !

I... get the .pulse directory and the .pulse-cookie as well... :twisted:
_________________
Back to top
View user's profile Send private message
onelove
Tux's lil' helper
Tux's lil' helper


Joined: 19 Dec 2004
Posts: 143
Location: Bielefeld, Germany

PostPosted: Tue Feb 12, 2013 10:04 pm    Post subject: Reply with quote

related to what directory? :-)

i got them in my $HOME as well.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3878
Location: Irgendwo im Nirgendwo

PostPosted: Wed Feb 13, 2013 3:22 pm    Post subject: Reply with quote

We all know that pulseaudio is "linux audio done right" (like systemd is "linux init done right" or dbus is "linux IPC done right").
And in the past pulseaudio devs often stated that problems with pulseaudio are due to bad integration by distributions. So removing the pulseaudio bug tracker was the only logical step.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
onelove
Tux's lil' helper
Tux's lil' helper


Joined: 19 Dec 2004
Posts: 143
Location: Bielefeld, Germany

PostPosted: Wed Feb 13, 2013 7:47 pm    Post subject: Reply with quote

FYI:

so i looked at the gentoo bug tracker. i found this unconfirmed bug:

https://bugs.gentoo.org/show_bug.cgi?id=438844

i will test the patch as soon as i can spare some time.

regards
onelove

edit1: removing alsasound from boot runlevel at least does not create the files under /, but in /root/ instead.
Back to top
View user's profile Send private message
Freeky
n00b
n00b


Joined: 11 Mar 2011
Posts: 71
Location: Novosibirsk, Russia

PostPosted: Thu Jul 18, 2013 6:48 am    Post subject: Reply with quote

aCOSwt wrote:

Following the link you mention, I got :
Quote:
TracError: IOError: [Errno 2] No such file or directory: '/home/lennart

This guy has got no home ! :D


You can find this site in http://web.archive.org/web/20081006093700/http://pulseaudio.org/ticket/315

I found similar bug at new home of pulseaudio bugtracker https://bugs.freedesktop.org/show_bug.cgi?id=48226

All of these bugs are marked as fixed. But right now pulseaudio creates .config at root directory not root home directory since pulseaudio-3. But It doesn't create /.pulse and /.pulse-cookie.

onelove wrote:
FYI:

so i looked at the gentoo bug tracker. i found this unconfirmed bug:

https://bugs.gentoo.org/show_bug.cgi?id=438844

i will test the patch as soon as i can spare some time.

regards
onelove

edit1: removing alsasound from boot runlevel at least does not create the files under /, but in /root/ instead.


Are you trying this patch with pulseaudio-4?
Back to top
View user's profile Send private message
Freeky
n00b
n00b


Joined: 11 Mar 2011
Posts: 71
Location: Novosibirsk, Russia

PostPosted: Sun Nov 24, 2013 7:15 am    Post subject: Reply with quote

Change this file /etc/conf.d/alsasound to
Code:
# RESTORE_ON_START:
# Do you want to restore your mixer settings?  If not, your cards will be
# muted.
# no - Do not restore state
# yes - Restore state

RESTORE_ON_START="no"

# SAVE_ON_STOP:
# Do you want to save changes made to your mixer volumes when alsasound
# stops?
# no - Do not save state
# yes - Save state

SAVE_ON_STOP="no"


And after boot I don't have /.pulse directory. Pulseaudio restores volume state independently.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum