Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Problema compilazione nvidia-drivers
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 158
Location: Rome

PostPosted: Fri Feb 08, 2013 11:11 am    Post subject: [RISOLTO] Problema compilazione nvidia-drivers Reply with quote

Ciao ragazzi il problema è questo:
Code:
emerge @module-rebuild                                                                                                                                                 | /home/mauro | 12:07 | 913 |

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-emulation/virtualbox-modules-4.2.6  USE="-pax_kernel" 0 kB
[ebuild   R    ] x11-drivers/nvidia-drivers-313.18  USE="X acpi (multilib) tools -pax_kernel" 0 kB
[ebuild   R    ] sys-power/bbswitch-0.5  0 kB
[ebuild   R    ] app-emulation/vmware-modules-271.1-r1::vmware  USE="-pax_kernel" 0 kB

Total: 4 packages (4 reinstalls), Size of downloads: 0 kB

>>> Verifying ebuild manifests
>>> Running pre-merge checks for x11-drivers/nvidia-drivers-313.18
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.7.6-gentoo/build
 * Found sources for kernel version:
 *     3.7.6-gentoo
 * Checking for suitable kernel configuration options...                                                                                                                                                    [ ok ]
>>> Starting parallel fetch
>>> Emerging (1 of 4) app-emulation/virtualbox-modules-4.2.6
>>> Emerging (2 of 4) x11-drivers/nvidia-drivers-313.18
>>> Emerging (3 of 4) sys-power/bbswitch-0.5
>>> Emerging (4 of 4) app-emulation/vmware-modules-271.1-r1 from vmware
>>> Failed to emerge x11-drivers/nvidia-drivers-313.18, Log file:
>>>  '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/temp/build.log'
>>> Installing (3 of 4) sys-power/bbswitch-0.5
>>> Installing (1 of 4) app-emulation/virtualbox-modules-4.2.6
>>> Installing (4 of 4) app-emulation/vmware-modules-271.1-r1
>>> Jobs: 3 of 4 complete, 1 failed                 Load avg: 2.74, 1.31, 1.12
 * Package:    x11-drivers/nvidia-drivers-313.18
 * Repository: gentoo
 * Maintainer: cardoe@gentoo.org jer@gentoo.org,xarthisius@gentoo.org
 * USE:        X acpi amd64 elibc_glibc kernel_linux multilib tools userland_GNU
 * FEATURES:   fakeroot preserve-libs sandbox userpriv usersandbox
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.7.6-gentoo/build
 * Found sources for kernel version:
 *     3.7.6-gentoo
>>> Unpacking source...
>>> Unpacking NVIDIA-Linux-x86_64-313.18.run to /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
 * Converting /kernel/Makefile.kbuild to use M= instead of SUBDIRS= ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
 * Preparing nvidia module
make -j5 -l4 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= ARCH=x86_64 IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/3.7.6-gentoo/build CC=x86_64-pc-linux-gnu-gcc clean module
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Errore 1
 * ERROR: x11-drivers/nvidia-drivers-313.18 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-313.18'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-313.18'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/'

 * Messages for package x11-drivers/nvidia-drivers-313.18:

 * ERROR: x11-drivers/nvidia-drivers-313.18 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-313.18'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-313.18'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/'

 * Messages for package app-emulation/virtualbox-modules-4.2.6:

 * Starting with the 3.x release new kernel modules were added,
 * be sure to load all the needed modules.
 *
 * Please add "vboxdrv", "vboxnetflt" and "vboxnetadp" to:
 * /etc/conf.d/modules


Idee? Ho provato a fare un downgrade del pacchetto credendo che fosse sbagliata qualcosa nel build ma non va comunque.


Last edited by stifler83 on Mon Feb 11, 2013 11:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
publiosulpicio
Apprentice
Apprentice


Joined: 31 Aug 2008
Posts: 150

PostPosted: Fri Feb 08, 2013 4:44 pm    Post subject: Reply with quote

Code:

ln -s /usr/src/linux/include/generated/uapi/linux/version.h /usr/src/linux/include/linux/version.h

Voilà!
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 158
Location: Rome

PostPosted: Mon Feb 11, 2013 11:59 pm    Post subject: Reply with quote

Grazie mille :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum