Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
!!! Your current profile is deprecated
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 4055
Location: india

PostPosted: Sun Feb 10, 2013 6:13 am    Post subject: !!! Your current profile is deprecated Reply with quote

Code:
localhost ramaswamy # emerge -DNuav world

!!! Your current profile is deprecated and not supported anymore.
!!! Use eselect profile to update your profile.
!!! Please upgrade to the following profile if possible:
        default/linux/x86/13.0



after today's portage sync i get this message.

this involves a lot of reinstall
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1471

PostPosted: Sun Feb 10, 2013 6:29 am    Post subject: Reply with quote

I would do what it recommends. You can save you current use flags by piping emerge --info to a text file then check to to see if you lost any important flags. You can then use you make.conf to recover them if necessary.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1565
Location: U.S.A.

PostPosted: Sun Feb 10, 2013 6:34 am    Post subject: Reply with quote

What did you have for a profile before?

I changed from default/linux/X86/10.0 to default/linux/x86/13.0 and the only thing 'emerge -uavDN world' did was reinstall a single package: dev-python/python-exec-0.2.
_________________
"We can't expect the American People to jump from Capitalism to Communism, but we can assist their elected leaders in giving them small doses of Socialism, until they awaken one day to find that they have Communism." -- Nikita Krushchev


Last edited by Bones McCracker on Sun Feb 10, 2013 6:53 am; edited 1 time in total
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2541
Location: Richmond, BC, Canada

PostPosted: Sun Feb 10, 2013 6:42 am    Post subject: Reply with quote

Just select one of the new 13.0 profiles. They are really identical to the 10.0 profiles with some other important updates like EAPI 5
There should not be any flag changes.

But to check and create a new package.use file you can use enalyze from gentoolkit.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 4055
Location: india

PostPosted: Sun Feb 10, 2013 7:05 am    Post subject: Reply with quote

first i tried to change to profile 13 gnome
it wanted to reinstall 234 packages
then i switched to 13
now reinstalling 4 packages and 6 upgrades
i did not see any news about 10 profile dropped.
recently last week it had gone through several reinstalls.
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Sun Feb 10, 2013 9:48 am    Post subject: Reply with quote

That profile switch, you know, that actually really did justify -N.

padoor wrote:
i did not see any news about 10 profile dropped.

Well, that was the news. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1565
Location: U.S.A.

PostPosted: Sun Feb 10, 2013 11:01 am    Post subject: Reply with quote

:lol:
_________________
"We can't expect the American People to jump from Capitalism to Communism, but we can assist their elected leaders in giving them small doses of Socialism, until they awaken one day to find that they have Communism." -- Nikita Krushchev
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 4055
Location: india

PostPosted: Sun Feb 10, 2013 12:42 pm    Post subject: Reply with quote

BoneKracker wrote:
:lol:


what does it mean :twisted:
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
dilfridge
Developer
Developer


Joined: 18 Sep 2010
Posts: 39
Location: Regensburg, Germany

PostPosted: Sun Feb 10, 2013 2:20 pm    Post subject: Reply with quote

The profile switch itself should not have any consequences at all on your packages (and should also not induce any rebuilds). It only adds support for new file formats within the profile directories.

Just make sure you first upgrade your portage to current stable before switching profile.

http://dilfridge.blogspot.de/2013/02/gentoo-100-to-130-profiles-upgrade.html
Back to top
View user's profile Send private message
smartass
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 189
Location: right behind you ... (you did turn around, didn't you?)

PostPosted: Sun Feb 10, 2013 4:07 pm    Post subject: Reply with quote

dilfridge wrote:


Just make sure you first upgrade your portage to current stable before switching profile.



I believe this should have been a GLEP 42 news item. I didn't know I should update portage first (a blog post certainly isn't the proper way to propagate such news) and I was wondering why I had suddenly have many blockers ad packages wanting to get ~arch.

C'mon, isn't this exactly what GLEP 42 news is for?
Code:
gentbox ~ # emerge -pvuND @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libatomic_ops-7.2d  1,234 kB
[ebuild     U ~] sci-libs/scikits-0.1-r1 [0.1] USE="-examples" PYTHON_TARGETS="python2_7%* python3_2%* -pypy1_9% -pypy2_0% -python2_5% -python2_6% -python3_1% (-python3_3)" 0 kB
[ebuild     U ~] sys-libs/timezone-data-2012j [2012f] USE="nls" 341 kB
[ebuild     U  ] x11-libs/qt-core-4.8.4-r2:4 [4.8.4:4] USE="exceptions glib iconv ssl (-aqua) -c++0x -debug -icu -pch -qt3support" 0 kB
[ebuild  N     ] media-fonts/stix-fonts-1.0.0-r1  USE="X -doc" 0 kB
[ebuild     U  ] dev-libs/boehm-gc-7.2d [7.1-r1] USE="cxx threads -static-libs%" 0 kB
[ebuild     U ~] dev-python/pycairo-1.10.0-r4 [1.10.0-r3] USE="svg xcb -doc -examples {-test}" PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% -python3_1% (-python3_3)" 0 kB
[ebuild     U ~] dev-python/six-1.2.0-r1 [1.1.0] USE="-doc {-test%}" PYTHON_TARGETS="python2_7%* python3_2%* -pypy1_9% -pypy2_0% -python2_5% -python2_6% -python3_1% (-python3_3)" 15 kB
[ebuild     U ~] dev-python/pytz-2012j [2012c] PYTHON_TARGETS="python2_7%* python3_2%* -pypy1_9% -pypy2_0% -python2_5% -python2_6% -python3_1% (-python3_3)" 210 kB
[ebuild     U ~] dev-python/xlwt-0.7.4-r1 [0.7.2] USE="-examples" PYTHON_TARGETS="python2_7%* -pypy1_9% -pypy2_0% -python2_5% -python2_6%" 112 kB
[ebuild     U ~] dev-python/pygobject-2.28.6-r53:2 [2.28.6-r52:2] USE="-examples -libffi {-test}" PYTHON_TARGETS="python2_7%* -python2_6%" 0 kB
[ebuild     U  ] www-plugins/adobe-flash-11.2.202.262 [11.2.202.261] USE="64bit (multilib) sse2check -32bit -kde (-selinux) -vdpau" 7,061 kB
[ebuild     U  ] media-gfx/exiv2-0.23-r1 [0.21.1-r1] USE="nls zlib -contrib -doc -examples -static-libs% -xmp" LINGUAS="-de -es -fi -fr -pl -ru -sk" 3,442 kB
[ebuild     U ~] dev-python/python-dateutil-2.1-r1 [2.1] USE="-examples" PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% -python3_1% (-python3_3)" 0 kB
[ebuild     U ~] dev-python/pygtk-2.24.0-r3:2 [2.24.0-r2:2] USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7%* -python2_6%" 0 kB
[ebuild     U ~] www-client/google-chrome-24.0.1312.68_p180326:stable [23.0.1271.97_p171054:stable] USE="plugins" LINGUAS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr sv sw ta te th tr uk vi zh_CN zh_TW" 35,888 kB
[ebuild     U  ] x11-libs/qt-gui-4.8.4-r1:4 [4.8.4:4] USE="accessibility cups dbus exceptions gif glib mng tiff xinerama xv (-aqua) -c++0x -debug -egl -gtkstyle -nas -nis -pch -qt3support -trace" 0 kB
[ebuild     U ~] dev-python/pyopengl-3.0.2-r1 [3.0.1] USE="-tk" PYTHON_TARGETS="python2_7%* -python2_6%" 872 kB
[ebuild   R    ] media-libs/devil-1.7.8-r1  USE="X gif jpeg lcms mng opengl png sdl sse sse2 tiff -allegro -glut -jpeg2k% -nvtt -openexr -sse3 -static-libs -xpm" 0 kB
[ebuild     U ~] dev-python/wxpython-2.8.12.1-r1:2.8 [2.8.12.1:2.8] USE="cairo opengl -doc -examples" PYTHON_TARGETS="python2_7%* -python2_6%" 0 kB
[ebuild     U ~] dev-python/matplotlib-1.2.0-r2 [1.1.1] USE="cairo excel gtk latex wxwidgets -doc -examples -fltk -gtk3% -qt4 {-test} -tk" PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% -python3_1%" 36,029 kB
[ebuild     U  ] dev-python/sphinx-1.1.3-r5 [1.1.2] USE="doc latex {-test}" PYTHON_TARGETS="python2_7%* python3_2%* (-pypy1_9) (-pypy2_0) -python2_5% -python2_6% -python3_1% (-python3_3)" 0 kB
[ebuild     U ~] sci-libs/scikits_learn-0.13-r1 [0.13] USE="-doc -examples" PYTHON_TARGETS="python2_7%* -python2_6%" 0 kB
[ebuild  N     ] media-libs/alure-1.2  USE="flac mp3 vorbis -dumb -examples -fluidsynth -sndfile -static-libs" 0 kB
[ebuild     U ~] games-util/springlobby-0.159::spring [0.147::spring] USE="sound -debug -gstreamer -libnotify (-torrent%*)" 2,743 kB

Total: 25 packages (21 upgrades, 3 new, 1 reinstall), Size of downloads: 87,942 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/matplotlib:0

  (dev-python/matplotlib-1.2.0-r2::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/matplotlib[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)] required by (sci-libs/scikits_learn-0.13-r1::gentoo, ebuild scheduled for merge)

  (dev-python/matplotlib-1.1.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-python/wxpython:2.8

  (dev-python/wxpython-2.8.12.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/wxpython-2.8.12.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/wxpython:2.8[python_targets_python2_6(-)?,-python_single_target_python2_6(-),python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/matplotlib-1.2.0-r2::gentoo, ebuild scheduled for merge)

dev-python/pygtk:2

  (dev-python/pygtk-2.24.0-r3::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/pygtk[python_targets_python2_6(-)?,-python_single_target_python2_6(-),python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/matplotlib-1.2.0-r2::gentoo, ebuild scheduled for merge)

  (dev-python/pygtk-2.24.0-r2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-python/pycairo:0

  (dev-python/pycairo-1.10.0-r3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/pycairo-1.10.0-r4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/pycairo-1.0.2[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)] required by (dev-python/pygtk-2.24.0-r3::gentoo, ebuild scheduled for merge)
    dev-python/pycairo[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_1(-)?,python_targets_python3_2(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_1(-),-python_single_target_python3_2(-)] required by (dev-python/matplotlib-1.2.0-r2::gentoo, ebuild scheduled for merge)
    >=dev-python/pycairo-1.8.4[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)] required by (dev-python/wxpython-2.8.12.1-r1::gentoo, ebuild scheduled for merge)

dev-python/pygobject:2

  (dev-python/pygobject-2.28.6-r53::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/pygobject-2.26.8-r53:2[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)] required by (dev-python/pygtk-2.24.0-r3::gentoo, ebuild scheduled for merge)

  (dev-python/pygobject-2.28.6-r52::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-python/pyopengl:0

  (dev-python/pyopengl-3.0.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/pyopengl-3.0.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/pyopengl[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)] required by (dev-python/wxpython-2.8.12.1-r1::gentoo, ebuild scheduled for merge)

sys-libs/timezone-data:0

  (sys-libs/timezone-data-2012j::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/timezone-data-2012j required by (dev-python/pytz-2012j::gentoo, ebuild scheduled for merge)

  (sys-libs/timezone-data-2012f::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
#required by dev-python/pytz-2012j, required by dev-python/matplotlib-1.2.0-r2, required by sci-libs/scikits_learn-0.13-r1, required by @selected, required by @world (argument)
=sys-libs/timezone-data-2012j ~amd64
#required by net-misc/wicd-1.7.2.4-r2[ncurses,-gtk], required by @selected, required by @world (argument)
=dev-python/pygobject-2.28.6-r53 ~amd64
#required by dev-python/python-dateutil-2.1-r1, required by dev-python/matplotlib-1.2.0-r2, required by sci-libs/scikits_learn-0.13-r1, required by @selected, required by @world (argument)
=dev-python/six-1.2.0-r1 ~amd64
#required by dev-python/matplotlib-1.2.0-r2, required by sci-libs/scikits_learn-0.13-r1, required by @selected, required by @world (argument)
=dev-python/pytz-2012j ~amd64
#required by dev-python/matplotlib-1.1.1, required by @selected, required by @world (argument)
=dev-python/python-dateutil-2.1-r1 ~amd64
#required by x11-wm/qtile-0.5-r1[-test], required by @selected, required by @world (argument)
=dev-python/pycairo-1.10.0-r4 ~amd64
#required by sci-libs/scikits_learn-0.13-r1, required by @selected, required by @world (argument)
=sci-libs/scikits-0.1-r1 ~amd64
#required by dev-python/matplotlib-1.1.1[excel], required by @selected, required by @world (argument)
=dev-python/xlwt-0.7.4-r1 ~amd64
#required by x11-misc/driconf-0.9.1-r1, required by @selected, required by @world (argument)
=dev-python/pygtk-2.24.0-r3 ~amd64
#required by @selected, required by @world (argument)
=dev-python/matplotlib-1.2.0-r2 ~amd64
#required by media-libs/libkate-0.3.7[wxwidgets], required by media-video/vlc-2.0.5[kate], required by @selected, required by @world (argument)
=dev-python/wxpython-2.8.12.1-r1 ~amd64
#required by dev-python/wxpython-2.8.12.1[opengl], required by dev-python/ipython-0.10.2[wxwidgets], required by @selected, required by @world (argument)
=dev-python/pyopengl-3.0.2-r1 ~amd64

What is this mess? As far as I can understand it, python based packages are trying to upgrade to the -r1 version, which is still ~arch.
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 4055
Location: india

PostPosted: Sun Feb 10, 2013 4:09 pm    Post subject: Reply with quote

portage upgrade availble message came up after sync in my amd64 installation and after changig profile it reinstalled 2 packages
portage upgraded and qt-gui reinstalled
it may be useflag chnges that caused the reinstallation.
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
smartass
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 189
Location: right behind you ... (you did turn around, didn't you?)

PostPosted: Sun Feb 10, 2013 4:11 pm    Post subject: Reply with quote

I'm talking mainly about those python packages, they want me to get the *-r1 version which is ~arch. Why?
Back to top
View user's profile Send private message
smartass
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 189
Location: right behind you ... (you did turn around, didn't you?)

PostPosted: Sun Feb 10, 2013 4:30 pm    Post subject: Reply with quote

Ok, after some debugging with --tree it seems most of these python packages are pulled in by matplotlib being pulled in by scikits_learn.
however, scikits_learn depends (accroding to equery graph) on any version of matplotlib with python_targets* flags. So if I understand this right, matplotlib-1.2.0-r2 is being pulled in because it uses the new python_targets stuff?
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1565
Location: U.S.A.

PostPosted: Sun Feb 10, 2013 9:00 pm    Post subject: Reply with quote

The one package I had to rebuild was also related to PYTHON_TARGETS.
_________________
"We can't expect the American People to jump from Capitalism to Communism, but we can assist their elected leaders in giving them small doses of Socialism, until they awaken one day to find that they have Communism." -- Nikita Krushchev
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum